1. jimothy508's Avatar
    I just gave it a shot with the Power A Mini Wii Controller, no luck. I tried to connect them with a few of the free Wii Remote apps available on the app market. I'm willing to pay for an app that works though. Is Optimus V the problem? Or the third party controller I'm using? Has anyone been able to make those apps work with an Optimus V? Any help would be greatly appreciated.

    Edit: Nevermind. I found the compatibility list (http://android.ccpcreations.com/wiic...-compatibility), so I'll guess I'll just steer the thread in a different direction. Does anyone know a good alternative for game pads that are compatible with this phone?
    07-15-2011 12:37 AM
  2. huchman's Avatar
    Wiimote works withe ath3nos rom. Not sure if it works with all cm7 roms or not but definitely does with ath3nos.
    I just gave it a shot with the Power A Mini Wii Controller, no luck. I tried to connect them with a few of the free Wii Remote apps available on the app market. I'm willing to pay for an app that works though. Is Optimus V the problem? Or the third party controller I'm using? Has anyone been able to make those apps work with an Optimus V? Any help would be greatly appreciated.
    07-15-2011 12:54 AM
  3. jimothy508's Avatar
    Wiimote works withe ath3nos rom. Not sure if it works with all cm7 roms or not but definitely does with ath3nos.
    Can anyone confirm this? I haven't rooted yet, I just got the phone yesterday, but I'm willing to if it means this will work. And I'm guessing the sources in this link (http://forums.androidcentral.com/opt...ad-7-12-a.html) for the stuff I need are all up to date?
    07-15-2011 01:11 AM
  4. camf3xu's Avatar
    Ya that's the rom he's talking about. And the developer will change the first post with each update. Theirs a huge upside to rooting/exploring roms, and virtually no downside.

    Just make sure you flash a custom recovery before venturing into changing your rom.
    07-15-2011 03:27 AM
  5. jimothy508's Avatar
    I went ahead and rooted. Then followed the instructions and now have ath3nos' unofficial cm7 on my phone. The first things I downloaded were Wii Controller Demo and Wiimote Controller, to test out and see if things would work now. Still no go. Bluetooth is on, WiiControllerIME is on, so what am I doing wrong?
    07-15-2011 06:49 AM
  6. tsunade2k4's Avatar
    I went ahead and rooted. Then followed the instructions and now have ath3nos' unofficial cm7 on my phone. The first things I downloaded were Wii Controller Demo and Wiimote Controller, to test out and see if things would work now. Still no go. Bluetooth is on, WiiControllerIME is on, so what am I doing wrong?
    This might sound too obvious but did you hold 1+2 on the wiimote to put it into sync mode? Wiimote Controller worked for me using AOSP but I haven't tried on ath3nos yet
    07-15-2011 10:53 AM
  7. huchman's Avatar
    Push the red button under the battery door to clear the programming and it will connect right up. I have tested it myself.
    Retorrent likes this.
    07-15-2011 11:06 AM
  8. kraven's Avatar
    What is the benefit/use of the wii remote with the phone?
    07-15-2011 12:57 PM
  9. one80oneday's Avatar
    What is the benefit/use of the wii remote with the phone?
    Addition of a controller
    07-15-2011 01:00 PM
  10. watskyhotsky's Avatar
    wii mote has been working with AOSPcm7 since a few months ago.

    its tricky to pair them, but once you do it works perfect. I use it regularly, only the phone doesnt have a kickstand so it gets awkward.
    07-15-2011 01:05 PM
  11. kraven's Avatar
    Addition of a controller
    for games and such?
    07-15-2011 01:21 PM
  12. watskyhotsky's Avatar
    for games and such?
    its a wiimote, its a gaming controller. the reason you pair it to android is to use it to control emulated games like GBA and SNES games.

    and possibly anything else that would benefit from it
    07-15-2011 01:40 PM
  13. jimothy508's Avatar
    So I've opened a whole new can of worms. I was able to root the phone, and bounced back and forth between the stock rom and ath3ros' cm7 rom. I decided to give ath3ros' cm7 rom one more shot to try the wiimote app.

    This time around after flashing, when I tried to log in to my google account for the market app, the market app started closing immediately after opening. I figured there was something wrong with gapps. So I downloaded the superuser.apk and clockworkmod.apk and installed those from SD card (via the ath3ros cm7 rom's file manager). Got back into clockworkmod, wiped everything, flashed the ath3ros rom over again, then the gapps, then the sprint to ov zip. Tried to start from square one, but upon opening the market and signing into my google account, again market started just shutting itself down immediately after opening. From there I ran the superuser and clockwordmod apk's again, got into clockworkd mod, but this time I "restored" from a stock optimus v rom I found. I still get the same problem with market.

    So now I'm stuck with a stock optimus v rom, with no access to market, and with no file manager to run apk's from. What do?

    Also, I did back everything up to an SD card with clockwordmod before I rooted, but for some reason thought it would be better to just try the stock rom instead.

    Edit: Should I be making a new thread for this? It's kinda not about the wii controller anymore.

    Edit 2: Nevermind. I found out you can just email .apk's. But I'm still having issues with market closing immediately after opening?
    07-15-2011 03:35 PM
  14. watskyhotsky's Avatar
    So I've opened a whole new can of worms. I was able to root the phone, and bounced back and forth between the stock rom and ath3ros' cm7 rom. I decided to give ath3ros' cm7 rom one more shot to try the wiimote app.

    This time around after flashing, when I tried to log in to my google account for the market app, the market app started closing immediately after opening. I figured there was something wrong with gapps. So I downloaded the superuser.apk and clockworkmod.apk and installed those from SD card (via the ath3ros cm7 rom's file manager). Got back into clockworkmod, wiped everything, flashed the ath3ros rom over again, then the gapps, then the sprint to ov zip. Tried to start from square one, but upon opening the market and signing into my google account, again market started just shutting itself down immediately after opening. From there I ran the superuser and clockwordmod apk's again, got into clockworkd mod, but this time I "restored" from a stock optimus v rom I found. I still get the same problem with market.

    So now I'm stuck with a stock optimus v rom, with no access to market, and with no file manager to run apk's from. What do?

    Also, I did back everything up to an SD card with clockwordmod before I rooted, but for some reason thought it would be better to just try the stock rom instead.

    Edit: Should I be making a new thread for this? It's kinda not about the wii controller anymore.

    Edit 2: Nevermind. I found out you can just email .apk's. But I'm still having issues with market closing immediately after opening?
    something isnt flashed right. make sure you completely wipe everything. cache, dalvik cache, system, and then do them all again just to be sure. then flash in correct order.

    re download gapps and the rom.

    i used to have small problems like this and i started to wipe 3 or 4 times everything before i flash a rom. not just once
    07-15-2011 04:24 PM
  15. jimothy508's Avatar
    something isnt flashed right. make sure you completely wipe everything. cache, dalvik cache, system, and then do them all again just to be sure. then flash in correct order.

    re download gapps and the rom.

    i used to have small problems like this and i started to wipe 3 or 4 times everything before i flash a rom. not just once
    Thanks for the tip! After emailing myself the superuser and clockworkmod apk's I restored to the restore point I made just before I rooted, that seems to have fixed everything. Except I still haven't been able to get Wii Controller to work. I'll re-download the ath3ros stuff and give it one more go.
    07-15-2011 04:50 PM
  16. jimothy508's Avatar
    I was able to get WiiMote Controller to work. I was able to see button presses on the app, and in SNESoid I was able to map buttons with the Wii remote (I can even navigate in some of the setting menus of the emulator with the D pad on the Wii controller), but when going to actual gameplay the button presses don't register. What do I do now? I'm so close!!!
    07-15-2011 05:39 PM
  17. watskyhotsky's Avatar
    I was able to get WiiMote Controller to work. I was able to see button presses on the app, and in SNESoid I was able to map buttons with the Wii remote (I can even navigate in some of the setting menus of the emulator with the D pad on the Wii controller), but when going to actual gameplay the button presses don't register. What do I do now? I'm so close!!!
    enable the wiimote as a keyboard in settings > language and keyboard, and make sure all the settings of the emulator are enabled. im sure it has an option for controlling the game with a hardware keyboard, on screen, or other, make sure its enabled.
    07-15-2011 09:40 PM
LINK TO POST COPIED TO CLIPBOARD