1. grip66's Avatar
    I've been playing with a OV that I got off ebay. The guy said it was ready to load a new rom... Not quite. It was a bit messed up. When I finally got it working ok, I found I could no longer use adb shell. I just keep getting "error: closed". In fact, all of the tools I've used that also use adb shell return the same error but most of the tools still work. At one point it did give me a message that /system/bin/sh was missing. I've flashed several roms at this point. The last thing I did was run the OV9 update with no problems but it did not fix the issue.

    An example, LGNPST seems to work fine but if I try to do an explore in ScreenCast, it errors out with an adb error. I can see the com ports in device manager with no problem.

    I've recorded all of the important numbers so at least I can recover from whatever I do to it.

    I've seen other postings where other people have run into the same situation and some people recovered by just rebooting their pc or rebooting both pc and phone. I've had no luck.

    Any ideas?
    02-28-2013 10:17 PM
  2. AndyOpie150's Avatar
    Could be you need to set up the SDK a little better.
    Do you have the Java jdk-6u41 installed with the class path to the java.exe set and the old java class path deleted?
    Do you have the path to the adb.exe set properly?
    You might need to delete the LG USB drivers and re-install.

    I have lots of info to give. Please give me more info. Is it now rooted ? What recovery? What ROM?

    Link to an easy adb setup: http://www.support-4-you.com/main/in...-tos&Itemid=57

    Link to the Java jdk-6u41

    Sent from my LG-VM670 using Android Central Forums
    02-28-2013 10:55 PM
  3. grip66's Avatar
    Hey Andy. Thanks for the reply. Well, here's the kicker. I have a working stock OV that I have no problems with. Same computer. Same cable. Same USB port. It's definitely something with the phone itself. I will be playing with it some more today. The last thing I was playing with before I realized the problem was SD cards. I'm going to see if removing the SD card makes a difference. I'll let you know what I find out.

    Thanks Again.
    03-01-2013 09:24 AM
  4. AndyOpie150's Avatar
    Could very well be a borked SD card. If it is, download "BootIt" to the computer. When you run it select yes to all prompts.
    Then put back in phone and select to erase the SD card in the storage setting. Reboot phone, then try ADB again.

    Sent from my LG-VM670 using Android Central Forums
    03-01-2013 04:46 PM
  5. grip66's Avatar
    Ok. I've reproduced it. I had gone through the "Unbricking Your Optimus V" post to get this thing working decently. Well, I did it again. I have adb after the flash to the S ROM. The rooting with optiauto-sfx.exe works fine too.

    btw. It should be noted that the instructions should tell people you have to have a functional sd card in the phone to run optiauto-sfx.exe. It apparently copies things to the sd card. Someone should update the unbricking instructions.

    Everything is fine up to this point. Now, When I flash the OV9 update from recovery, adb no longer works. Adb gives me a missing /system/bin/sh message when I try it from recovery mode and the "error: closed" message if I do it from a normal boot. Weird. I can even share the sd card and copy files to it from the PC. Everything works but adb.

    I'll try to repartition and format the sdcard just to see if that's the issue. That brings me to my next set of question which probably belong to another thread. How to partition my sd card. Is there a good thread on this? I know how to do it. I just need to know what partitions should be created and their settings. Like for moving applications to the sd card.

    03-02-2013 09:29 AM
  6. thekraven's Avatar
    When you do the ov9 update, it takes you back an unrooted state. Make sure debugging mode is on. So re-root, install busybox if needed, install custom recovery, then install a rom.
    AndyOpie150 likes this.
    03-02-2013 05:02 PM
  7. AndyOpie150's Avatar
    To root the Virgin Mobile security update ZV9 go here: http://androidforums.com/optimus-v-a...0-rooting.html
    This will install the BobZohme modified ClockworkMod recovery (VM670NH_recovery.img). It doesn't have the "fix recovery loop" option.

    The ZenGarden recovery or the Cannibal Open Touch recovery would be you best choice to flash thru the terminal emulator supplied with all Gingerbread ROM's. They both have the "fix recovery loop" option, but, the ZenGarden is the only one that will work with QTADB and ROM Manager (I use it to manage my backups. Will even make a scheduled backup if your constantly flashing new stuff).

    The MiRaGe ROM would be a good choice
    All Gingerbread ROMs for the V have Busybox pre-installed to /system/xbin. Same with su.

    Sent from my LG-VM670 using Android Central Forums
    03-03-2013 04:51 AM
  8. grip66's Avatar
    Ok. Tried the ZV9 root above. Everything seemed to have gone fine until it tested to see if the root had taken. It failed. It did install the ClockworkMod recovery which was nice. abd was still giving the same error.

    So, just for fun, I installed BobZhome's CM9 ROM. The flash went fine. It's very nice. It's much better than the stock rom. Everything works... except adb. Now, the phone doesn't event show up with "adb devices". My stock OV still works fine with adb.

    Is there something special I have to do with the CM9 ROM to make adb work? I already enabled USB debugging and enabled root for adb in the debugging menu.

    I did have one thought. Since I wiped all the important numbers out of it, maybe it needs those to work with adb. I noticed that the device name in adb is part of the NAI1 entry. I'm going to try put all of the info back into the phone and see what happens. If that doesn't work, I'm going to try to take it back to stock and see if things clear up.
    03-06-2013 06:42 PM
  9. AndyOpie150's Avatar
    You are now rooted. The Gingerbread ROM has su installed to the /system/xbin.
    To install a recovery go here: http://androidforums.com/optimus-v-a...ml#post3263770
    Step # 6.
    It doesn't hurt to read the whole thing.

    To get the Android Debug Bridge to work try these:
    1. With the phone pluged into computer go to the debugging option in phone settings. With the box checked, as fast as you can unchecked then re-check the box.

    2: With phone pluged into computer, phone off. Turn phone on.

    3: Phone on, plugged into the computer. Unplug and plug in the the phone. Do this several times until positive it isn't working.

    4, Probably won't work if you have newer computer. Phone on, computer off. Turn on computer.
    Sent from my LG-VM670 using Android Central Forums
    03-06-2013 09:00 PM

Similar Threads

  1. Rooting Issues (adb shell error: closed). Help!
    By GJOKER in forum LG Optimus S
    Replies: 8
    Last Post: 09-14-2013, 09:16 AM
  2. Verizon Messed Up my pre-order and can't fix it
    By daso in forum Verizon Galaxy S III
    Replies: 4
    Last Post: 07-10-2012, 10:58 PM
  3. Gallery Messed up; Can't fix it this time
    By BlackHawkA4 in forum Sprint Nexus S 4G Rooting, ROMs, and Hacks
    Replies: 3
    Last Post: 10-01-2011, 03:33 PM
  4. adb shell error: device not found. LG Mobile Support does not rec. device either
    By fireberd350 in forum LG Optimus S Rooting, ROMs, and Hacks
    Replies: 12
    Last Post: 05-21-2011, 05:26 PM
  5. Screwed up my keyboard, how can I fix it?
    By slvrscoobie in forum Motorola Droid X
    Replies: 12
    Last Post: 10-11-2010, 08:55 PM