1. Vladimir88's Avatar
    Hello, I have a strange problem with my Vodaone Sensation.
    When I plug it on standard htc ac 1000 ma charger it detects it as USB charger, not exceeding 500 ma. It takes up to 5 hours to charge it completely. Somethimes when I play a game, it discharges slowly... Often it opens up a menu where I can select what the connection will be used for (charge only, disk drive...) from a wall socket ))

    Can somebody help, its really annoying. Especially if I have to charge it quickly in the middle of the day.
    P.S. The phone is not rooted. I tried Samsung S4 2A charger, same problem... I tried different battery, same again...
    Thanks in advance.
    09-03-2013 05:06 PM
  2. Scott Kenyon's Avatar
    It's likely a problem with the USB port, but you should do a hard reset just to be sure. I don't think the reset will benefit you at all, but if you have to claim a warranty or something they'll ask you to do this first. You'll be able to honestly say you tried.
    09-03-2013 05:44 PM
  3. Vladimir88's Avatar
    I thought so. I will try a factory reset, but I don't expect it to solve the problem. The warranty has expired... I'll try to find out if somebody can fix it, but I think it's best for me to buy a new phone

    Thank you for the reply.
    Scott Kenyon likes this.
    09-04-2013 02:59 AM
  4. Scott Kenyon's Avatar
    Read up on your potential candidates, then go play with them. Hopefully you find the right device for you!
    09-04-2013 08:11 AM

Similar Threads

  1. Droid 3 Stuck On Dual Core Screen?
    By boovish in forum Motorola Droid 3
    Replies: 7
    Last Post: 05-14-2015, 09:25 AM
  2. HTC One GPE on T-Mobile gets stuck on EDGE
    By chrishathaway in forum HTC One Google Edition
    Replies: 10
    Last Post: 09-15-2013, 11:02 AM
  3. Replies: 13
    Last Post: 09-05-2013, 09:39 AM
  4. Replaced the screen on my Series 3 Chromebook
    By TofuTwit in forum Samsung Chromebooks
    Replies: 0
    Last Post: 09-03-2013, 04:31 PM
LINK TO POST COPIED TO CLIPBOARD