1. AC Question's Avatar
    I have a Moto X Play with android Lollipop running on it. If i turn off the vibrate function on Whatsapp settings, it does not even show me the unread message notification on the top of the screen.
    I do not want any sound or vibration notification and just want a visual notification when i receive a message.
    I have installed Nova Launcher with Tesla Unread notification and the same happens with this too. If i turn off the vibration, it does not show how many unread messages I have. If the vibration is turned on, it works fine.

    Any assistance would be appreciated.

    12-08-2015 11:17 AM
  2. Javier P's Avatar
    Hi, welcome to the forums! That's strange. I have the same phone and vibration off for WhatsApp and I get the notifications in the status bar without problem. What do you have under "Notification tone" in the whatsapp settings? Does the same problem happen with all your chats? You could try clearing cache for WhatsApp in settings - apps and then reboot. Tell us how it goes.
    12-08-2015 11:29 AM
  3. Gargeya's Avatar
    Hi Javier,

    Thanks for your note, I am the original poster above. Previously I had kept my notification tone as "none" but since seeing your note, i have changed it to "beep". I also tried clearing my cache per your note but none of this works. I still get vibrating alerts when I receive a Whatsapp message.

    12-09-2015 10:12 AM
  4. Javier P's Avatar
    Hello Sandeep, thanks for registering and welcome as a new member! Let me ask a couple of questions to try to better understand what's going on. Did Whatsapp work fine in the beginning and then started to misbehave or did you always get the same problem? Maybe there's another app at the origin of the problem. Does the problem occur with WiFi and mobile? And with all your chats?

    Also you could try to reset the Whatsapp notification settings in the overflow menu (three dots top right), then reboot your phone and see if it makes a difference.
    12-09-2015 10:52 AM
  5. Gargeya's Avatar
    Hi Javier,

    Thanks for your response. In response to your questions, Whatsapp has always been working this way, it never behaved differently. There is no difference in behaviour on Wifi or Mobile data.

    I have found a fix though and am posting it here becuase it might help someone else who has the same problem. I turned the vibration notifications for individual chats on (since i mostly use this for group conversations) while keeping the vibration notifications off for group conversations. Now it works as i want it i.e., I got a notification on the tool bar when there is a message, The tesla count tells me how many messages I have and i dont have pesky vibrations disturbing me all day.

    Thanks for your help though,
    12-17-2015 11:57 AM
  6. Javier P's Avatar
    Glad you managed to fix it and thank you for the follow up. It will definitely help other users with a similar issue.
    12-17-2015 12:06 PM

Similar Threads

  1. Get the latest Galaxy S5 security and bugfix update NOW!
    By ironass in forum Samsung Galaxy S5
    Replies: 4
    Last Post: 01-11-2016, 06:05 AM
  2. Replies: 1
    Last Post: 12-08-2015, 12:11 PM
  3. How do I hard reset my S6?
    By p4ng1t in forum Samsung Galaxy S6
    Replies: 1
    Last Post: 12-08-2015, 10:56 AM
  4. How do I take a screenshot?
    By AC Question in forum General Help and How To
    Replies: 2
    Last Post: 12-08-2015, 10:55 AM