1. Android Central Question's Avatar
    After the last update (2.18.9) I can't disable the annoying WhatsApp popup (showing on top of screen) , somehow the app override my settings config.

    I disabled notification on settings - app settings - WhatsApp messages

    But after someone send me a message and the annoying popup shows up and the settings went back to default

    Nexus 6P Android Oreo 8.1.0
    (on WhatsApp settings popup and sound are off)
    01-16-2018 09:46 PM
  2. Tim1954's Avatar
    Try to kill it from the device settings... Permissions etc...
    01-17-2018 04:08 AM
  3. dov1978's Avatar
    Have you tried changing the setting inside the app itself?
    Open WhatsApp>settings>notifications>pop up notification - turn off
    01-17-2018 05:44 AM
  4. rockshan's Avatar
    Hi there,

    I am experiencing the same issue. Tried in-app settings and Android settings. The app seems to be overriding any Android settings.

    Anyone figure out how to resolve this?
    01-18-2018 04:18 AM
  5. Javier P's Avatar
    Hi there,

    I am experiencing the same issue. Tried in-app settings and Android settings. The app seems to be overriding any Android settings.

    Anyone figure out how to resolve this?
    Have you tried in settings - notifications - WhatsApp - show silently?
    01-18-2018 07:50 AM
  6. rockshan's Avatar
    I don't see show silently as an option on the latest Android
    01-21-2018 09:46 AM
  7. moaazkhan's Avatar
    i started a thread on the same issue https://forums.androidcentral.com/as...=1#post6139636 - yes this is really annoying, im on Pixel2 and my settings keep reverting to default even after changing it multiple times. I've tried everything that people have mentioned here but nothing works. GOOGLE HELP!!!
    02-01-2018 01:12 AM
  8. Haris Bhutta's Avatar
    Change the notification setting to high. Then turn off your phones notification sound. This will result in you receiving silent whatsapp notification.
    03-03-2018 03:47 PM
  9. Johhny Tapia's Avatar
    I had the same problem. Found a solution on the other topic someone posted here.
    04-12-2018 11:27 AM
  10. Elgaran's Avatar
    I've found a fix for Whatsapp but should work with other apps too. It's all in the "app info" settings

    Tap and hold app icon
    Click on app info (little circled "i" )
    App notification
    Set priority to high on both group and message notification
    Go to Whatsapp notification settings and uncheck "use high priority notification" boxes on both categories
    You can always alter these settings according to your need. For example, you can disable sounds for group messages and keep sound for private chats.
    05-03-2018 08:20 AM
  11. urbantea's Avatar
    Hi Elgaran,

    I can't seem to do the steps you have outlined. When I hold on the icon, my only options are to remove from home screen, uninstall and "select items"

    where else can i go to set the priority??
    05-03-2018 09:23 PM
  12. Elgaran's Avatar
    Hello urbantea

    Which Android version is your phone currently running? The features I described (notification channels) were made available on 8.0 (Oreo) so please make sure you're on that version or newer. Also, not all apps have that feature.

    If you do have a supported Android version, please refer to the below link which has a detailed guide on how to make it work.

    https://www.androidpolice.com/2018/0...fication-type/

    By the way, this is what it looks like after you tap and hold the icon.

    WhatsApp annoying popup on top of screen-screenshot_20180508-110621.jpg
    05-08-2018 09:13 AM
  13. Lost Warrior's Avatar
    there is no error, and google does not do something without being able to customize its options and more referring to notifications.

    To disable the pop-up window go to "Settings> Notifications> (go down until you find whatsapp) enter> enter group notifications and message notifications> importance> select" High "(which is just sound).
    By default it is in Urgent (which is sound and pop-up window on the screen).

    I hope that is the solution that several users are looking for.
    08-27-2018 02:48 PM
  14. Coolsubzerous's Avatar
    Hi there.

    Is it the same with when I get a WhatsApp call, say from A and I don't want to hear a whatsapp notification sound that is coming in ,say from B while I'm talking on the whatsapp call with A.
    09-15-2018 09:44 AM
  15. Rohit Yeolekar's Avatar
    "
    Hello urbantea

    Which Android version is your phone currently running? The features I described (notification channels) were made available on 8.0 (Oreo) so please make sure you're on that version or newer. Also, not all apps have that feature.

    If you do have a supported Android version, please refer to the below link which has a detailed guide on how to make it work.

    https://www.androidpolice.com/2018/0...fication-type/

    By the way, this is what it looks like after you tap and hold the icon.

    Click image for larger version. 

Name:	Screenshot_20180508-110621.jpg 
Views:	4 
Size:	184.1 KB 
ID:	283873
    "

    I'm on Android 8.1 abd still don't see this option for app info! 🙄
    09-30-2018 05:32 AM
  16. Guruprasad Jayanna's Avatar
    After searching many forums found a simple solution.
    1.Go to settings
    2.Apps and Notification
    3.scroll down till you find WhatsApp where you see uninstall and force stop button
    4.Below that go-to App notifications
    5.There is a Chat section and option to turn it off
    6.Choose the annoying chat and disable the pop-up.

    NOW I DONNO HOW FEW CHATS ARE ONLY LISTED DOING HERE, BUT THIS WORKED FOR ME
    02-12-2019 01:40 AM
  17. Tunde Larsson's Avatar
    On my Samsung s9 I accidentally activated "smart pop-ups" which resulted in these frustrating little WhatsApp badges that popped up any time I got a message. I disabled this by going into ADVANCED FEATURES >> SMART POP-UP VIEW.
    03-18-2019 11:31 PM

Similar Threads

  1. how to see pics on USB stick/SD card on rca viking pro 10.1
    By Android Central Question in forum Ask a Question
    Replies: 1
    Last Post: 01-17-2018, 12:49 AM
  2. How can i know for sure if i have a hacker/stalker app on my device?
    By Android Central Question in forum Ask a Question
    Replies: 2
    Last Post: 01-16-2018, 09:34 PM
  3. Fragments on main activity not working.
    By Android Central Question in forum Ask a Question
    Replies: 0
    Last Post: 01-16-2018, 08:45 PM
  4. My LG G Stylo won't let me take it off of lock screen
    By Android Central Question in forum Ask a Question
    Replies: 0
    Last Post: 01-16-2018, 08:26 PM
  5. Locked photos on Stylo 3 plus can't open on new phone
    By Android Central Question in forum Ask a Question
    Replies: 1
    Last Post: 01-16-2018, 07:40 PM
LINK TO POST COPIED TO CLIPBOARD