1. moek's Avatar
    Hello...

    New to Android but been a Linux hacker in the past.

    Just for my Xoom Wifi. Unlocked it and rooted it. Installed boot.img from Tiamat 1.3.1 Kernel and enabled MicroSD support. However I can not see an external USB drive.

    The /usbdrive path is created and the fstab file has the right entries for both the sdcard and USB.

    I am the supplied micro USB cable that comes with the xoom and a USB Female-to-Female "gender changer".

    Does the 1.3.1 Kernel have support for an external USB drive? If not could you please point me to a version that does.

    Thanks
    04-17-2011 12:18 AM
  2. NewAge's Avatar
    Yes it supports. Either your USB is not an "OTG" cable, or the USB thumb disk, or card you are trying to read is not formatted correctly.
    04-17-2011 01:23 AM
  3. moek's Avatar
    Thanks. I do not have an OTG cable but was not aware that it could not be made by simply using the standard MicroUSB to male USB and then adding a female-female USB converter. I guess the cable must do something different than simply converting female to male.
    04-17-2011 02:31 AM
  4. Azimuthmedia's Avatar
    Yes the OTG cable is required. I just got mine, worked great. The problem is that they are hard to find. Most of us ordered one from China via Ebay, mine cost $4 and got here in 10 days. You need a Micro USB OTG Male/female adapter. The guy who made the USB hack uses and recommends one designed for the Nokia 810 (I think!). Here's his original post about his breakthrough:

    [HACK] Enable USB host mode (ie thumb drives) on the Xoom - SlateDroid.com
    04-17-2011 08:29 AM
  5. REHolt218's Avatar
    I had the same problem using a micro USB adapter I got on Amazon. Once o bought the recommended cable everything worked great.
    04-17-2011 10:16 AM
  6. Flipper's Avatar
    10-10-2011 10:16 PM
  7. Flipper's Avatar
    Ok it works I can see my USB flash drive at the end of this cable.
    10-10-2011 11:10 PM
LINK TO POST COPIED TO CLIPBOARD