1. bellerivemark@yahoo.com's Avatar
    Took a cruise to Mexico tuned on airline mode as to not accrue any international charges...Came home only to not having it connect any Internet away from wifi...my phone is telling me it will connect when my mobile data is turned on, it is turned on? I tried turning off and pulling batter out, toggling air plane mode off and on, nothing is working???,
    06-03-2015 10:13 AM
  2. B. Diddy's Avatar
    Welcome to Android Central! Go to Settings>Wireless & Networks>Cellular/Mobile Networks, and check your Preferred Network Type and your Preferred Network. Also make sure the APN is the right one for your carrier.
    06-03-2015 11:35 AM

Similar Threads

  1. Is the Samsung Galaxy S5 Active waterproof?
    By AC Question in forum Samsung Galaxy S5 Active
    Replies: 2
    Last Post: 06-27-2015, 02:53 AM
  2. Replies: 1
    Last Post: 06-03-2015, 11:40 AM
  3. Replies: 1
    Last Post: 06-03-2015, 11:38 AM
  4. How do I turn off notifications on my ZTE tracfone?
    By AC Question in forum Other ZTE Android Phones
    Replies: 1
    Last Post: 06-03-2015, 11:36 AM
  5. wifi calling/texting
    By katiheefner in forum Samsung Galaxy S6
    Replies: 1
    Last Post: 06-03-2015, 10:23 AM
LINK TO POST COPIED TO CLIPBOARD