1. AC Question's Avatar
    Hi, I am unable to save any new contacts. I have gmail and contacts used to sync with this account. But off late when I try to save any contacts, I get two options "KEEP LOCAL" & ADD ACCOUNT (already have gmail account). If i keep local it wont sync. If i try to Add account, I will be asked to add Exchange Activesync account (only option). If I select the same and try to add gmail account again, will get error saying gmail is already there. I am frustrated and not able to save contacts from long time. Please help.
    09-24-2015 06:13 AM
  2. Crashdamage's Avatar
    You didn't say what email accounts you are dealing with. I assume at least one Gmail, maybe an Exchange account? Also you didn't specify what phone you have. Exact procedures vary by phone make and model. The following is for a Nexus with vanilla Android. Your device may be different, but at least similar.

    First, make sure your contacts are saved correctly to your Google account. Login to Gmail online and check your contacts there. Remember, any contacts you have saved using the Keep Local option will not be in Gmail, they exist only on the phone. If all other Google contacts look good, move on to the phone.

    Check your sync settings again.

    1. Go to: Settings > Accounts > Menu (3 dots upper right corner) > Auto-sync data should be checked.
    2. In Accounts select: Google > Your account > Enable Contacts sync (and enable/disable sync as desired for other items).

    With luck, your Google contacts will now sync up and you will be able to save edits and additions. If the contacts fail to sync and/or you still cannot save edits or additions, try this:

    1. Go to your Google accounts as above and disable Contacts sync.
    2. Go to: Settings > Apps > All > Google Contacts > Force stop > Clear cache > Clear data.
    3. Reboot the phone.
    4. Go back to Accounts and enable Contacts sync.

    Just maybe now all will be good. Think positive. It might help to get some good karma going.

    Android since v1.0. Linux since 2001
    09-24-2015 09:48 AM
  3. Sunnyk's Avatar
    Hi,
    Thanks for suggestion. Sorry for providing half information. I use Sony Xperia C3 with android 5.1.1. The problem started after updating to 5.1.1. Yes I use gmail. The contact used to sync with my account without any problem till the update. I am having problem only after updation. Attached few screen shots of the problem. Can you please help me.

    I tried as suggested by you but no use.
    Attached Thumbnails Contact Syncing/saving-screenshot_2015-09-25-11-42-06.png   Contact Syncing/saving-screenshot_2015-09-25-11-42-16.png   Contact Syncing/saving-screenshot_2015-09-25-11-42-51.png   Contact Syncing/saving-screenshot_2015-09-25-12-24-46.png  
    09-25-2015 02:27 AM
  4. Crashdamage's Avatar
    I dunno what to tell you. Apparently something didn't go quite right with the update an now the contacts app isn't picking up on you Google account. That's what I suspected, but I was hoping the instructions I left would do the trick.

    You could try a cache partition wipe. Worth a try. If still no go the only other thing I can suggest is a factory reset. Clear everything and start over. Instructions for clearing the cache partition and resetting can be found here:

    How-to: Sony Xperia C: Clear the Cache Partition, Master Reset and Reboot in Safe Mode

    DON' FORGET TO DO BACKUPS FIRST!
    09-25-2015 06:55 AM

Similar Threads

  1. Replies: 1
    Last Post: 09-24-2015, 02:51 AM
  2. Replies: 0
    Last Post: 09-24-2015, 02:26 AM
  3. Why isn't my contact showing up in the contacts list?
    By AC Question in forum Ask a Question
    Replies: 0
    Last Post: 09-23-2015, 07:58 PM
  4. Contact Icon Greyed Out
    By Hadley Fraser in forum Samsung Galaxy S6 edge
    Replies: 2
    Last Post: 09-23-2015, 06:04 PM
  5. Replies: 2
    Last Post: 09-23-2015, 05:37 PM
LINK TO POST COPIED TO CLIPBOARD