1. AC Question's Avatar
    I am using a Samsung Galaxy S5 G900A. I was unsatisfied with android 5.1.1 so I decided to downgrade. I followed this method: htt p: //forum .xda-developers. c o m/showthread.php?t=2785363

    Now my phone says: "Firmware upgrade encountered an issue. Please select recovery mode in Kies and try again."

    Kies says that the connected device is not supported. However, Odin still detects my device, but keeps failing to load Android KitKat. At this point, I don't care what firmware I'm using as long as I get my S5 back to normal. Please help.
    11-11-2015 12:41 AM

Similar Threads

  1. Why isn't my soft key buttons lighting up anymore on S6?
    By AC Question in forum Samsung Galaxy S6
    Replies: 3
    Last Post: 11-11-2015, 08:45 PM
  2. How do I mount the sd card on my Galaxy S5?
    By AC Question in forum Samsung Galaxy S5
    Replies: 1
    Last Post: 11-11-2015, 02:51 AM
  3. Replies: 1
    Last Post: 11-11-2015, 01:45 AM
  4. Replies: 1
    Last Post: 11-10-2015, 07:35 PM
  5. Replies: 0
    Last Post: 11-10-2015, 05:15 PM
LINK TO POST COPIED TO CLIPBOARD