Welcome to the Android Central Forums Create Your Account or Ask a Question Answers in 5 minutes - no registration required!
Results 1 to 19 of 19
Like Tree1Likes
  • 1 Post By ioo
  1. Thread Author  Thread Author    #1  

    Unhappy Audio, but no video from Google Chrome Tab

    My Chromecast just arrived. I got it all setup and I tested it by sending a YouTube video from my Nexus 7. AWESOME!!!!!

    I then sent music from Google Play Music. AWESOME!!!!!

    Then I came upstairs to my desktop (Windows 7 PC 64-bit 3 GB RAM, Intel Pentium 2.80GHz) and went to NBC.COM and tried casting Revolution. I tried casting full screen. All I got was audio, no video (screen on TV was blank). TV is a VISIO HD TV (I would have to go look at the model number if you really need that). It has two HDMI ports. The Chromecast is in HDMI-1 and the BD Player is in HDMI-2. I don't have a receiver or anything else connected.

    Any ideas?

    Thank you
    Neal
  2. Thread Author  Thread Author    #2  

    Default Re: Audio, but no video from Google Chrome Tab

    Oh, and FWIW. These are my Cast options:



    It doesn't look like I have an option to cast the entire desktop.
  3. #3  
    ioo
    ioo is offline
    ioo's Avatar

    Posts
    136 Posts
    ROM
    Stock

    Default Re: Audio, but no video from Google Chrome Tab

    I would guess flash/DRM issue.

    Posted via Android Central App
  4. #4  

    Default Re: Audio, but no video from Google Chrome Tab

    Quote Originally Posted by NealJ777 View Post
    Oh, and FWIW. These are my Cast options:

    http://i143.photobucket.com/albums/r...ps5dde545e.png

    It doesn't look like I have an option to cast the entire desktop.
    thats weird... from all the options i have seen it did incude casting the desktop.
    maybe it realized the desktop is far from chromecast that the desktop mirroring will be useless???
  5. #5  

    Default Re: Audio, but no video from Google Chrome Tab

    I have the same problem. But I have a Intel 2 Core Duo laptop. I think the extension is preventing flash video for lower spec computers. But I don't know why they don't just let it all work.
  6. #6  
    beck79's Avatar

    Posts
    60 Posts
    ROM
    Stock JellyBean

    Default Re: Audio, but no video from Google Chrome Tab

    Quote Originally Posted by NealJ777 View Post
    My Chromecast just arrived. I got it all setup and I tested it by sending a YouTube video from my Nexus 7. AWESOME!!!!!

    I then sent music from Google Play Music. AWESOME!!!!!

    Then I came upstairs to my desktop (Windows 7 PC 64-bit 3 GB RAM, Intel Pentium 2.80GHz) and went to NBC.COM and tried casting Revolution. I tried casting full screen. All I got was audio, no video (screen on TV was blank). TV is a VISIO HD TV (I would have to go look at the model number if you really need that). It has two HDMI ports. The Chromecast is in HDMI-1 and the BD Player is in HDMI-2. I don't have a receiver or anything else connected.

    Any ideas?

    Thank you
    Neal
    I read some where that casting will not work for websites that use flash or Silverlight(microsoft). The websites that use HTML5 works. NBC seem to be flash enabled.
    I am waiting for my chromecast so its just what I have read online.
  7. Thread Author  Thread Author    #7  

    Default Re: Audio, but no video from Google Chrome Tab

    Okay. Thank you for the Flash explanation.

    It also could just be that my desktop is not strong enough for Chromecast. My desktop is over five years old, which I know is antique as far as tech is concerned.
  8. #8  
    ioo
    ioo is offline
    ioo's Avatar

    Posts
    136 Posts
    ROM
    Stock

    Default Re: Audio, but no video from Google Chrome Tab

    I have a more detailed explanation of why it doesnt work, and a workaround using Plex Media Server, that I will post in a FAQ thread I am compiling. Should be done in a bit.
    Thanked by:
    NealJ777 likes this.
  9. #9  

    Default Re: Audio, but no video from Google Chrome Tab

    Funny. I saw some reviews using flashing just fine in their video. So what the hell.
  10. #10  
    beck79's Avatar

    Posts
    60 Posts
    ROM
    Stock JellyBean

    Default Re: Audio, but no video from Google Chrome Tab

    Quote Originally Posted by NealJ777 View Post
    Okay. Thank you for the Flash explanation.

    It also could just be that my desktop is not strong enough for Chromecast. My desktop is over five years old, which I know is antique as far as tech is concerned.
    In which case I need a new laptop, I am pretty sure my 4 yr old laptop wont be casting anything
  11. Thread Author  Thread Author    #11  

    Default Re: Audio, but no video from Google Chrome Tab

    Quote Originally Posted by beck79 View Post
    In which case I need a new laptop, I am pretty sure my 4 yr old laptop wont be casting anything
    Our four year old laptop died last week. I'm using that as an excuse to get a replacement capable of Casting!

    I don't see my wife approving the purchase of a Pixel.
  12. #12  
    ioo
    ioo is offline
    ioo's Avatar

    Posts
    136 Posts
    ROM
    Stock

    Default Re: Audio, but no video from Google Chrome Tab

    So I have been playing around, and it seems to me that browser casting is definitely dependent on having a fast computer and fast wifi connection.

    NBC.com works fine casting it from my quad core desktop, but my old work laptop apparently is not up to snuff as I get the blank screen and just audio, same as you.

    So it works if I set it on my desktop and then walk downstairs and watch it on my tv. Not very practical though. Playing it through Plex on my laptop is better, but not great. I changed the output in the chromecast extension to 480 and that makes it mostly watchable from the laptop.

    So I guess the answer is A) Get a faster laptop, or B) wait for Plex to add native cast support.
    Thanked by:
  13. Thread Author  Thread Author    #13  

    Default Re: Audio, but no video from Google Chrome Tab

    Thank you for looking into this.

    (A) Look at the post right above yours.
  14. #14  
    WhoMe's Avatar

    Posts
    326 Posts
    Global Posts
    454 Global Posts
    ROM
    Clean ROM 4.0

    Default Re: Audio, but no video from Google Chrome Tab

    Yeah my machine is right on the edge. 2010 i3 iMac, Tab casting works pretty good, but desktop casting brings my machine to its knees. That part of this magical thing definitely is asking our machine and networks to do the heavy lifting. My little extension icon on the browser even turns orange and has a little exclamation mark...like OH ****!
  15. #15  

    Default Re: Audio, but no video from Google Chrome Tab

    Google has posted spec requirements for tab casting. It comes down to this:
    HD: Gen 2 Core i5 processor clocked at 2GHz+
    SD: Core i3 processor

    My laptop has a Gen 1 Core i5 clocked at 2.3GHz. Tab casting at Extreme quality caused issues, especially when I used the computer for anything else. But casting at High quality worked really well. I haven't tried casting the desktop.
  16. #16  

    Default Re: Audio, but no video from Google Chrome Tab

    Those requirements are high. Damn, I guess i can forget tab casting any sort of video that is not html5. This sucks.
  17. #17  

    Default Re: Audio, but no video from Google Chrome Tab

    I have Two Chromecast. one on my room connected to the TVs USB.... the other one on the second room connected to the wall....
    The one in my second room works perfect when I Tabcast.... the one in my room USED TO WORK and last night stopped working... I think the difference is maybe the power supply coming from the TV's USB???
    I will try to connect it to the wall tonight and see what happens....

    this is driving me nuts....
  18. #18  

    Default Re: Audio, but no video from Google Chrome Tab

    So in case anyone is still interested.... I connected my chromecast to the wall instead the usb port on my tv.... It works normal now... Maybe there was not enough power coming from the tv usb?... Well i hope this helps somebody.
  19. #19  

    Default Re: Audio, but no video from Google Chrome Tab

    So the problem persisted and discovered that When I turned off the InLink option on my TV made the problem go away. So that is a feature on the Insignia Tvs that allows you control your hdmi devices that are compatible... I hope this helps.

Similar Threads

  1. Problems with Google Play Music on Nook HD+
    By D-Caf in forum Barnes & Noble Nook HD / HD+
    Replies: 3
    Last Post: 08-24-2013, 08:28 PM
  2. WTS: Samsung Galaxy Nexus [VERIZON, 32GB, UNLOCKED, NO OS INSTALLED, DOCK, ETC.]
    By mhpspeed in forum The Marketplace - Buy, Sell & Trade
    Replies: 4
    Last Post: 08-19-2013, 08:28 PM
  3. Music app closes when I play a video? Grr
    By cafshari in forum HTC One
    Replies: 2
    Last Post: 08-09-2013, 01:01 PM
  4. Apps disappearing from phone. Not from Google Play Store account.
    By intlzncster2 in forum Samsung Galaxy S4 Mini
    Replies: 6
    Last Post: 08-04-2013, 11:08 AM
  5. The new Google Maps - bug-ridden!
    By 6tr6tr in forum Google Nexus 4
    Replies: 4
    Last Post: 07-29-2013, 06:10 PM

Posting Permissions