Welcome to the Android Central Forums Create Your Account or Ask a Question Answers in 5 minutes - no registration required!
Results 1 to 2 of 2
  1. Thread Author  Thread Author    #1  

    Default Help?!?

    Sorry for this strange question, but I am pretty new to Android and on my HTC Desire S, I am unable to download some applications because it says 'your device is incompatible with this version'. It does it to apps such as android central which is pretty annoying. Pls help me!
  2. #2  

    Default Re: Help?!?

    Quote Originally Posted by Sophie Ruiz View Post
    Sorry for this strange question, but I am pretty new to Android and on my HTC Desire S, I am unable to download some applications because it says 'your device is incompatible with this version'. It does it to apps such as android central which is pretty annoying. Pls help me!
    Unfortunately there is nothing you can do about that- the phone and OS Version simply isn't compatible with this app. Perhaps try to find an older version APK file of this- but I doubt this will help. The best solution? Possibly run the apps off a PC using an Android Emulator or just upgrade your phone.

Similar Threads

  1. Helping my brother..
    By N4warhead in forum ASUS MeMO Pad HD7
    Replies: 1
    Last Post: 06-17-2014, 08:12 PM
  2. update 12.15.15.en.us Help needed
    By heath patrick in forum Motorola Droid MAXX
    Replies: 4
    Last Post: 05-25-2014, 11:47 PM
  3. Replies: 2
    Last Post: 05-24-2014, 11:11 AM
  4. Help! Hashtag missing from Phone!
    By The Big Biff in forum General News & Discussion
    Replies: 1
    Last Post: 05-24-2014, 12:55 AM
  5. Need help rooting Pantech Marauder
    By wakedaddy820 in forum General Help and How To
    Replies: 0
    Last Post: 05-23-2014, 03:06 PM

Posting Permissions