Welcome to the Android Central Forums Create Your Account or Ask a Question Answers in 5 minutes - no registration required!
Results 1 to 6 of 6
  1. Thread Author  Thread Author    #1  

    Default Network speed is averaging .04 mbps

    I've rooted, and tried many roms with my nexus 4 and I know i've done something to cause the network speed to be averaging about .04 mbps. I've spent the last 2 weeks trying to fix it by doing a couple things and can't find the answer anywhere. I'm using Straight Talk Tmobile in SLC, UT. I use to get 8 mbps easy. This is what i've done to try and fix it:

    Verified APN settings are correct
    Have flashed different radios
    Used the Nexus root toolkit to unroot, and return to stock

    I did the whole #*#*4636*#*# and clicked on "run ping test" and it says: Ping IpAddr: Fail: IP addr not reachable

    Any advice on what to do?
  2. #2  
    acejavelin's Avatar

    Posts
    1,226 Posts
    Global Posts
    1,228 Global Posts
    ROM
    SimpleAOSP & Hells-Core

    Default Re: Network speed is averaging .04 mbps

    Quote Originally Posted by mjacobson7 View Post
    I've rooted, and tried many roms with my nexus 4 and I know i've done something to cause the network speed to be averaging about .04 mbps. I've spent the last 2 weeks trying to fix it by doing a couple things and can't find the answer anywhere. I'm using Straight Talk Tmobile in SLC, UT. I use to get 8 mbps easy. This is what i've done to try and fix it:

    Verified APN settings are correct
    Have flashed different radios
    Used the Nexus root toolkit to unroot, and return to stock

    I did the whole #*#*4636*#*# and clicked on "run ping test" and it says: Ping IpAddr: Fail: IP addr not reachable

    Any advice on what to do?
    Did you exceed your data usage on Straight Talk? They do have "unlimited data" but after about 2GB or so they throttle you to Edge speeds, which is about what you are getting, when your renewal comes up and you pay again it should take off within about 4 hours.
    Current Personal Phone: Google Nexus 4 on AT&T (SimpleAOSP/hells-Core Kernel/LTE)
    Current Work Phone: LG G2 VS980 on VZW (Snuzzo's Plain-Andy ROM)
    Current Tablet: iPad 4/Samsung Galaxy Note Pro 12.2
    Other phones "in the family": HTC One (M7), Moto G GPE, LG G2
    Previous/Retired Android Devices: HTC Aria/Incredible 2/Rezound/DNA, Samsung Stratosphere, SGS2 Skyrocket, Nextbook 8P
  3. Thread Author  Thread Author    #3  

    Default Re: Network speed is averaging .04 mbps

    Good point, and I forgot to mention that, but this has gone on for at least two months. I mostly use wifi anyway, but it's very annoying that this happens.
  4. #4  
    acejavelin's Avatar

    Posts
    1,226 Posts
    Global Posts
    1,228 Global Posts
    ROM
    SimpleAOSP & Hells-Core

    Default Re: Network speed is averaging .04 mbps

    Quote Originally Posted by mjacobson7 View Post
    Good point, and I forgot to mention that, but this has gone on for at least two months. I mostly use wifi anyway, but it's very annoying that this happens.
    I was once on Net10 (essentially Straight Talk), had nothing but issues... slow data speeds, inconsistent service, inability to send MMS (or receive, I can't remember which), but then I switched to Go Phone, it was excellent but pricey for the service (~$65/month), but switched then to Aio Wireless for $45/month on auto refill for unlimited talk, text, and 2.5GB of high speed data. I have since gotten a few people I work with to switch from Straight Talk to Aio, and they can't believe the difference in service they get for the same money... It is on AT&T's network though, not T-Mobile. Honestly, I haven't heard anyone have a good story about ST lately.

    Just something to consider... not all MVNO's are the same.

    But back to your original problem, this sounds like either a SIM or APN issue, you could have a bad SIM, incorrect APN information, or an incorrectly configured account with Straight Talk (pray this is not the issue, it seems very tough for them to "fix" something)...

    If you use something like Network Signal Info, what kind of network type does it show you have when on mobile data... Edge, HSPA, HSPA+ or something else? When network is active it should show something like "(DC)HSPA+ * 42.2Mbps", when data is inactive it should show something like "HSPA * 14.4 Mbps", and if you are only in Edge mode, it will show something like "EDGE * 220 kbps".
    Current Personal Phone: Google Nexus 4 on AT&T (SimpleAOSP/hells-Core Kernel/LTE)
    Current Work Phone: LG G2 VS980 on VZW (Snuzzo's Plain-Andy ROM)
    Current Tablet: iPad 4/Samsung Galaxy Note Pro 12.2
    Other phones "in the family": HTC One (M7), Moto G GPE, LG G2
    Previous/Retired Android Devices: HTC Aria/Incredible 2/Rezound/DNA, Samsung Stratosphere, SGS2 Skyrocket, Nextbook 8P
  5. Thread Author  Thread Author    #5  

    Default Re: Network speed is averaging .04 mbps

    So I've had Straight Talk for about a year. Before I started really messing with the phone, I was getting at least 7-8 mbps without a problem. I rooted it and then started noticing some issues. I mostly always see H+ when using my phone. I even enabled the LTE and it wouldn't go faster than .05 mpbs. I'll have to check out that other service you mentioned. I'm about ready to get a new phone because of the issues I've had. I appreciate your feedback.
    Thanked by:
  6. #6  
    acejavelin's Avatar

    Posts
    1,226 Posts
    Global Posts
    1,228 Global Posts
    ROM
    SimpleAOSP & Hells-Core

    Default Re: Network speed is averaging .04 mbps

    Send me a PM if you want to switch, they have a refer a friend program, if you stay with them 60 days we each get $25 credit.

    Sent from my Nexus 4 using Tapatalk
    Current Personal Phone: Google Nexus 4 on AT&T (SimpleAOSP/hells-Core Kernel/LTE)
    Current Work Phone: LG G2 VS980 on VZW (Snuzzo's Plain-Andy ROM)
    Current Tablet: iPad 4/Samsung Galaxy Note Pro 12.2
    Other phones "in the family": HTC One (M7), Moto G GPE, LG G2
    Previous/Retired Android Devices: HTC Aria/Incredible 2/Rezound/DNA, Samsung Stratosphere, SGS2 Skyrocket, Nextbook 8P

Similar Threads

  1. only the flashing samsung logo is appearing
    By David Pretorious in forum Samsung Galaxy S4 Mini
    Replies: 1
    Last Post: 04-28-2014, 05:41 PM
  2. pattent is locked in maxx AX353
    By tamil arasan2 in forum Droid RAZR MAXX
    Replies: 2
    Last Post: 04-25-2014, 12:08 PM
  3. HTC One (M8): This is just a simple thread about the camera!
    By CHILLYWILL_95831 in forum HTC One M8
    Replies: 62
    Last Post: 04-16-2014, 11:12 AM
  4. Download Booster IS on the Verizon S5!
    By rnd0209 in forum Samsung Galaxy S5
    Replies: 9
    Last Post: 04-13-2014, 08:38 PM
  5. Replies: 0
    Last Post: 04-13-2014, 09:19 AM

Posting Permissions