Results 1 to 22 of 22
  1. Thread Author  Thread Author    #1  

    Default turning off roaming guard on sprint galaxy s4

    I am having a issue turning off roaming guard on my galaxy s4 on sprint. And of course their customer service has no clue. I go to where you should turn it off and everything is greyed out and cannnot be selected. I only get one box to select and that is under international cdma for sms messages. I need to select the domestic ones and cannot. Anyone have the same issue or know how to get them so they can be selected.
  2. #2  
    RG129's Avatar

    Posts
    205 Posts
    Global Posts
    211 Global Posts

    Default Re: turning off roaming guard on sprint galaxy s4

    I struggled with this for the past two days.

    The next time you start to roam and guard comes on, click on it from the notification panel, there should be an option that says "do not display in the future" or something similar. Once that happens, the grayed out options should be unchecked.

    Domestic CDMA roaming is now unchecked on my phone, but I have yet to roam again to verify that it actually got rid of the guard.
  3. #3  

    Default Re: turning off roaming guard on sprint galaxy s4

    Quote Originally Posted by wozz1820 View Post
    Anyone have the same issue or know how to get them so they can be selected.
    Same issue? Yes. Fixed? Not yet.
  4. #4  

    Default Re: turning off roaming guard on sprint galaxy s4

    Go to settings>More Networks>Roaming>Roaming Network>Home Only to completely disable it or Automatic to disable some features.
  5. #5  

    Default Re: turning off roaming guard on sprint galaxy s4

    Quote Originally Posted by josearmz10789 View Post
    Go to settings>More Networks>Roaming>Roaming Network>Home Only to completely disable it or Automatic to disable some features.
    That's the problem. Setting it to Automatic does NOT allow anything to be disabled. All the boxes in the Roaming Guard section are checked, and the only one able to be unchecked are "International CDMA/Outgoing SMS".
  6. #6  
    RG129's Avatar

    Posts
    205 Posts
    Global Posts
    211 Global Posts

    Default Re: turning off roaming guard on sprint galaxy s4

    See my post above. It explains how to deactivate the guard. Worked for me.
  7. #7  

    Default Re: turning off roaming guard on sprint galaxy s4

    I was driving in a remote area and my navigation quit working due to this stupid roaming guard. I hate Samsung, never had as many problems with my HTC Evo. I actually have the Note 2, but same greyed out area. However, I didn't get the notification you mention.
  8. #8  

    Default Re: turning off roaming guard on sprint galaxy s4

    Quote Originally Posted by statdoc View Post
    That's the problem. Setting it to Automatic does NOT allow anything to be disabled. All the boxes in the Roaming Guard section are checked, and the only one able to be unchecked are "International CDMA/Outgoing SMS".
    On mine it allows me to un check every single one under domestic and international.

    Sent from my SPH-L720 using Android Central Forums
  9. #9  

    Default Re: turning off roaming guard on sprint galaxy s4

    Quote Originally Posted by statdoc View Post
    That's the problem. Setting it to Automatic does NOT allow anything to be disabled. All the boxes in the Roaming Guard section are checked, and the only one able to be unchecked are "International CDMA/Outgoing SMS".
    While you are roaming those boxes should become accessible and you can then uncheck them.
  10. #10  

    Default Re: turning off roaming guard on sprint galaxy s4

    Nope. I tried that today, while in a roaming area.
  11. #11  

    Default Re: turning off roaming guard on sprint galaxy s4

    Are the boxes supposed to be checked or unchecked to allow roaming. Under the roaming guard tab most of its greyed out and I can't check anything.

    Posted via Android Central App
  12. #12  

    Default Re: turning off roaming guard on sprint galaxy s4

    When the roaming guard comes up you need to click the
    check box for "Do not show this warning again" and hit ok.
    Then the roaming guard is unchecked but everything is still
    grayed out.
  13. #13  

    Default Re: turning off roaming guard on sprint galaxy s4

    Quote Originally Posted by sambo57u#AC View Post
    When the roaming guard comes up you need to click the
    check box for "Do not show this warning again" and hit ok.
    Then the roaming guard is unchecked but everything is still
    grayed out.
    I tried this. There is nothing stating do not show this warning again. Who is your service provider? I'm on Sprint.

    Posted via Android Central App
  14. #14  

    Default Re: turning off roaming guard on sprint galaxy s4

    I am on Sprint. When you loose Spring data service do you get a warning from "roaming guard"? That warning has a little
    box saying like ":if you don't want to see this warning again click here". If you click that the roaming quard check mark in
    the settings will be gone. If you are not getting the above warning then your roaming guard is off already.
  15. #15  
    Mudavo's Avatar

    Posts
    1 Posts
    Global Posts
    86 Global Posts

    Default Re: turning off roaming guard on sprint galaxy s4

    Quote Originally Posted by RG129 View Post
    I struggled with this for the past two days.

    The next time you start to roam and guard comes on, click on it from the notification panel, there should be an option that says "do not display in the future" or something similar. Once that happens, the grayed out options should be unchecked.

    Domestic CDMA roaming is now unchecked on my phone, but I have yet to roam again to verify that it actually got rid of the guard.
    Same for me.


    Sent from my SPH-L720 using Tapatalk 2
  16. #16  

    Default Re: turning off roaming guard on sprint galaxy s4

    Thanks for the info. Worked perfectly for me.
  17. #17  

    Default Re: turning off roaming guard on sprint galaxy s4

    Thanks! It was annoying me to no end!
  18. #18  

    Angry Re: turning off roaming guard on sprint galaxy s4

    that didnt work on my phone if i turn roaming off i dont get any of my txt msgs or emails i love the phone but this roaming ringer has got to go any more suggestions before i have to take it in.
  19. #19  

    Default Re: turning off roaming guard on sprint galaxy s4

    hello,
    what about the Galaxy S4 MINI?
    The same issue, but no such a "ROAMING" option in the "More Networks" menu
  20. #20  

    Default Re: turning off roaming guard on sprint galaxy s4

    To everyone who is having roaming guard issues and isnt getting the option to click "do not display this message again" try this and see if it works

    go to settings> more networks> roaming> roaming network>
    set it to home only
    wait a few seconds and turn it back to automatic
    then see if you get the warning with the box to check next time you are roaming

    this worked for me
  21. #21  

    Default Re: turning off roaming guard on sprint galaxy s4

    On my Optima LG, I constantly get the popup about enabling data roaming and the "Don't show this again"...every time I check and approve data roaming, and still it comes back.
  22. #22  

    Default Re: turning off roaming guard on sprint galaxy s4

    I done that but it still shows the R and my internet doesn't work.

Similar Threads

  1. I can't turn off auto answer on my T-Mobile Samsung Galaxy S3
    By Ursusveritas in forum General Help and How To
    Replies: 4
    Last Post: 09-25-2013, 09:27 AM
  2. how to turn off vibrate when on call?
    By shley00 in forum Motorola Droid
    Replies: 5
    Last Post: 08-28-2011, 01:03 AM
  3. Turning off shutter sound on Droid
    By mugenprincess in forum General Help and How To
    Replies: 10
    Last Post: 08-31-2010, 02:26 AM
  4. Turn off notifications while on a call
    By shribe in forum Verizon Droid Incredible
    Replies: 3
    Last Post: 08-12-2010, 10:05 PM
  5. wi fi turning off and back on
    By scotth45 in forum Verizon Droid Incredible
    Replies: 0
    Last Post: 06-08-2010, 07:44 PM

Posting Permissions

B