Welcome to the Android Central Forums Create Your Account or Ask a Question Answers in 5 minutes - no registration required!
Results 1 to 25 of 25
  1. Thread Author  Thread Author    #1  

    Default how to delete email history from autofill

    i cant for the life of me figure out how to get rid of the email history of contacts that are not even on my phone.

    i have accidently typed emails wrong before, and other peoples addresses from CC's, or 1 time random emails that i dont want saved with the same name as other people always show up.

    im about ready to wipe the phone i'm so annoyed.

    i have already eliminated all the email accounts, exchange & hotmail, and then when i just add google back i can start to type an email and low and behold the emails are all still there, even after wiping the "people" & contacts data. some other things in mail have no cache but wont let me clear data.

    i have searched and searched. and several people say remove the account and re-add it. i just did that, and its not working, there must be one more step somehwere im missing.

    help please
    Thanked by:
  2. #2  
    Mikey D_PhD's Avatar

    Posts
    213 Posts
    ROM
    Stock

    Default Re: how to delete email history from autofill

    Don't know for sure if this will work but try:

    Go to Messages > Settings (use menu key) > General. See if the show sent message history, call history and emaill address are checked or not (3 separate check boxes).

    This worked for me when old addresses or one time addresses kept popping up.
  3. #3  
    natehoy's Avatar

    Posts
    1,647 Posts
    ROM
    Stock

    Default Re: how to delete email history from autofill

    If you're syncing with a Google account, log on to it on the web and look for them in your contacts. It may be under other contacts.
  4. #4  
    FrankXS's Avatar

    Posts
    3,148 Posts
    Global Posts
    3,645 Global Posts
    ROM
    Latest OTA Official ROM

    Default Re: how to delete email history from autofill

    What email program are you using?

    It could possibly be a personal spelling dictionary issue...

    Check: Menus, Settings, Language & Keyboard, Touch Input, Personal Dictionary, Edit personal dictionary, Menu, Delete... then scroll through and see if your mispelled addresses are there. If so, checkmark all of the bad ones and hit delete.

    Also you could check: Search key, Menu, Search Settings, Searchable items, remove the checkmark from "Messages".

    Anyhow, maybe one of these will work.

    -Frank
    [HTC Thunderbolt™ 4G/LTE!]
    It's not your dream phone. It's the one after that!©
    Look here for a [VZW Coverage Map] to check your area. Select 4G before hitting [Refresh]
  5. Thread Author  Thread Author    #5  

    Default Re: how to delete email history from autofill

    They are not contacts, its a email log in the phone hidden somewhere.

    I'm using the HTC mail client, all 3 accounts, exchange , hotmail, Google show the same history in the auto complete.

    I just checked the dictionary and they are not there.

    I found someone say you have to remove the accounts and then delete a certain cache, but I can't find that forum again .

    This question is all over the internet, but I have found no solution to it. I can't believe thus doesn't bother more people, its annoying to keep emailing my wife wrong if Im not careful and pick the wrong one.
  6. #6  
    FrankXS's Avatar

    Posts
    3,148 Posts
    Global Posts
    3,645 Global Posts
    ROM
    Latest OTA Official ROM

    Default Re: how to delete email history from autofill

    Quote Originally Posted by billdorn View Post
    They are not contacts, its a email log in the phone hidden somewhere.

    I'm using the HTC mail client, all 3 accounts, exchange , hotmail, Google show the same history in the auto complete.

    I just checked the dictionary and they are not there.

    I found someone say you have to remove the accounts and then delete a certain cache, but I can't find that forum again .

    This question is all over the internet, but I have found no solution to it. I can't believe thus doesn't bother more people, its annoying to keep emailing my wife wrong if Im not careful and pick the wrong one.
    Under People, Menu, View, how many accounts do you have people listed under? Have you tried uncheckiing them one by one and testing?

    -Frank
    [HTC Thunderbolt™ 4G/LTE!]
    It's not your dream phone. It's the one after that!©
    Look here for a [VZW Coverage Map] to check your area. Select 4G before hitting [Refresh]
  7. #7  

    Default

    Quote Originally Posted by billdorn View Post
    I'm using the HTC mail client, all 3 accounts, exchange , hotmail, Google show the same history in the auto complete.
    I don't have that app on my phone anymore, so I can't test this, but in some apps, when the auto-complete selection pops up, you can long-press it and you'll get the option to delete that choice. HTH

    Sent from my Sinclair ZX-80 using Tapatalk
  8. Thread Author  Thread Author    #8  

    Default

    Quote Originally Posted by GSDer View Post
    I don't have that app on my phone anymore, so I can't test this, but in some apps, when the auto-complete selection pops up, you can long-press it and you'll get the option to delete that choice. HTH

    Sent from my Sinclair ZX-80 using Tapatalk
    Tried this but its a no go
  9. Thread Author  Thread Author    #9  

    Default

    Quote Originally Posted by FrankXS View Post
    Under People, Menu, View, how many accounts do you have people listed under? Have you tried uncheckiing them one by one and testing?

    -Frank
    I removed every account so there was nothing but 5 contacts on my phone.

    Re-added just one account so I can even do a test email and all the old emails contacts still pop up
  10. Thread Author  Thread Author    #10  

    Default Re: how to delete email history from autofill

    MENU-SETTINGS-APPLICATIONS- MANAGE APPLICATIONS- SELECT ALL- MAIL- FORCE STOP – CLEAR DATA- THEN REINSTALL YOUR EMAIL ACCOUNTs

    this is what i keep finding posted as the solution. but on my phone, the clear data is greyed out and i cannot do this part of it.
  11. #11  
    Gimpx's Avatar

    Posts
    1 Posts
    Global Posts
    3 Global Posts

    Cool Re: how to delete email history from autofill

    Well I have a solution for this.
    I am on a Galaxy Nexus with 4.1.1

    Goto:
    Settings
    Apps
    All
    Scroll to contacts storage
    Clear Data
    Go back a screen
    Select Contacts
    Clear Data

    it doesn't remove your contact list (my concern when it warns you about everything it will remove), but it does remove the autofill email addresses.
    Now spread this to every forum that has the same question with no results!!!
    WINNER!
  12. #12  

    Default Re: how to delete email history from autofill

    Mine deleted all the contacts and then repopulated them from my email account.

    Caution! Backup you data first.


    If the numbers are only on your phone you will loose them.
    Last edited by Theman555; 03-07-2013 at 12:58 PM.
  13. #13  

    Default Re: how to delete email history from autofill

    this happened to my phone's gmail and yahoo mail. i was able to delete the unwanted email contact with this:
    1. write new message in yahoo mail.
    2. fill in the "To" field (recipient) with the unwanted email address.
    3. once the email contact is there, press and hold it, a window will appear, then press "view contact details"
    4. press "edit"
    5. scroll all the way down the Edit Contact page and hit the red Delete Contact button.
    This automatically deleted the email address from my gmail autofill as well.
    I had to repeat same process in my tablet and it also worked.
  14. #14  

    Default Re: how to delete email history from autofill

    Quote Originally Posted by Theman555 View Post
    Mine deleted all the contacts and then repopulated them from my email account.

    Caution! Backup you data first.


    If the numbers are only on your phone you will loose them.
    Not only did this clear all my contacts, it also did not solve the problem.
  15. #15  

    Default Re: how to delete email history from autofill

    With a Galaxy S4, go to settings, application manager and then select "All" from the top, rather than "downloaded" or "running". Find an app called "LogApp" - delete cache and then disable. It will delete the email log history in the messages section.
  16. #16  

    Default Re: how to delete email history from autofill

    Yes,Yes,Yes!
    That's the only solution that WORKS!!!
    Thank you!
    I am on HTC One T-Mobile

    This is the reply to "madsaints"
    Last edited by S B2014; 09-28-2013 at 07:26 AM. Reason: reply to
  17. #17  

    Angry Re: how to delete email history from autofill

    Quote Originally Posted by Cosmo2407 View Post
    With a Galaxy S4, go to settings, application manager and then select "All" from the top, rather than "downloaded" or "running". Find an app called "LogApp" - delete cache and then disable. It will delete the email log history in the messages section.
    I have been fighting to delete emails address' that come up in the drop down box for months!!!!! I have the Galaxy S4 and I didn't have the "Log App" to delete. I spat it, went to emails and delete the cache and all data. Fantastic. Reset them and no more emails in the drop down bar.. BUT, you can go to logs and they are ALL there *fumes* and can you delete this log??? NOOOOO of course you can't! Iphone is looking good.
  18. #18  

    Default Re: how to delete email history from autofill

    This seems to work on my Samsung Note,
    Settings / Storage / Applications / ( Put them in A-Z order ) / Log Provider/ Clear Data.
    All of my email logs were then gone.

    Thank you.
  19. #19  

    Default Re: how to delete email history from autofill

    Update............And yet after deleting the email logs, the Autofill still has all the old email address's , even though they are not in my Contacts anymore.
  20. #20  

    Default Re: how to delete email history from autofill

    Update 2............Settings / All Applications / Email / Clear Data.................Reinstall email address's gone the Auto fill from the past but will accumulate again now I suppose.
  21. #21  

    Default Re: how to delete email history from autofill

    My emails are piling up and I can't seem to find a way to delete all at once.
  22. #22  

    Default Re: how to delete email history from autofill

    I had this same problem and finally found the offending misspelled email by going to my Gmail account on the web via my desktop computer. Go to contact list and there is a list of my contacts that synchs to my phone but there was another list of 'other contacts'. This list was mostly old email addresses, mistakenly typed ones etc. I found the offending address there and was able to delete it and when the phone synched to the gmail account automatically the offending address was finally gone. So it actually was not stored on the phone at all but in the Gmail 'other contact' list.
  23. #23  

    Default Re: how to delete email history from autofill

    Christopher J's solution worked for me. Samsung Galaxy S3. Application Manager, ALL, found LogsProvider and Cleared data. Thanks!
  24. #24  

    Default Re: how to delete email history from autofill

    I'm a Note2 user and am having the same problem as others on this thread. I've tried all the suggestions shown here (even though I'm using a Note 2) to no avail. I'm not even using GMail or Yahoo. I have one email account tied to a GoDaddy account. The GoDaddy account is set not to save contacts! I've deleted the account on the phone twice and set it up again... every address from every sender still populats the autofill. As massive as the Android user community is, I can't believe this is such a problem for so many users. Truly pitiful. Anyone out there with a Note2 have any ideas to fix this?
  25. #25  

    Default Re: how to delete email history from autofill

    After a lot of searching I finally found one method to remove auto-fill with gmail. I have a Galaxy S5.
    Settings/ Applications/ Internet/ Privacy/ Delete personal data/ Auto fill data.....

Posting Permissions