04-27-2015 12:06 PM
31 12
tools
  1. GolferChris68's Avatar
    Not a huge deal, but definitely annoying. When on WIFI, the 4GLTE is still displayed in the status bar alongside the WIFI symbol. In the next update, I hope this gets fixed, as it's rather annoying, and takes up precious status bar space when in WIFI.
    05-21-2013 11:01 PM
  2. Joe the Insider's Avatar
    Turn off mobile data and it will disappear.

    Posted via Android Central App
    05-22-2013 12:15 AM
  3. thedeceiver's Avatar
    I had/have this same issue. I don't have it consistently, just sometimes when I'm on WiFi.
    05-22-2013 09:41 AM
  4. wintrmte's Avatar
    Yeah, I have it all the time when I'm connected to WiFi.
    05-22-2013 12:06 PM
  5. jhnnyblze2000's Avatar
    Go in to application manager and disable the caller name id app. I did that and its been gone the entire time. It requires a constant connection to verizons data but only uses it when a call comes in.
    05-24-2013 09:35 PM
  6. MaccaBird's Avatar
    Go in to application manager and disable the caller name id app. I did that and its been gone the entire time. It requires a constant connection to verizons data but only uses it when a call comes in.
    This worked for me, thanks!

    Will disabling it have any effect on the phone? What exactly does it do?
    05-25-2013 12:52 PM
  7. prodigy1814's Avatar
    Go in to application manager and disable the caller name id app. I did that and its been gone the entire time. It requires a constant connection to verizons data but only uses it when a call comes in.
    Thank you! This worked instantly!!
    05-25-2013 12:54 PM
  8. gamebird's Avatar
    I have this problem but don't have the "Caller Name ID" app in my app list. It appears I'm using data while on wifi. manually turning off data every time i'm on wifi is NOT an option.

    UPDATE: Just spoke with Verizon...note the icons in your notification bar: if the WIFI shows the yellow arrow under it, it actively in use - the 4G one is available but not in use. WIFI trumps and negates 4G while in use. I am checking my 4G data closely for a month to verify.
    05-25-2013 01:20 PM
  9. jhnnyblze2000's Avatar
    No it won't effect the phone. Only caller ID ull have is the standard ID for people that are in your phone.
    05-25-2013 01:27 PM
  10. jhnnyblze2000's Avatar
    I have this problem but don't have the "Caller Name ID" app in my app list. It appears I'm using data while on wifi. manually turning off data every time i'm on wifi is NOT an option.
    Make sure you scroll over to all applications and not just the downloaded ones.
    05-25-2013 01:29 PM
  11. gamebird's Avatar
    Right you are, my mistake!
    05-25-2013 02:04 PM
  12. 757Dave's Avatar
    Thanks, worked like a charm.
    05-25-2013 03:03 PM
  13. haevolution's Avatar
    You can actually uninstall the app which is what I just did. The service is only free for a few days then they want you to pay for it monthly!!!!
    05-27-2013 02:10 PM
  14. jaymojones's Avatar
    Thanks!!! I was just coming in to post this. Stopped caller ID and the 4G went away

    Sent from my SCH-I545 using Tapatalk 4 Beta
    05-27-2013 10:15 PM
  15. TreeSpooner's Avatar
    So I've only had by S4 for 5 days and received it at the beginning of a new billing cycle. Even though I have been home and using Wifi 99% of the time, I still managed to burn through 30% of my data plan. I realized both my Wifi and 4g were on at the same time and apps were using the data plan when they had no reason to. I spent at least 2 hours on the phone with Verizon and they didn't believe me that this was happening! Anyway long story short, they told me to disable mobile data while I am on wifi and I told them that was just a work around and I wanted a fix. They told me to delete two of the largest offending apps and see if it is the apps or actually the phone. Anyway I stumbled across this post and disabled the caller id app and the 4g signal went away! I really hope this is my fix b/c I don't want to spend another 2 hours on the phone with Verizon! Thanks
    06-15-2013 10:44 PM
  16. DarkSorrow's Avatar
    I don't see a 4G symbol unless I get a text or MMS message. Those will use 4G not WiFi.
    06-16-2013 02:21 AM
  17. brun019822's Avatar
    awesome!
    06-22-2013 11:38 AM
  18. David Malcomess's Avatar
    Hi, I can't work out if my Samsung gs4 is using 4g.. I haven't seen anything on the status bar yet. What should I expect (or do)?? Recently got 4g prepaid access.
    08-06-2013 04:53 AM
  19. bwun's Avatar
    My "Caller Name ID" process was not running in the default view Downloaded devices. I had to scroll over to the Running applications to find the "Caller Name ID" app.

    Disabling this app did stop my 4G symbol from displaying. I should have left it running as I wonder if it was also affecting my battery life.
    10-09-2013 08:27 AM
  20. bwun's Avatar
    I found that if your "Caller Name ID" does not stay disabled, your "Caller Name ID" account may still be active. My new S4 came with a free trail (and I unknowingly accepted the trail). If you don't want the "Caller Name ID", you will have to drill down in the "Caller Name ID" settings menu to stop the trail or account. Then you can go into the Running applications and disable it.
    10-10-2013 05:45 AM
  21. jpriest007's Avatar
    Not a huge deal, but definitely annoying. When on WIFI, the 4GLTE is still displayed in the status bar alongside the WIFI symbol. In the next update, I hope this gets fixed, as it's rather annoying, and takes up precious status bar space when in WIFI.
    If you have Verizon go into the application manager find caller id app open it and disable it. That will fix the problem.

    Posted from my Galaxy Note 2 via Android Central App
    10-10-2013 10:29 PM
  22. Marla Milton's Avatar
    OMG...this did the trick. Just disable the Caller Name ID app. Jeez. I've been using data when I thought I was connected wirelessly.
    12-07-2013 06:22 PM
  23. centaurette's Avatar
    I know its a few months old, but it could also be your phone trying to send an SMS or MMS message. I just noticed that I was having this issue and when I restarted my phone, I got a notification that my MMS wasn't sent...and the 4G icon had disappeared. Once I tried to resend it, it came on again. Even though I deleted the message I was trying to send, the phone doesn't realize that so it's still trying. Try stopping your messaging app and see if that helps also. I'm sure Caller ID may be the culprit for some, but it wasn't in my case since my phone is rooted and I already deleted that app.
    03-14-2014 10:37 AM
  24. Narge's Avatar
    I found the caller name id app and turned it off. What exactly does that app do? I'm new to the s4 and I'm still navigating all of its features....is this app something we seriously need or just a "nice to have"?

    Thanks for all your help! Turning off this app did remove the 4g icon when wifi is running.
    05-04-2014 10:50 AM
  25. mahler9's Avatar
    I just went and turned off the Caller ID app and it had no effect on the ghost 4G icon. So I guess it does not work for every phone?
    05-04-2014 01:25 PM
31 12

Similar Threads

  1. Evo 4g LTE overheating and battery life
    By everlast316 in forum HTC EVO 4G LTE
    Replies: 42
    Last Post: 09-21-2015, 07:54 PM
  2. 4g LTE phones and ebay/craigslist
    By mylasthope in forum Verizon
    Replies: 6
    Last Post: 07-27-2012, 02:19 PM
  3. Just past a Verizon 4g lte poster and I have no 4g
    By bulvine420 in forum Verizon Galaxy Nexus
    Replies: 0
    Last Post: 07-15-2012, 10:37 PM
  4. Evo 4G LTE Problems and the Gnex
    By dmmarck in forum Verizon Galaxy Nexus
    Replies: 3
    Last Post: 05-28-2012, 05:47 PM
  5. Replies: 1
    Last Post: 09-16-2011, 08:40 AM
LINK TO POST COPIED TO CLIPBOARD