1. AC Question's Avatar
    Ever since I upgraded to 6.0, I have not been able to access my device from my Linux box. It worked fine last week under 5.0. But today, I tried to transfer files by plugging my device (MotoX) into my Linux box (running Ubuntu Studio 14.04.3) and I see it, I click and a file manager window opens, but I don't see any files and when I try to drag & drop, I get a "Cannot write to this location" message.

    Furthermore, the Ghost Commander app that had no problem transferring files directly to a microUSB drive under 5.0, can't even see said drive under 6.0.

    Fortunately, while looking for an answer to this problem, I discovered that 6.0 has its own built-in file manager that does allow me to transfer files to and from that USB drive.

    Is anyone else having this problem?
    01-13-2016 02:00 AM
  2. dpham00's Avatar
    Which moto x do you have?
    01-13-2016 07:15 AM
  3. ABook's Avatar
    2nd gen; not Pure; 64GB

    Today I tried connecting it to my old tablet running Win7 and Lubuntu 12.04 (no-pae, can't upgrade); neither could see that it was connected (but phone was charging off USB).
    01-14-2016 10:57 PM
  4. Crashdamage's Avatar
    I don't have a. Moto X. But I do have several Nexus devices running 6.0 or 6.0.1, stock unrooted and rooted. None of them have any problem connecting with my Fedora 23 box or a Win 10 Pro box, charging or not.

    Sounds like a problem with Moto's 6.0 update that you will have to wait for Moto to fix.

    Android since v1.0. Linux user since 2001.
    Laura Knotek likes this.
    01-15-2016 02:31 AM
  5. ABook's Avatar
    I think you're right, Crashdamage. Just plugged it into a laptop running Win 10 and no joy.

    As I stated above, at least the file manager that comes with 6.0 does work to transfer files to/from a USB flashdrive.
    01-15-2016 01:36 PM
  6. peterjt's Avatar
    Remember that the default connection is charge only. You have to explicitly change the connection to MTP.
    01-17-2016 07:31 PM

Similar Threads

  1. note 5 vibrating when i lift it from my desk
    By srinathp1988 in forum Samsung Galaxy Note 5
    Replies: 5
    Last Post: 01-15-2016, 10:34 AM
  2. Why can't I now not get on certain websites (I was able to get)?
    By AC Question in forum Samsung Galaxy Tab A (8 & 9.7)
    Replies: 1
    Last Post: 01-14-2016, 08:16 AM
  3. Why doesn't my touch screen work anymore?
    By BenBush in forum Samsung Galaxy A5
    Replies: 6
    Last Post: 01-13-2016, 06:31 AM
  4. Why is my background of application name turning black or green?
    By AC Question in forum Samsung Galaxy Note 3
    Replies: 0
    Last Post: 01-13-2016, 01:57 AM
  5. Galaxy S5: Can I organize Gallery photos into sub folders?
    By AC Question in forum Samsung Galaxy S5
    Replies: 0
    Last Post: 01-13-2016, 12:01 AM