1. Tifoso's Avatar
    That's the message I see in the Market when I decide to download an app. Problem is, it never downloads. It just hangs and downloads nothing. I have WiFi connected and 3G. This is on a Droid X. What am I missing here?
    07-20-2010 12:38 PM
  2. BluePLanetMan's Avatar
    Have you tried to reboot your phone? I had that once on my droid, I pulled the battery waited about a minute and restarted it.
    07-20-2010 12:43 PM
  3. Nebilim's Avatar
    restart the connection. it could be timing out
    07-20-2010 12:49 PM
  4. Tifoso's Avatar
    I toggled the WiFi off then back on and that seems to have worked. There is a black dot with a green arrows scrolling downward in the notifications bar. I assume this is the downloading icon.
    07-20-2010 01:17 PM
  5. Sundown's Avatar
    Just hit "Cancel Download" and then hit "Install" again. This happens to me a fair amount, and that's the simplest solution.
    07-20-2010 02:43 PM
  6. paul_aka_paul's Avatar
    I also found that going into Settings>Applications and clearing the cache for the market clears this up.
    07-20-2010 04:19 PM
  7. stonexu1984's Avatar
    i had same problem, i think you have to set gmail as your google account
    07-21-2010 12:10 AM
LINK TO POST COPIED TO CLIPBOARD