1. shilohlady's Avatar
    I was looking for a way to have an app read me my text messages and let me respond to them while driving. My son suggested Android Auto and it appears that it *should* work for this functionality. My car does not have Android Auto functionality however I can use bluetooth connectivity for the audio and theoretically a quick press on the screen would suffice. In testing it, however, texts were not coming through. I also noticed that Do Not Disturb was being activated when Android Auto (AA) was activated. For one test, I deactived Do Not Disturb (DND) after AA had activated and was able to ask a family member to send me a text. AA worked as expected, read me the incoming text and permitted me to compose and send a reply verbally.

    Since I didn't want to have to manually deactivate DND each time I got into the car, I started exploring. I found that after activating AA, DND is activated but specifically allowing ALL calls and NO messages! I tried to manually change this 'custom' notification but each time AA starts, it resets the custom notifications to this unwanted 'default'.

    HELP! I finally found something that will do exactly what I want but by default it turns off the specific capability I'm looking for.
    01-04-2018 10:09 PM
  2. hallux's Avatar
    Welcome.

    What messaging app are you using? Whatever you use needs to be Android Auto-enabled. I use Hangouts (I'm on Project Fi) and I can get text notifications and have the messages read to me.
    01-05-2018 05:57 AM
  3. sferrell615's Avatar
    When Android Auto is turned on it sets do not disturb to the following. Even if you change it to allow messages from all or whatever, the next time that you use Android Auto it sets do not disturb back to this.
    Samsung Galaxy S9
    Attached Thumbnails Android Auto activates Do Not Disturb automatically-screenshot_20180403-010659_settings.jpg  
    04-03-2018 01:10 AM
  4. sferrell615's Avatar
    I found a workaround for me with Samsung Galaxy S9...
    Give Bixby permissions to control 'Do Not Disturb'.
    This is in Lock Screen and Security | Other Security Settings | Do Not Disturb Permissions.

    I created a Bixby 'quick command' called ~ Android Auto and added
    open the Android Auto app
    turn off do not disturb
    open the Android Auto app (to bring Android Auto back to the forefront)

    It doesn't seem to work as consistent with 'show screen results' disabled as when enabled i.e. when I have 'show screen results' disabled it disables 'do not disturb' but then Android Auto (immediately) turns it back on.

    Now I just say 'Hi Bixby Android Auto' and it opens Android Auto without do not disturb enabled.
    Attached Thumbnails Android Auto activates Do Not Disturb automatically-screenshot_20180403-013443_settings.jpg  
    04-03-2018 01:35 AM

Similar Threads

  1. Galaxy s6 hotspot will not turn on
    By rickh1968 in forum Samsung Galaxy S6
    Replies: 6
    Last Post: 01-06-2018, 05:55 PM
  2. Does the hbogo app not work anymore on a samsung note 10.
    By Android Central Question in forum Ask a Question
    Replies: 0
    Last Post: 01-04-2018, 09:44 PM
  3. iPhone Contact Pictures to Android
    By Android Central Question in forum Ask a Question
    Replies: 0
    Last Post: 01-04-2018, 09:21 PM
  4. USB key not detected on 1 tablet but not the other
    By Android Central Question in forum Ask a Question
    Replies: 0
    Last Post: 01-04-2018, 09:13 PM
  5. My s8 pluses screen becomes pixelated once I use it in the dark. How do I fix it?
    By Android Central Question in forum Ask a Question
    Replies: 0
    Last Post: 01-04-2018, 08:04 PM
LINK TO POST COPIED TO CLIPBOARD