1. Jules_99's Avatar
    My phone switches wifi off when the screen has been off for a while and so it uses cellular data then. So far I haven't found a way to stop it doing this.

    So far I have

    - tried switching off battery optimisation
    - changed every setting I can find, inc in Developer options.
    - Used ADB to set sleep policy to 2 "adb shell settings put global wifi_sleep_policy 2"
    - Used every "wifi keep alive" app I can find
    - enabled incoming wifi calls on the phone in call settings in the hope this would make wifi stay on,

    ..and the wifi still switches off when the screen goes off, even with mobile data off.

    I have also tried using Tasker to switch wifi on if screen is off but this seems to cause a wifi or WhatsApp call to drop if the screen goes off as there is a gap whilst Tasker switches wifi back on after it goes off.

    i know this seems to be a known feature of Pie, but has anyone found a way to circumvent it?
    03-28-2020 07:10 AM
  2. mustang7757's Avatar
    Hi welcome!
    Which phone you have ?
    03-28-2020 09:26 AM
  3. Jules_99's Avatar
    Hi, thanks for your reply. I have an S4 mini flashed with Pie, Havoc OS but I understand this problem is common to many Pie models out of the box.
    03-28-2020 02:04 PM
  4. mustang7757's Avatar
    Hi, thanks for your reply. I have an S4 mini flashed with Pie, Havoc OS but I understand this problem is common to many Pie models out of the box.
    Usually should be something in wifi settings or power optimization , but your not on a stock firmware which would be harder to help because not sure where the dev of that ROM did or deleted , have you tried get in contact with the dev of that ROM?
    03-28-2020 02:33 PM
  5. Jules_99's Avatar
    Yes, I have but no answer. As the issue is common to other Pie phones I am hoping someone might have a work-around for it.
    03-28-2020 02:37 PM
  6. mustang7757's Avatar
    Yes, I have but no answer. As the issue is common to other Pie phones I am hoping someone might have a work-around for it.
    I do remember pie having something like that , but cant check my devices they all on android 10 maybe we see if other members can help out
    03-28-2020 02:40 PM
  7. mustang7757's Avatar
    Here is something to go over in wifi settings under advanced .


    Wifi Doze when screen off - how to defeat it?-screenshot_20200328-154242_settings.jpeg
    03-28-2020 02:43 PM
  8. mustang7757's Avatar
    Make sure no medium or extreme power saving modes are on
    03-28-2020 02:45 PM
  9. Jules_99's Avatar
    Looking under Settings/Apps and Notifications/Advanced/Battery optimisation/All apps, so I can try to turn optimisation off for whatever controls WiFi, I see hundreds of apps and system apps, but cannot see one which looks like it controls WiFi.

    I guess it could be called something different.
    03-28-2020 02:46 PM
  10. mustang7757's Avatar
    Also go to settings>apps>3 dots upperright corner tap > special access>scroll to wifi control make sure things are toggled off to control wifiWifi Doze when screen off - how to defeat it?-screenshot_20200328-154759_settings.jpeg
    03-28-2020 02:50 PM
  11. Jules_99's Avatar
    I have looked under WiFi control as you suggest (good idea, thanks) , and there is a list of apps which can control wifi. I have turned off "work profile setup" because it sounds like a system app. The others look like regular apps. I will try to attach a screenshot. Wifi Doze when screen off - how to defeat it?-screenshot_20200328-195941.jpg.
    03-28-2020 03:04 PM
  12. Jules_99's Avatar
    These are my wifi options.Wifi Doze when screen off - how to defeat it?-screenshot_20200328-195518.jpg, and the developer options for wifi are here. Wifi Doze when screen off - how to defeat it?-screenshot_20200328-195604.jpg.

    I will try it for a while to see if the WiFi Control setting change works. Sometimes it takes a while go go to sleep.
    03-28-2020 03:07 PM
  13. mustang7757's Avatar
    Ok that's good work profile might interfere, also toggle on automatically connect wifi in known places
    03-28-2020 03:09 PM
  14. Jules_99's Avatar
    OK, I will try that also, thanks for your help. I will see how it works tonight. Wifi is still on at the moment but is is not always predictable.
    mustang7757 likes this.
    03-28-2020 03:38 PM
  15. mustang7757's Avatar
    OK, I will try that also, thanks for your help. I will see how it works tonight. Wifi is still on at the moment but is is not always predictable.
    Ok , your welcome, keep me posted .
    03-28-2020 03:39 PM
  16. Jules_99's Avatar
    OK, so after a day of testing, the phone now does seem to work OK and WiFi does not now switch off when the screen goes off and the phone dozes.

    The fix appears to be to stop "Work Profile Setup" from controlling the WiFi. The procedure might vary slightly on other Pie phones but on mine it was:

    Settings / Apps and Notifications / Special App Access / WiFi Control - then 3 dots at the top to enable "Show System". Scroll to "Work Profile Setup" and switch this to "Not Allowed".

    It might be nice to edit the Work Profile somehow but I'm not sure it's even possible. At least we have the option to run the WiFi on all the time if you want now, if you have this problem with Pie switching wifi off and using cellular data when the screen is off as I know many have.

    A BIG shout out must go to Mustang7757 for suggesting I try the WiFi Control option, deep in the settings. Thanks a lot and I hope it works for others.
    mustang7757 likes this.
    03-30-2020 06:38 AM
  17. mustang7757's Avatar
    OK, so after a day of testing, the phone now does seem to work OK and WiFi does not now switch off when the screen goes off and the phone dozes.

    The fix appears to be to stop "Work Profile Setup" from controlling the WiFi. The procedure might vary slightly on other Pie phones but on mine it was:

    Settings / Apps and Notifications / Special App Access / WiFi Control - then 3 dots at the top to enable "Show System". Scroll to "Work Profile Setup" and switch this to "Not Allowed".

    It might be nice to edit the Work Profile somehow but I'm not sure it's even possible. At least we have the option to run the WiFi on all the time if you want now, if you have this problem with Pie switching wifi off and using cellular data when the screen is off as I know many have.

    A BIG shout out must go to Mustang7757 for suggesting I try the WiFi Control option, deep in the settings. Thanks a lot and I hope it works for others.
    Glad I could help , your welcome!
    03-30-2020 09:18 AM

Similar Threads

  1. Lock Screen brightness at night - any way to Dim while charging?
    By siglerm in forum Samsung Galaxy S10 & S10+
    Replies: 4
    Last Post: 03-29-2020, 09:34 PM
  2. Quicker fingerprint unlocking from blank screen
    By williams448 in forum Samsung Galaxy S20 & S20+ & S20 Ultra
    Replies: 5
    Last Post: 03-28-2020, 07:18 PM
  3. How do I unblock my kid’s tablet from iwawa?
    By Amaclaire in forum Android 7.0 Nougat
    Replies: 1
    Last Post: 03-28-2020, 07:08 AM
  4. Replies: 1
    Last Post: 03-28-2020, 02:20 AM
  5. my vpn cannot be turned off(there is no off)
    By antelopevalley83 in forum General Help and How To
    Replies: 3
    Last Post: 03-27-2020, 10:29 PM
LINK TO POST COPIED TO CLIPBOARD