08-14-2018 03:09 PM
27 12
  1. NTBeard's Avatar
    Hi all, I'm having some problems with my Android TV box. When I try to factory reset the box, it boots with the initial setup screen as you'd expect. However when I restart the box, it returns to its pre-reset state, with all my apps and settings as they were before the reset. I have tried the following:

    - Full factory reset
    - Installing older firmware, deleting partition cache, then reinstalling the new firmware

    Despite all this the box still boots with my previous apps/data/settings.

    Any help with this is much appreciated. Thanks in advance.
    05-08-2014 12:41 PM
  2. B. Diddy's Avatar
    Welcome to Android Central! It's hard to troubleshoot these Android TV boxes, since they're often so generic, without any real documentation or support.

    Try going to Settings>Backup & reset​, and uncheck Automatic Restore. Then try the factory reset again.
    zkSharks and NTBeard like this.
    05-08-2014 12:46 PM
  3. NTBeard's Avatar

    The Auto Restore was actually checked (I feel stupid now...), and that did help a little, but strangely some settings are still there. I'll keep having a play with it. Like you say it's a generic MX2 clone so it's a little difficult. Thanks for your help!
    B. Diddy likes this.
    05-09-2014 05:49 AM
  4. idroidnation's Avatar
    Did you try inserting a toothpick in the av socket while unplugged and holding it and connecting the power cable and powering it on?
    07-24-2014 01:08 PM
  5. JUS4FUN's Avatar
    I have m8s that does start at all. Blue light comes on then nothing. I tried to use a toothpick in the av but still nothing . Any other ways?
    07-08-2015 12:17 AM
  6. jeff14510's Avatar
    My M8 was working perfectly. Overnight it developed a problem where when I move between apps the picture goes blank for a few seconds. Sometimes, it reboots constantly. I have tried to do a factory reset but pressing the button and then plugging it in does nothing. Any ideas? Thank you.
    08-15-2015 03:45 PM
  7. gingerkidht's Avatar
    So I found this forum and need help. When I went to do the kodi update in 2015 my box display on the tTVmessed up. The / key won't help and I only see part of what I watch. When I switched tvs it does the same thing and in the display settings it shows it locked to the other tv and I can't change it at all. Anyhow nothing I have tried works. What should I do....?
    09-15-2015 08:16 PM
  8. crafael's Avatar
    I have m8s that does start at all. Blue light comes on then nothing. I tried to use a toothpick in the av but still nothing . Any other ways?
    I have the same problem, what can I do to resolve the problem? Can someone help me?
    12-03-2015 05:27 PM
  9. lemont3444's Avatar
    I have the M8S and it is experiencing the same problem. No blue light and it will not power up.
    01-13-2016 03:30 PM
  10. AndyH42's Avatar
    I've had a couple of these boxes ( mx2) and to be honest there crap. They last about 6 months and then give up, get yourself an Amazon fire TV box or Nvidia shield TV box. There a bit more expensive but so much better, especially for kodi.

    Posted via the Android Central App
    01-18-2016 01:23 AM
  11. matricomg's Avatar
    when reseting a box first hold the reset button down wait 15 sec unplug the device wait 15 sec plug it back in wait 15 sec and release the reset button this will erease everything to factory setings and you will have to start over.
    01-26-2016 09:13 AM
  12. Blerim Gega's Avatar
    I have notice that if u unplug the network cable , or disconnect from wireless it stays on . So thats what I did , than I tried factory reset and worked
    03-19-2016 12:53 AM
  13. hpat99's Avatar
    Doesn't work for me...
    04-22-2016 11:38 AM
  14. MAN6074's Avatar
    Hi all
    I updated firmware of my Ki Plus Android TV box and the box stopped displaying anything after first reboot,
    I will be so grateful if someone can help, I tried my level best to find out hard reset button but could not find, please help
    04-24-2016 03:41 PM
  15. clorice123's Avatar
    hi there i am having a problem when i reboot my goobang doo .box. the time goes back to jan 1970. and .i factory reset it dose the same if i reboot it.
    04-29-2016 08:17 AM
  16. MrE Benstead's Avatar
    Download Clocksinc app from playstore, open app, go to settings, Down to Enable and tick box, scroll down to Detect time zone and tick that box, scroll down to Sync on boot and tick that box. Reboot your box, it will show the wrong date and time but correct itself after aprox 30 seconds. Hope it works for you. Has worked on 3 boxes I own
    05-24-2016 06:08 PM
  17. paul hargreaves1's Avatar
    I have mx boxes and there stuck on mbox screen any advise
    06-14-2016 10:13 AM
  18. jayraj22's Avatar
    I have the same issue with my android box m8s
    08-04-2016 01:54 AM
  19. caper46's Avatar
    Just curious if you found a fix for this? I have the same problem with my m8s
    08-14-2016 08:00 PM
  20. jarralass's Avatar
    I have mx boxes and there stuck on mbox screen any advise
    Have u found a solution? Im having the same problem. Blue light is constantly on. Cant turn the box off and it seems yo be locked on startscreen
    10-06-2016 07:13 AM
  21. D-heron58's Avatar
    I found that if I just pulled the power plug out for 5 seconds or so then plug it back in the box would start up
    10-25-2016 12:36 AM
  22. Mike Smith52's Avatar
    Hi there I am having the same problem no reset button in the av socket there is one on the bottom press this down and waited but nothing now it is stuck on mbox splash screen please need help
    09-12-2017 02:09 AM
  23. Seesaw Babagnush's Avatar
    I purchased three of these media boxes in an estate sale...
    their is a tactile switch behind the A/V jack..
    Android TV Box factory reset does nothing-img_0674.jpg

    I was able to get what I call a "BootLoader" menu when I hold the tactile switch in with a Toothpick... then insert the power plug and hold it for a few seconds... then release the toothpick and let it boot up...
    Android TV Box factory reset does nothing-img_0675.jpg

    This should help you validate the unit can do this Cold Boot to a BootLoader screen...

    My issue is with loosing the whole network... wired or Wireless...

    I will need to figure out if I can load another image from the SD card on Bootup... or use an external USB network device...
    thought I just wanted to share what I'm doing
    10-21-2017 03:06 PM
  24. Seesaw Babagnush's Avatar
    10-21-2017 03:06 PM
  25. judydreamz's Avatar
    Good Day,

    My Android TV box is stuck on the pic below:

    I have followed a few youtube instructions, but it still does not reboot.
    I have done a factory reset, clear cache, mount/system and then choose the option to reboot.

    It goes to an android screen, but then opens on this screen again.

    Please help
    Android TV Box factory reset does nothing-recovery-screen.jpg
    04-16-2018 03:45 AM
27 12

Similar Threads

  1. Why are Android phones made of plastic?
    By Trackr in forum General News & Discussion
    Replies: 79
    Last Post: 09-10-2016, 07:36 AM
  2. Tic Tac Toe Glow(free game for android)
    By Nayem Islam1 in forum Android Games
    Replies: 1
    Last Post: 02-22-2015, 06:31 AM
  3. Why there no co-ordination among apps in Android ?
    By ilikeandroid123 in forum AT&T HTC One
    Replies: 7
    Last Post: 05-09-2014, 01:46 PM
  4. Happy day! My wife switched to Android!!
    By OceanSD in forum New to the Forums? Introduce Yourself Here!
    Replies: 11
    Last Post: 05-09-2014, 12:05 AM