1. WeepingBat's Avatar
    My phone model is the GT-19082 (Samsung galaxy grand duos) Currently running on jellybean 4.2.2 , if i stand correctly.Starting off, I needed to do a recovery boot as my battery drains too fast and somehow charges very fast too as in 16% to 60 % in mere minutes, I followed as instructed (hold power button, home and volume up while the phone was off), the phone went on , and i was directed to a page with three options which are recovery , fastboot and normal boot , however i can only navigate with the home screen button between the three and not be able to select either of them . Iam so close to rebooting , any help or tips is highly appreciated! Thank you.
    06-22-2014 12:51 AM
  2. B. Diddy's Avatar
    Welcome to Android Central! Not sure if you also posted in this other thread, but refer to it for a response: http://forums.androidcentral.com/ask...cessfully.html
    06-22-2014 02:49 AM
  3. Izzdanial Xp's Avatar
    Welcome to Android Central! Not sure if you also posted in this other thread, but refer to it for a response: http://forums.androidcentral.com/ask...cessfully.html
    i dont know why but my android isnt displaying the same reboot page as the one shown in the video , it looks much simpler like the screen is all black and it displays only like the following :
    Select Boot mode:
    [VOLUME_UP to select. VOLUME_DOWN is OK. ]

    [Recovery Mode]
    [Fastboot Mode]
    [Normal Boot] <<==


    But then, i cant select using the volume button and cant press ok with the volume down button , although both works flawlessly , the only thing that can i can use to navigate between these options is the home button , sorry for any inconvenience , your reply is very much appreciated . Thank you ! Oh and if it helps my android is on 4.2.2 jellybean update, and i recently factory reset it .
    06-22-2014 03:20 AM
  4. B. Diddy's Avatar
    Did you get the phone brand new or used? If used, I wonder if the previous owner installed a custom recovery.

    So you're saying that on that screen, when you press Volume Up, the arrow doesn't scroll down to the next selection, and Volume Down won't execute it? If you can move the arrow with the Home button instead, have you tried pressing the Power button to execute?
    06-22-2014 03:24 AM
  5. Izzdanial Xp's Avatar
    Hmm , this was a hand me down from my close family members, he bought it from someone , but however after giving it a few good tries again, i was finally redirected to what seemed like the legit reboot page as it looked like the one in the video link you sent me , didnt get the chance to reboot , as screen went instantly black after pressing the volume buttons to scroll the options, well im gonna give it more tries and see if i can get redirected to that same page again and yes i have tried pressing the power button , only the home button works, but i have yet another problem as fast as this phone drains my batteries , it also charges very fast 20% to 100% in mere minutes,like i stated on the other thread , is this a common problem with the battery or is this something new?! And should i consider trying another battery pack or charger? Thanks you.
    06-22-2014 03:50 AM
  6. B. Diddy's Avatar
    That kind of battery behavior could suggest a failing battery. I agree, try a new battery.
    06-22-2014 03:58 AM
  7. Izzdanial Xp's Avatar
    Thanks man, youve been such great help, I'll get a new battery soon and see how it turns out.
    B. Diddy likes this.
    06-22-2014 04:00 AM

Similar Threads

  1. Galaxy s5 touch screen problem??
    By Kelvin Alexander1 in forum Ask a Question
    Replies: 3
    Last Post: 08-26-2015, 04:51 PM
  2. Both WiFi and Mobile data icones are on all the time (AT&T)
    By lordielordie in forum Samsung Galaxy S4
    Replies: 1
    Last Post: 07-03-2014, 09:35 AM
  3. Samsung galaxy s3 mini gtl8190 memory problem, pls help
    By nelly boy in forum Ask a Question
    Replies: 5
    Last Post: 06-23-2014, 04:07 PM
  4. Lost phone, no back up, help me retrieve data?
    By AC Question in forum Ask a Question
    Replies: 1
    Last Post: 06-22-2014, 12:27 AM
  5. HTC Boot Loop Flip Out
    By capn_tack in forum HTC One M7
    Replies: 1
    Last Post: 06-21-2014, 11:24 PM