1. Kaelstrom's Avatar
    My phone was still on this morning and the battery had about 70% life remaining. I went to my class and I was actually still using it. So after an hour or so, I checked my phone again to find that it was dead. It won't fully turn back on.

    I tried removing and putting back the battery, but it only vibrates and shows the logo then dies again. Tried charging it w/battery, won't turn on and doesn't even show that its charging. Tried charging it without the battery, it vibrates then small red light appears briefly, then dies. I couldn't access Download mode and Recovery mode either.

    I tried my friend's battery as well, but to no avail. I'm 100% sure that we both had an S3 and that his battery was compatible with mine.

    My phone has been already turning off on its own in the last two months, usually 1-2 or times a day. It didn't really bother me that much so I didn't try to get it checked. It only got worse today when it actually died for good. :/

    I know this question has been asked already, but I couldn't find a clear answer on those other threads. Is this the SDS thing I've been hearing about? Is there anymore method/way I could try to possibly revive my phone? Or should I just go straight to Samsung and get this replaced?

    Not sure if these matter, but here's some additional info:
    Model: SGH-T999
    FCC ID: A3LSGHT999
    10-27-2014 06:19 PM
  2. butterfly210's Avatar
    U might need a new battery...
    10-27-2014 06:30 PM
  3. Kaelstrom's Avatar
    I don't think it's a battery problem. I already tried my friend's battery, which was the same as mine, and it still didn't work.
    10-27-2014 06:57 PM
  4. belodion's Avatar
    A problem with the power button or associated circuitry, perhaps?

    When you tried your friend's battery, did you get zero response, or the partial response you were getting with your own battery?

    Posted via the Android Central App
    10-27-2014 07:05 PM
  5. Kaelstrom's Avatar
    I got the same partial response when I tried his battery.
    10-27-2014 07:13 PM
  6. belodion's Avatar
    I think you're going to have to get that diagnosed....it sounds to me like a hardware problem. Probably not the SDS because I believe that an update patch took care of that some time ago.
    It may be worth reposting the problem in the Galaxy S3 forum first where others more familiar with the device may be able to help.
    Anyway, good luck with it.

    Posted via the Android Central App
    10-27-2014 08:04 PM
  7. Rukbat's Avatar
    Sounds exactly like water damage (which can happen if you bring an ice cold phone into a warm humid place, it doesn't have to be dropped into a lake). Vibrating when you plug the charger in with no battery eliminates the battery and points to some corrosion inside the phone.
    10-27-2014 10:36 PM

Similar Threads

  1. My Autocorrect is all screwed up!!!
    By Moltres_rider in forum Samsung Galaxy S4
    Replies: 4
    Last Post: 10-29-2014, 05:59 AM
  2. Finding my posts
    By Marioclement23 in forum General Help and How To
    Replies: 3
    Last Post: 10-28-2014, 05:44 PM
  3. Why won't my Nexus 4G charge?
    By ne0pandemik in forum Ask a Question
    Replies: 1
    Last Post: 10-27-2014, 03:53 PM
  4. any idea when or where to get kitkat 4.4.4 on my note 3?
    By kami8586 in forum Verizon Samsung Galaxy Note 3
    Replies: 0
    Last Post: 10-27-2014, 03:47 PM
  5. How do I get my Flash CS6 test APKs to play background music?
    By davenation in forum Legacy Android & Other OS's
    Replies: 0
    Last Post: 10-27-2014, 03:15 PM