1. CherylLawyer's Avatar
    FIXED!!!! I somehow got onto my USB settings on my phone where I had options as to how I would use the USB connection. I swiped from top to bottom and selected USB. Sorry I can't be more detailed but I'm still learning this darn smartphone thing. So I'm guessing that the setting got changed when I did a recent update.
    pkcable likes this.
    08-16-2016 08:44 AM
  2. Kenneth Hill2's Avatar
    When I plug my Galaxy S5 into my PC USB I find Samsung SM900V but when I click on it nothing shows. I think I accidently deleted something. Prior to this when I clicked on Samsung in my PC directory it showed many files.
    09-05-2016 05:42 PM
  3. Kenneth Hill2's Avatar
    Thanks. I went to USB Protocol and selected MTP and now it works.
    09-05-2016 06:05 PM
  4. ChrisPCritters's Avatar
    ANTHONYN2392 has the right idea, though it looks a bit different on my phone. Try this:

    Plug phone into the computer.
    Unlock the phone.
    Pull down the menu by swiping from the top of the screen down.
    Click on Power options.
    Select File Transfer.
    Approve connection.
    Computer will then ask twice how you want to connect—once for the phone and once for the card.

    Normally when I connect my phone to the computer, it defaults to charging mode, so I have to manually change it to File Transfer. When I select Power options it gives me several: Charging, File Transfer, Photo Transfer, Software Installation, and MIDI.

    Thanks ANTHONYN2392.

    Cheers,
    Chris P. Critters
    09-26-2016 06:11 PM
  5. Summu's Avatar
    I was having the same problem. I just reinstalled the drivers and now its working great. Thanks =D
    Where to reinstall the drivers? In phone or pc? Can anyone help?
    11-09-2016 09:57 PM
  6. anon(632115)'s Avatar
    You need to install the drivers on your PC. They can be found at the top of the page here Technical Documentation | SAMSUNG Developers
    11-10-2016 04:45 AM
  7. radoslw's Avatar
    Ive done it! Try to install "MIUI USB Settings" from Google Play store and that's it. It works!
    11-11-2016 06:54 PM
  8. PetraK87's Avatar
    I installed the app above and driver again on my laptop and neither worked. However I then remembered how I solved this last time and got it to work! I wondered what had changed so I had this problem once again and it's both times been this:

    I'd bought a new USB cable for my charger. Turns out they aren't all created equal. My new cheap one only connects to charge, however not to upload and register my phone as a device. I plugged in another I had around and it works fine! There isn't anything different written on the cables as far as I can see, so no idea why.

    Therefore worth trying a different cable, preferably one that came with a hard-drive or your phone. Although the one that works for me now is a poundland one and the budget one I bought off eBay doesn't. I'm not sure if the cables can somehow be partially faulty in some cases.
    11-17-2016 12:12 PM
  9. SpiderSymbiote's Avatar
    Ok I was having the same problem with my S5 connecting to my computer but not being able to see my files or transfer anything. If you have Marshmallow on your phone you need to open settings then go down to about phone, scroll down to build number and tap it repeatedly until it says developer options unlocked. Now go back to settings find developer options go in and scroll down till you see USB configuration. Set it to MTP(Media Transfer Protocol). You should be good to go from there. Hope this helps anyone who has this problem. If you don't know if you are running marshmallow just go to settings down to about phone and find android version and tap it till a picture appears. tap that picture and you should see what version you are running.
    11-17-2016 01:05 PM
  10. wallymortar's Avatar
    I tried the several suggestions from users on my Samsung Galaxy S5, e.g. updating or uninstalling/reinstalling device drivers in Win 10, etc. None of these worked. Then I noticed a USB connection icon in my phone's status bar. I clicked the icon and there was a menu titled "Use USB for" and there were 6 radio button choices. The one that was checked was "Charging". The others were other functions, including "File Transfer", "Photo Transfer", "Software Installation", "MIDI" and "Media device (USB 3.0) when the phone is plugged into a USB 2.0 port. I selected "File Transfer" and then the phone memory and installed SD card were visible to my Win 10 PC. When I plugged the phone into a USB 3.0 port, the "Media device (USB 3.0) selection disappears but if you then select "File Transfer", the phone and installed SD card are again visible to the Win 10 PC. I assume file transfer speed will be consistent with the USB version to which connected, i.e. faster on USB 3.0 than USB 2.0.
    12-17-2016 07:23 PM
  11. rodderscas's Avatar
    Figured it out!!
    Enable developer mode in "about phone" then go back to setting and you will see developer mode. Open developer mode and scroll down to "USB Config" and and change setting to MTP (media transfer Protocol)
    After I did this the second I plugged the phone in, my computer saw it!

    THIS is the real answer. I believe a recent update is the culprit and it changed the type of transfer available when you plug in a USB cable from your phone to your PC. It changes to Charge Only. You need to make it Media File Transfer or whatever it is called. Why you would automatically know how to do this heaven only knows. Thanks very much to the poster of this solution.
    12-20-2016 05:25 PM
  12. Benice Lee's Avatar
    I don't know if this will help you guys. We all know we can connect different types of USB in to our samsung s4,s5 we can connect a small usb piece or the big piece if that makes sense to you guys? In summary, its the head piece if i connect the giant head piece it won't connect to my computer but if i connect the small one it will work its pretty weird but try it out and make sure u enable developer option and turn on USB port
    01-09-2017 05:21 PM
  13. mrgts4's Avatar
    Thanks for the options you all supplied. Mine was fixed by dialing the number and changing the setting to media file transfer. My only problem now is my old s5 has a broken screen so I cant change anything on that as the screen doesnt work, I guess I wont be transferring anything off that to my new phone. I had only updated it 4 weeks ago. I think I might refrain from updating my phone from now on.

    Cheers
    01-22-2017 06:45 PM
  14. mrbeechmont's Avatar
    I never sign up or post in these forums but this has been driving me nuts for months and I just figured it out so figured I'd share...another stupid modification to a system that worked just fine before...

    plug in your phone to your CPU
    on your phone, swipe down to see the open apps, it should say charging with USB, click here for more options
    click more options and select file transfer or photos or whatever else you want the phone to do besides just charge from the USB
    what a stupid change
    I hope this helps everybody...
    01-24-2017 08:20 PM
  15. Omniest's Avatar
    It may be simple, but I was just having this problem and realized that I had the wrong usb cable connected. I have some cables that will only charge devices. I switched it out and it connects perfectly.
    You are the only person I've found on the internet that has had the answer I needed. No one else's solution worked until I read your comment. This was my exact problem and I'm so grateful for your answer. You saved the day as I would have NEVER thought of switching cables. Thank you times a thousand!
    02-25-2017 11:07 AM
  16. korok_janaj's Avatar
    Figured it out!!
    Enable developer mode in "about phone" then go back to setting and you will see developer mode. Open developer mode and scroll down to "USB Config" and and change setting to MTP (media transfer Protocol)
    After I did this the second I plugged the phone in, my computer saw it!
    This worked for me! Thank you!
    04-09-2017 08:00 PM
  17. foresthome54's Avatar
    This worked for me when I had the same problem

    Go to settings

    Open developer options check USB debugging

    In that same screen scroll down to USB configuration and check the media transfer button or picture transfer protocol whatever you are trying to do.

    Hope this helps
    05-11-2017 10:28 AM
  18. Bluejay3's Avatar
    Hello, i've had this problem as well where it would charge and show up but not allow me to transfer files. what worked for me was clicking on the message on the phone that says its charging which will bring up a menu where you can set it to file transfer.
    07-15-2017 02:04 PM
  19. samsungs5usbfix's Avatar
    BOOT IN SAFE MODE!!

    I had the same issue tried everything (drivers, smart switch, kies, *#0808#, developer mode etc) but samsung support said to boot in safe mode power off, hold volume key down, the bottom left of your screen should now say safe mode

    this allowed the usb option to show up in the status bar AND! for it to be shown on my PC/MAC
    12-30-2017 10:37 AM
  20. Jeoffrey Auscia's Avatar
    On your phone, ppen up your contacts and go to Keypad Tab and dial: *#0808#
    On the options, choose 'MTP+ADB'
    That should do the trick
    04-17-2018 09:49 PM
70 123

Similar Threads

  1. Replies: 1
    Last Post: 02-25-2015, 09:09 PM
  2. Posting pictures to AC
    By Kingjamesv in forum Ask a Question
    Replies: 1
    Last Post: 02-23-2015, 12:11 AM
  3. Replies: 0
    Last Post: 02-21-2015, 09:50 PM
  4. Replies: 0
    Last Post: 02-21-2015, 09:48 PM
  5. Replies: 0
    Last Post: 02-21-2015, 09:36 PM
LINK TO POST COPIED TO CLIPBOARD