1. AC Question's Avatar
    i have a samsung galaxy trend gts7392 (ROOTED) and im having a memory problem...... when i connect it with my pc it shows -1048976..something something memory(internal memory, my sd caed is fine) and i cant add any folders,apps,etc in the internal memory of it. and also when i try to use "my files" to explore the memory it says there is no folders....what do i do to fix it????
    05-18-2015 10:59 AM
  2. TJ04's Avatar
    i need to fix it please help...(by the way im the threat author...lol)
    05-18-2015 11:06 AM
  3. mrsmumbles's Avatar
    Have you tried using a different file manager to explore your folders? Total Commander is good, and ES File Explorer.
    05-18-2015 12:22 PM
  4. TJ04's Avatar
    well... i havent.. but thats not the point.... the phones memory is at a negative value, which is not letting me access or edit my phones internal memory....here is a photowhy the heck is my android phones memory at negative value??!!-untitled.png
    i also tried to do factory reset but it didnt help, i even unrooted my phone but it didnt help either
    05-19-2015 12:07 PM
  5. Rukbat's Avatar
    It looks as if your phone's internal storage is corrupt. If it's a software problem, reinstalling the ROM from scratch (including partitioning) might fix it. If it's a hardware problem, you need a new motherboard (or a phone repair shop into replacing chips on the board, which isn't normally done commercially, but some store owners are old enough to remember when repairability was part of a device's specification).

    The number you're seeing is actually a HUGE number - when a number is represented in binary, which it is in a computer regardless of how it's shown to the user), it "wraps" - that is, when it gets to the maximum number that can be represented as a signed positive number makes it a signed negative number one less. So if 100 were the maximum positive signed number, adding 1 to 100 would make it -99.) Since the phone doesn't have that much internal storage (as much as the number being shown), something's wrong.

    If My Files, when you're looking at All, says there are no folders, and the phone still works (which it does, or My Files wouldn't be running - which says that there are folders), there are a few possibilities of corruption in Linux (which would be fixed by reflashing the ROM) and a much less likely possibility in hardware. A reflash is the easiest way (see [Samsung] How to flash Stock ROM via ODIN) - 10 minutes and, if that's the problem, the phone is working. (And if not, it's a hardware problem, so it doesn't matter if it has any ROM in it or not.) The only problem there is that you probably won't be able to back anything up, so if it's not backed up already, you may lose it. (Pictures, videos, songs, you can probably back up. Data stored by apps - game scores, settings, etc. - might get lost.)
    TJ04 and mrsmumbles like this.
    05-19-2015 04:34 PM
  6. TJ04's Avatar
    im gonna try what u suggested Rukbat,
    i'll inform you if it worked within the next 5 hours thank you
    05-20-2015 01:07 AM
  7. TJ04's Avatar
    umm.... the thing i said earlier "i'll inform you if it worked within the next 5 hours thank you" i think i cant do that my internet connection is slower than i thought.... so until i finish downloading the stock rom i wont be replying,
    FYI my internet download manager says its gonna take about 15-19 hours
    05-20-2015 01:44 AM
  8. TJ04's Avatar
    THANK YOU SO MUCH Rukbat!!!!!!!!!!!!!!!!!
    It WORKED!!! now i can finally start playing those awesome games!!!!
    and by the way do i have to end this thread or does it end itself over time????
    and if you are wondering how i downloaded the file so fast(even though it said it was gonna take like 15 hours) lets just say some secrets are meant to kept a secret.... XD
    05-20-2015 03:52 AM

Similar Threads

  1. Is that the new Apple watch?
    By Jermaine Gray in forum Samsung Galaxy Gear
    Replies: 8
    Last Post: 07-10-2015, 12:05 PM
  2. Why doesn't my phone charge after the battery died?
    By AC Question in forum General Help and How To
    Replies: 2
    Last Post: 05-19-2015, 04:39 PM
  3. Why am I receiving Error message when entering my phone number?
    By AC Question in forum General Help and How To
    Replies: 1
    Last Post: 05-18-2015, 11:13 AM
  4. Replies: 1
    Last Post: 05-18-2015, 10:36 AM
  5. Why can't I establish a reliable connection to the serve?
    By AC Question in forum General Help and How To
    Replies: 1
    Last Post: 05-18-2015, 10:35 AM