1. AC Question's Avatar
    It is increasing clear that nobody in google really knows how to cure this. True, some people do find that clearing data in Google Play and Google Framing Services helps, but if that fails, there is a complete lack of knowledge about how to fix this.

    A factory reset will not always cure it either, despite what they say. Why? Because that's what actually caused my problem.

    Until somebody within Google really starts to take this problem seriously, people are going to be stranded and unable to access apps etc through Google Play. If you can't access Google Play, then basically you're stranded.

    If anybody has any other suggestions, which work, all of us who are stranded would be grateful.
    08-26-2015 03:01 PM
  2. B. Diddy's Avatar
    Welcome to Android Central! Can you reference some other post or article detailing this issue? It would help if you registered on this forum, so that you can respond in threads you already created.

    Google Talk is outdated and was replaced by Hangouts a while ago. The fact that you're having issues with Google Talk authentication suggest your device is fairly old--do you know if its Google Play Services is up to date? Have you updated Google Talk to Hangouts? Is the device up to date in terms of system updates?
    08-26-2015 05:56 PM
  3. Aaron Thomas Barker's Avatar
    Yes, the device is a bit old HTC Flyer 32GB wifi/3G and running Android 3.2.1

    However, it was working with Play Store etc before I did a factory reset. I did this because it was bought off eBay and still had the person's gmail account etc active. Yes really! There were also some links to shall we say, not the sites I want my boy to visit, so to be safe I did a factory reset. Bad news! I can get Play Store working but it will not let me add any apps. Google Play Services is not present neither can I add it. So I'm effectively locked out of getting new apps.

    When I try to add an app I get a message saying Google Talk Authentication error and also another error showing a server response error.
    I've tried sync, my gmail account will sync within the HTC no problem. If I use my laptop to access Play Store, I find that no devices are listed under my account, hence I can't download any apps!

    I've been told by a very nice chap within Google (help desk) that I need the Google Play Services file which is not present in my list of applications. I doubt whether I can simply add the file anyway to my device as HTC don't provide enough access. (I think). Their android version doesn't include any file manager or apk device, otherwise I would be home and dry. So I'm marooned, well and truly!

    Personally, I suspect that Google Talk has just been switched off and is non responsive which means unless you've updated before the switch, you're stuffed. I may of course be wrong there.

    Any suggestions for rescue much appreciated. But I've had a belly of clearing data and cache accounts and it obviously needs somebody who really understands what's going on and that's not me!
    08-27-2015 04:00 AM
  4. B. Diddy's Avatar
    After you did the factory reset and you went through the Setup Wizard, you added your Google account, right? It didn't let you skip this step, did it? Just want to make sure there is a valid Google account that the device is linked to.

    On your computer browser, go to the Google Play Services app page: https://play.google.com/store/apps/d...roid.gms&hl=en. Click on the Installed button, and see if that device shows up in the list. If it's there and says it can be installed, select it, then wait up to a minute or so for the device to start installing.
    08-27-2015 11:12 AM
  5. Aaron Thomas Barker's Avatar
    Yes, my account is valid and guess what it syncs with gmail every time and whenever I ask it to sync. Google Play Services is no help because my device is not listed. The system says "you don't have any devices". Yes I do, it's just that the Google Play Services doesn't link to my gmail email address which is synced (yes it receives mail etc. etc.).
    08-27-2015 12:02 PM
  6. B. Diddy's Avatar
    Ok, try downloading the apk file and see if you can install it manually: Google Play Services v7.8.87 Begins Rolling Out With Support For Nearby API And New Account Management Links [APK Download]
    08-27-2015 12:20 PM
  7. Aaron Thomas Barker's Avatar
    Thanks. Good idea and looks like it should have worked. The file was downloaded successfully BUT I get an error message saying "there is a problem parsing the package". Not sure what this means. So near ....... !
    08-27-2015 12:56 PM
  8. Aaron Thomas Barker's Avatar
    The 'parsing problem' may be due to HTC's lack of an obvious apk installer. There must be one of some kind I guess, but it's not listed as an app and need addressing in a specific way for it to work? Just guessing.
    08-27-2015 03:51 PM
  9. B. Diddy's Avatar
    That's strange. I think any Android device should be able to install a valid apk file. I'm afraid I've run out of ideas at this time. One last question--is the device rooted? Run an app like Root Checker to see. If someone rooted it and modified it, something they did might have led to this issue.
    08-27-2015 05:46 PM
  10. Aaron Thomas Barker's Avatar
    Ok. This is how the situation has been resolved for me.

    The answer lies outside of the Android system.
    If you have the ability to connect to a PC or laptop then this MAY work for you.

    I use Linux Mint LMDE 2
    INSTALL ADB installer This is an app which will install an apk file on your 'droid'
    Download the apk file you want to your laptop/pc
    Connect your laptop/pc to the 'droid'
    Run the adb installer.

    I successfully loaded MX Player, ES File Manager doing this. Then I tried a Play Services apk. The first attempt failed so I opted for an older version which worked.

    I then noticed that the google talk authentication error had stopped. I confirmed this by checking Google Play on my laptop and the HTC device is now in the list of devices. I have also loaded hangouts through Play Store and updated it.

    So, it can be done, but it wasn't easy and needed external support in the form of a laptop. I couldn't do it simply from the android device. Best of luck
    B. Diddy likes this.
    08-28-2015 10:44 AM
  11. B. Diddy's Avatar
    Wow, bravo!
    08-28-2015 10:45 PM
  12. nassiball's Avatar
    Thanks a lot, this seems to be the only way to get the HTC Flyer working again!

    On Windows 10 I ran https://androidmtk.com/download-15-s...-adb-installer
    Get your usb cable out and connect the Flyer to your pc.
    Put the usb connection in HTC Sync mode (USB Debugging will show on the task bar)
    Try to install something from c:\adb
    adb install <filename>.apk
    you may get a read only error

    Go to google play and notice the Flyer should be among your devices again
    After some time the talk error went away, and hangouts was installable.

    Not quite sure what exactly did it, but usb connection and adb installer mentioned above may be enough. Plus maybe half an hour of waiting.
    09-05-2016 08:13 PM

Similar Threads

  1. Replies: 2
    Last Post: 09-11-2015, 04:20 PM
  2. How do I delete Google contact birthdays on the Samsung Calendar?
    By AC Question in forum General Help and How To
    Replies: 1
    Last Post: 08-26-2015, 02:24 PM
  3. Why can't I no longer delete photos from Google Photo?
    By AC Question in forum General Help and How To
    Replies: 1
    Last Post: 08-26-2015, 02:19 PM
  4. Replies: 0
    Last Post: 08-26-2015, 12:34 PM
  5. Replies: 0
    Last Post: 08-26-2015, 08:58 AM