1. AC Question's Avatar
    my micromax canvas a74 is stuck on the "Canvas " logo .
    i tried hard reset through recovery mode.(wipe data/cache), it didnt worked.
    it is running on stock rom. and my phone is rooted.
    i tried installing the stock rom which i flashed earlier , but this time the same rom installation failed.
    i havent installed custom recovery.
    and i even cant access my phone storage through usb.
    so in this case what do i have to do??

    i think installing custom rom would make my phone running but for that i need to install custom recovery .
    how to install custom recovery when my phone is not turned on(cant enable usb debugging )

    looking for a solution .. Thank YOU !!
    09-06-2015 11:37 PM
  2. Teejai80's Avatar
    Are you able to boot into download mode? If you can do that you might be able to flash using ADB. I would download the stock rom again, just incase the first one had a problem.
    09-07-2015 12:26 AM

Similar Threads

  1. Replies: 25
    Last Post: 12-06-2016, 07:15 PM
  2. Replies: 5
    Last Post: 10-18-2015, 06:51 AM
  3. Replies: 1
    Last Post: 09-07-2015, 02:04 AM
  4. Replies: 1
    Last Post: 09-06-2015, 11:38 PM
  5. Sprint/Boost galaxy S3 no options for disabling KNOX, will not root.
    By Ian Stephens1 in forum Samsung Galaxy SIII I9300
    Replies: 0
    Last Post: 09-06-2015, 10:55 PM