1. AC Question's Avatar
    Hi there,

    I need help here, I bought AT&T GSM unlocked galaxy S4 but I am not able to transfer data from my computer to Phone. Also this phone is not updating Android firmware. Can someone please help me on that?
    11-03-2015 01:27 PM
  2. B. Diddy's Avatar
    Welcome to Android Central! How are you trying to transfer data? Via USB connection? If so, is the device showing up in Windows Explorer? Make sure the screen is unlocked when you connect, and make sure the USB connection is set to MTP.

    Are you using the phone on AT&T? Carrier-specific phones usually need to be on that carrier in order to get the system update OTA.
    11-03-2015 02:25 PM
  3. danial80's Avatar
    Thanks buddy for responding on it. I am trying to transferring the data via data cable and using T-mobile service on phone which is working fine. I tried so many times but my laptop is not detecting the phone however it's getting charge if I'm connecting phone via data cable.

    I didn't get you "USB connection is set to MTP". Can you please mention in details.

    It's AT&T specific phone which is GSM unlocked. I can use T-mobile on it. I bought that from ebay.
    11-03-2015 04:03 PM
  4. B. Diddy's Avatar
    When you connect via USB, do you see a USB connection notification appear in the status bar? If so, swipe down the notification panel, tap the notification, and then select MTP.

    If you don't see a USB notification at all, then try a different cable, since the one you're using could be faulty. You could also try plugging into a different USB port on the computer.

    If you're using an AT&T phone on T-Mobile, you won't get system updates over-the-air, since AT&T pushes them for their own phones. You could try using Samsung Kies to install firmware updates. Or you could bring it to your local Best Buy store, and ask the Samsung Experience rep to flash the update for you.
    11-03-2015 04:53 PM
  5. danial80's Avatar
    Thank you for responding on it. Related to USB data cable notification, my phone is not showing anything except charging. I tried 2 cables which are working fine for Nexus 7 tablet and connecting with my laptop. I think something is not allowing to connect with laptop and phone as this phone was only GSM unlocked.

    For firmware update, I'll try to download Samsung Kies in my laptop and get back to you. I really appreciate your help If you have any other solution for data transferring please let me know.

    11-04-2015 12:40 PM
  6. B. Diddy's Avatar
    Also try reinstalling the USB driver: Download Center: Download Software, Firmware, Drivers & Manuals | Samsung
    11-04-2015 06:46 PM

Similar Threads

  1. Why my phone doesnt auto connect to wifi
    By AC Question in forum Ask a Question
    Replies: 3
    Last Post: 01-30-2016, 01:13 PM
  2. What you NOT like about your DROID TURBO 2?
    By Ry in forum Motorola Droid Turbo 2
    Replies: 47
    Last Post: 11-30-2015, 11:32 AM
  3. Replies: 1
    Last Post: 11-03-2015, 02:31 PM
  4. Replies: 1
    Last Post: 11-03-2015, 02:28 PM