1. Sushil Sahu1's Avatar
    very very thnx khan sahab
    12-25-2015 10:27 AM
  2. Eunicenoob's Avatar
    thank you!!
    12-25-2015 11:04 AM
  3. iamsubha's Avatar
    Thank you

    I have remove this.But after removing it i can not change my screen lock wall paper.

    I have used Kingoroot to root my device.

    Please help me to shootout this problem...........
    12-26-2015 02:21 AM
  4. Yasar Arafat's Avatar
    Hi guys...
    I had also the same problem I tried many antivirus apps but useless finally I solved it. You must have LOOKOUT antivus be installed in your phone open lookout and scan it detect the virus but it doesn't give you chance to delete or any informations because it's a trojan virus and you can't delete firewall on your phone So it give you another way, that you can go to this app 'security service' forced it to stop and dont forget to clear data and disable the service after done it go to running apps find firewall service in listed apps open it and forced it to stop and disable it..problem solved...
    For any problem contact me on whatsapp +917418662089
    12-27-2015 12:08 AM
  5. alex de souza's Avatar
    I've just signed up to thank you, Arafat. It worked for me but isn't it possible to completely remove the firewall service virus?
    12-29-2015 04:21 AM
  6. Krishna raj v's Avatar
    First install: Ghost push Trojan killer(playstore) and run it.It will detect and remove all Trojans.
    Next install:CM security antivirus and scan the device.
    This worked for me......I'm not sure for others.
    xaninhapt likes this.
    12-29-2015 04:59 AM
  7. tajuddin786's Avatar
    Sam problem bhai iska koi salution hai kya bataw me paresan hu
    12-29-2015 02:37 PM
  8. tajuddin786's Avatar
    Thank u bhai my problem solve ho gya
    Look out se
    12-29-2015 02:53 PM
  9. Andy Geeks's Avatar
    I manged to remove all 3 trojans uṣing Titanium backup ,Firewallservice,SecurityService and time service .
    12-30-2015 04:03 AM
  10. roopesh_sahu's Avatar
    sorry i don't understand your question
    01-01-2016 08:29 AM
  11. Johnkharl Modillas's Avatar
    appearing HISENSE HS-E970 have the same problem i dont know how to fix it. i reset. reboot. delet the app. but it still appearing my android phone. could you help me ? oopsand i try to scan the phone using the malware. 360. etc... but nothing happen whats is the best way to fix it?
    01-02-2016 09:34 AM
  12. Akash Kumar11's Avatar
    My phone keeps showing "Firewall Service" but just q second. After a couple of minutes it shows again, and just a second. It happened after i used 360 security. I boost the phone and cleared junk files. Help me please.
    it happens again after i use google applications.
    01-04-2016 09:22 AM
  13. lablab's Avatar
    my phone showing me a firewall service how can i fix this problem in my phone , please help me .
    01-05-2016 10:34 PM
  14. sujayn's Avatar
    my mobile show automatically launcher loading windo and then atomatically downloaded any application and installed this process repeated....
    please help me
    01-08-2016 09:59 AM
  15. Alejandr0o0's Avatar
    hi guys you have 2 options to solve this malware problem 1) you have to reset the firmware data from ur android and reset ur phone 2) you have to go to the application administrator>all>find" firewall service" > and forze detention,desactivate and eliminate data
    but in the second way the troyan can be activate by anyhing aplication no verificate by the playstore
    pd: sorry for my bad englando xP
    01-08-2016 10:34 PM
  16. Neethu Murali K's Avatar
    My phone keeps showing "Firewall Service" but just q second. After a couple of minutes it shows again, and just a second. It happened after i used 360 security. I boost the phone and cleared junk files. Help me please.
    01-10-2016 03:34 AM
  17. Polas Das's Avatar
    I have followed the step and my phone is also rooted, but unable to delete the file in priv-app folder(.gma.apk, .gmp.apk, .gmtgp.apk)....Please help me to delete ...thanks
    01-11-2016 05:49 AM
  18. Vishalhjoshi's Avatar
    Hello everyone,
    This method I'm going to write is tried on my own PANASONIC ELUGA S Kitkat 4.4.2 , which I did not flash because I'm not sure about stock roms available on the net. If I had found a reliable rom I wouldn't be able learn this

    To remove this virus you need to install busybox, Terminal emulator, Root explorer pro and you must have Supersu not superuser which is installed by Kingoroot. If you have rooted your device with kingoroot, so you need to change that.

    Here is how to change that:
    Google this: how to get ride and replace kinguser with supersu app (Follow first zidroid link)

    I'm not able to submit links so im going to write the exact apps with developer names to download from Playstore.

    Busybox Installer by JRummy Apps Inc.
    Terminal Emulator by Jack Palevich
    Root Explorer Pro by Speed Software

    Once you have installed everything here is what to do in steps:
    [Note: USB DEBUGGING MUST BE ENABLED Turn on Usb Debugging by going to settings> developer options> Usb debugging]

    1) Turn off wifi/3G/4G, and then go to settings> apps> all> disable time service and monkey test. (If already frozen via titanium backup or other app) skip this.

    2) Open Root explorer go to system/xbin and see if there is any file starting with a dot (eg: .ext.base) also note that every (.) file has diff permission then the rest of other files. So just remember those files with dots because those are the one that you're going to remove in terminal emulator.

    3) Go back to system and then go to Priv-app folder and look for these two files
    [1] gma.apk
    [2] gpa.apk
    and also notice permission of these two files are different then the rest of Apks so these two are the base virus and needs to be deleted.

    4) Open Terminal Emulator OR if you have access to your device via adb from a computer.


    adb devices (Type this line if you're using adb Windows)
    adb shell
    mount -o remount,rw /system
    cd system/priv-app
    chattr -iaA gma.apk
    rm gma.apk
    chattr -aA gpa.apk
    rm gma.apk
    cd ..
    cd system/xbin
    chattr -iaA .b
    rm .b
    chattr -iaA .ext.base
    rm .ext.base
    chattr -iaA .sys.apk
    rm .sys.apk
    [NOTE: If you are using older version than KK you need not to type priv-app just type cd system/app]

    6) Please make sure you type the file name correctly just as .gma.apk otherwise permission wont change.

    7) Exit Emulator/ADB

    8) Go to settings> apps> all> send me the screenshot if you have Monkey test or Time Service there

    9) I'm 100% sure if you've followed everything as I mentioned you are good as new and you don't need to flash.
    10) I am not developer and that's it.
    01-12-2016 11:55 PM
  19. rohani's Avatar
    thanks for your help...its works on my phone...
    01-13-2016 08:30 PM
  20. AMEERUL MOMNEEN's Avatar
    I also faced the same problem it is annoying jus go to setting->apps then select all tab in the app where you will find all the services you will also find this firewall services clear the data and desable it then ur problem is solved....it is bcos of I installed 360 securiy
    01-13-2016 10:59 PM
  21. Saghir Hussain's Avatar
    FirewallService which is showing in your android phone is like a trojen horse. To get rid of this, download stubborn trojen and scan ur mobile.
    01-19-2016 11:01 PM
  22. Juan D's Avatar
    Hi, I tried what you suggested: I instal x-plore, granted permissions so I could see the hiden files, located the three .apk files that I have to delete (firewall service, time service and security service) but when I selected them and tap on delete, x-plore said that some files could not be deleted... and they remain in there.

    Any thoughts on how to continue?
    01-26-2016 12:11 PM
  23. Verdao's Avatar
    I did this and worked for me:
    www computing net -> answers -> android -> need-help-disable-firewall-service-in-android-phone -> 1306 html
    01-26-2016 03:18 PM
  24. xaninhapt's Avatar
    thank you works to me
    01-27-2016 03:43 AM
  25. Adulik2's Avatar
    Hello, I did everything step by step acc. to you instruction, it works aprox. 10 min and it stars again, the firewallservise runs again.
    01-28-2016 08:42 AM
63 123

Similar Threads

  1. Motorola Customer Service: Moto Care and terrible service experience
    By Crazy Yankee in forum Moto X Pure Edition
    Replies: 59
    Last Post: 03-05-2016, 05:16 AM
  2. $50 kindle fire tablet keeps re-downloading apps?
    By patstar5 in forum Amazon Kindle Fire HD
    Replies: 1
    Last Post: 12-25-2015, 06:45 PM
  3. Replies: 8
    Last Post: 12-16-2015, 12:19 PM
  4. Replies: 7
    Last Post: 12-16-2015, 09:57 AM
  5. Replies: 1
    Last Post: 12-15-2015, 08:05 AM