1. AC Question's Avatar
    I have P8 lite,and it was working good till yesterday but in today morning it is not connecting to my Wifi,error is 'Network Access Denied'..but if it get close to my Router less then 1 meter its connected and if i go far from Router again it is given same error. Plz help mw out this.
    Thanks in Advance
    04-27-2016 06:46 AM
  2. H3aTeRzz's Avatar
    Hi

    Try unplugging your wifi router, from the wall outlet. wait 10 seconds, plug back in, and try again. Next, on your device (not familiar with P8) See if there is a Wipe Cache Partition, option, in Recovery. Do this.

    You can also look into resetting your router (factory reset) and also your P8. Hopefully you won't need to get this far.

    Chris
    04-27-2016 07:05 AM
  3. Scorpion000777's Avatar
    hey..thanks for your advice but its not working..problem is still there
    any other solution..?
    04-27-2016 08:49 AM
  4. H3aTeRzz's Avatar
    So you did a factory reset of your device and router and this still didn't help? There's really nothing else to do sir/ma'am. You'll probably need to have your phone serviced.

    Only other thing I can suggest....is to try another person's device on your wifi, see if the other device has the same issue, this will at least rule out your router being the problem.

    Chris
    04-27-2016 02:43 PM
  5. andreasandreas's Avatar
    we had the same problem
    in our case huawei nova on fritzbox 7580
    option for wlan standby always was on.
    it would be denied wifi access on wlan. entering correct wlan key would not make any difference , nor restarting phone.
    what worked as a immediate fix was restarting the router (power off)
    i did not try any factory resets cause they would seem nonsensical.
    however, the problem recurred, eventually every day.
    by trial and error i saw encryption setting on router was set to wpa2/ccmp
    i chancen that to wpa/wpa2. since then the problem did not recur.
    08-12-2017 05:49 AM
  6. Rukbat's Avatar
    The problem, only working when you're near the router, can be either a bad wifi adapter (or antenna connection) in the phone, or a bad wifi transceiver (or antenna connection or antenna) in the router.

    If other devices connect from 50-100 feet away, it's the phone., If no device connects unless it's close to the router, but they connect to other routers from a distance, it's the router.

    It usually doesn't pay to repair the router - most homes aren't large enough to need more than a cheap 150mbps router, and most people don't have enough devices connected to the router to need more than that. (The Netgear WNR 2000 is only about $40-$50, and the repair is going to be more than that.)

    If it's a problem with the phone, it probably means a motherboard replacement (unless the antenna connector just got unplugged), then you have to compare the repair cost to the cost of replacing the phone. A fairly new flagship phone is worth repairing, an4 year old cheapie isn't.

    Andreas, your problem didn't involve how close the phone was to the router, so it's a completely different kind of problem.
    08-12-2017 01:16 PM

Similar Threads

  1. Replies: 11
    Last Post: 05-02-2016, 06:16 AM
  2. Replies: 0
    Last Post: 04-27-2016, 04:32 AM
  3. Replies: 0
    Last Post: 04-27-2016, 01:23 AM
  4. Note 5 network and wifi issues
    By AC Question in forum Ask a Question
    Replies: 0
    Last Post: 04-26-2016, 08:01 PM
  5. My home wifi network is not auto connecting
    By AC Question in forum Ask a Question
    Replies: 0
    Last Post: 04-26-2016, 07:51 PM
LINK TO POST COPIED TO CLIPBOARD