1. AC Question's Avatar
    All the phones I've had that I've rooted has made google play inoperable. I would just like to be able to root my phone without any problems at all.
    06-29-2016 03:51 PM
  2. enesha's Avatar
    I've rooted about every phone i've owned since cupcake lol. You can definitely mess things up if you are not careful, however just rooting should not break your google play. What happens when you try to install something?
    06-29-2016 04:37 PM
  3. Toby Chew's Avatar
    It always says lost connection with a retry button sometimes it works sometimes it doesn't and ultimately hitting retry stops working even the workaround stops working
    06-29-2016 04:46 PM
  4. enesha's Avatar
    Him...I've never encountered that problem myself. I assume you have either a working WiFi connection or a high speed connection from your carrier? What mode is it slapping you in to? i.e edge, 3g, 4g, 4gLTE?

    Is all you did root, or did you do a new rom as well?
    06-29-2016 04:49 PM
  5. Toby Chew's Avatar
    I use wifi more reliable on my 1st and 2nd phone I did the 3rd one I didn't that one actually lasted longer than the other 2 and the phone I have now haven't done anything yet because I don't want what happened to the other 3 happen to this one.
    06-29-2016 04:53 PM
  6. enesha's Avatar
    Ok so you rooted and then it won't connect to google play...hrm...I know sometimes on a new phone it will have to update itself to the latest and sometimes that looks like it's not working. Rooted we might be able to get you the latest play as ask and update yourself. You might need to flash from recovery for that, I can't remember - I only ever have to do that if I use a custom rom,

    Perhaps if you give us the phone model and a step by step and where the error occurs and any error code maybe I (or more likely a more experienced person on here) can help you...
    06-29-2016 05:48 PM
  7. Toby Chew's Avatar
    I'm not having any problems now because I haven't tried rooting my phone yet but the 3 other phones I had did have problems on 3 other occasions I followed everything it said to do for a little while google play would work just fine able to update apps and google play then after awhile some apps would fail to update eventually I wouldn't even be able to update anything. Once this happens I get the no connection error with a retry button eventually the retry button stops working and have to use the workaround where I use root explorer and edit the hosts file and put in an IP address.The 3 other phones I had was an HTC Evo V,Kyocera hydro,and a kurio. The phone I currently have is a alcatel one touch which I haven't tried to root yet.
    06-29-2016 06:11 PM
  8. enesha's Avatar
    Very strange. Like I said I've rooted a few dozen phones and on here just about everyone is I would bet. Rooting wouldn't be a useful thing if it broke play, seeing as how important that is. What method of rooting are you using? Maybe something in the particular approach is breaking something. Also rooting is specific to the phone and to the version of android. Is it possible that you are rooting and then somehow getting an OTA update to a slightly newer version?

    Kingroot seems to work with the One Touch. I've used it in the past with no troubles. If you do root it, try to install a custom recovery like TWRP. Then you can boot into recovery and make a backup of your system partition. If you start having troubles you can then always go back to your latest backup. It's saved me a dozen times and i'm having troubles right now with my phone because I didn't install the recovery or make a backup. Bit me in the *** lol

    TWRP is at [6045*] [TWRP] custom recovery | Alcatel Onetouch Idol 3
    Golfdriver97 likes this.
    06-29-2016 07:35 PM
  9. enesha's Avatar
    Sorry for the second reply but my first one his pending *shrugs*

    What are you adding to the hosts file? The ip for the play servers? Generally you should never have to do that, and doing anything by ip these days can strand you because the domain address can resolve to any number of ip's and some will go in and out of service etc, that's one of the main perks of the domain system. If you were able to do that and have it work at least for a while, it sort of sounds like you are having trouble with your dns resolution. When you set up your wifi or the network settings for your carrier, are you changing the name server entries?

    I know you don't want to hear it, but it kinda sounds like you are doing something that is causing it.
    06-29-2016 07:38 PM
  10. Toby Chew's Avatar
    The phone I have now is a pixi 3 tried kingroot and it says root failed
    06-30-2016 08:28 AM
  11. Golfdriver97's Avatar
    Is there a version of TWRP for your device? Rooting should simply be flashing that and installing a super user .zip file.
    06-30-2016 09:11 AM
  12. Toby Chew's Avatar
    Got kingroot to work do I still need twrp?
    06-30-2016 09:49 AM
  13. Golfdriver97's Avatar
    06-30-2016 01:23 PM

Similar Threads

  1. Verizon won't activate my Moto X Pure!!!
    By Bradmeister2008 in forum Moto X Pure Edition
    Replies: 13
    Last Post: 07-08-2016, 02:19 PM
  2. help me unlock my phone using google account?
    By AC Question in forum Ask a Question
    Replies: 1
    Last Post: 06-29-2016, 05:23 PM
  3. How do you unsync a phone that is connected to mine.
    By AC Question in forum Ask a Question
    Replies: 1
    Last Post: 06-29-2016, 04:05 PM
  4. Phone shuts off despite plenty of charge and changes time.
    By AC Question in forum Ask a Question
    Replies: 2
    Last Post: 06-29-2016, 03:43 PM
  5. Replies: 0
    Last Post: 06-29-2016, 02:57 PM