1. AC Question's Avatar
    Hello I have a dragon touch X10 made by tablet express. It is running on 5.1 lollipop and is rooted. Last night i was playing around with an app called "superSu Me" that i got from google's play store when my tablet froze up and i couldn't get it to make a move so i did the soft reset by simply holding down the power button till it went off. When i turned it back on it wouldn't load past the "ANDROID" start screen, so i let it set two hours to make sure it just wasn't going slow and then i booted into "safemode" and tried wiping the cache no luck then did a factory reset and still no luck. I also tried boot to bootloader and then it just gets to the "dragon touch" logo screen and freezes(this is the very first thing you see after powering on device). I then have to hold down the power button to just to get it back to the "android" screen. I tried a different cable and different PC's even did a linux and windows and no mount. Now i have the firmware ready to be flashed but since my device wont mount via usb cable i tried to use MicroSd with iso written on it but i get an error: saying it cant mount (invalid argument) Any advice will be appreciated, thank you.
    08-01-2016 03:31 PM

Similar Threads

  1. SM-930A Older Software Possible?
    By jitter77 in forum Samsung Galaxy S7 Rooting, ROMs, & Hacks
    Replies: 1
    Last Post: 08-01-2016, 03:48 PM
  2. Replies: 0
    Last Post: 08-01-2016, 03:22 PM
  3. Replies: 0
    Last Post: 08-01-2016, 02:46 PM
  4. Replies: 0
    Last Post: 08-01-2016, 02:35 PM