1. AC Question's Avatar
    I have an LG G2 LS980 that recently had the digitizer/touch sensitivity go out on the part of the screen I would need to enter my pin. It held up for 4 years so NO COMPLAINTS THERE!!! I used the built-in encryption software to full-disk encrypt with pin. I unfortunately didn't have USB Debugging enabled, otherwise I would have just forced the keyevents for the encryption pin and recovered the data. I apologize if this is a redundant question. I have scoured the internet looking for a solution to this problem. Everywhere I go, everyone says that USB Debug must be enabled and that there is no other alternative. So, instead of just coming with the question, I have come to you with a POSSIBLE solution that I see but don't have the technical skill to attempt myself, without guidance.

    Is there any way to force a PC to recognize the device, clone the partition, and mount it on a PC using an Android cloning software? If so, I could then enter my encryption pin and recover my data.
    McDouble 1 likes this.
    09-10-2016 12:53 PM
  2. McDouble 1's Avatar
    UPDATE:
    I found these instructions on another site. After entering fastboot I cannot view the device from ADB unless I go to Apply Update From ADB. When in this mode I cannot execute the Pull command.

    Download insecure boot.img to your PC from https://www.androidfilehost.com/?fid...69635556426389
    Reboot your phone into fastboot mode by powering it off and then pressing and holding volume-down and power buttons.
    From your PC in the folder where boot.img is located type:
    $ fastboot boot boot.img
    To make an image of the mmcblk0p23 partition type:
    $ adb shell 'stty raw && dd if=/dev/block/mmcblk0p23' > ~/userdata.img
    09-10-2016 01:56 PM
  3. McDouble 1's Avatar
    Since I could recognize the device while in Apply From ADB, I tried to execute a sideload of the boot.img file and received the following:

    Finding update package
    Opening update package
    Verifying update package
    E:footer is wrong
    E:signature verification failed
    Installation aborted

    This leads me to believe that this method of accessing the partition is indeed viable, I just don't know how to convert a cracked boot.img into an ADB available update that the phone would accept.
    09-10-2016 03:12 PM
  4. belodion's Avatar
    Welcome as a new member.

    Excuse me for subtracting my Like....I thought you were replying to the original poster. I guess you ARE the OP.
    I'll pass this to certain clever persons whom I happen to know.
    McDouble 1 likes this.
    09-10-2016 03:24 PM
  5. McDouble 1's Avatar
    Thank you. I am not the type to idly sit by and wait for an answer, I will be avidly trying to find a work around until someone helps me...... even though this is apparently a long lasting issue and no one has yet to find a solution.
    belodion likes this.
    09-10-2016 03:34 PM
  6. McDouble 1's Avatar
    I've dug and found the following command, but again I run into the device only being recognized in the Apply Update from ADB mode. The command will result in an ERROR: CLOSED because the device wants a file and not a command.

    adb shell recovery --set_filesystem_encryption=off
    09-10-2016 03:42 PM
  7. McDouble 1's Avatar
    Is it possible to sideload a file that is a boot_completed then inputs the keyevents for the encryption pin?
    09-10-2016 07:02 PM
  8. AlphaTango414's Avatar
    Have you thought about approaching this from a more simple straight forward approached? OTG with keyboard maybe?
    McDouble 1 and belodion like this.
    09-10-2016 07:19 PM
  9. McDouble 1's Avatar
    I have thought about that. If I can't find a solution soon that is the route I'm going to take. Mostly, I've been looking into this because I have seen hundreds of other topics in forums about this very same thing and would love to be a part of the solution. It is one of those "see a problem, get focused and hellbent on finding a solution" type deals. Thanks for the advice.
    09-10-2016 07:24 PM

Similar Threads

  1. Replies: 11
    Last Post: 01-06-2018, 02:02 AM
  2. Replies: 0
    Last Post: 09-10-2016, 12:52 PM
  3. How do I find my saved links on my Android phone
    By AC Question in forum Ask a Question
    Replies: 0
    Last Post: 09-10-2016, 12:50 PM
  4. Getting failed to detect location on pokemon go
    By AC Question in forum Ask a Question
    Replies: 0
    Last Post: 09-10-2016, 12:32 PM
  5. how do I reconnect spell check on my galaxy J3 device?
    By AC Question in forum Ask a Question
    Replies: 1
    Last Post: 09-10-2016, 12:24 PM
LINK TO POST COPIED TO CLIPBOARD