1. koakuma's Avatar
    Hi,
    I haven't used my phone for weeks and maybe a month now (because of another problem that I tried and am still trying to fix) and whenever I think I find a solution, another completely different problem happens.
    Asking help on forums is always my last solution, after searching for days for a solution for this specific problem and finding nothing, only solutions that might've worked for other people but not me.
    I hope someone here could find a solution for me on this, because otherwise I have no idea what I'll do.

    Here's the most recent problem I had :
    Whenever I plug my phone to my computer, my computer sees the phone, but there's no way of accessing what's on it or moving files to it.
    If I click on my phone's icon (MotoG3), it shows it as completely empty.
    I looked it up and it should normally show an internal storage folder and a Transcend SD card folder (my SD card).
    I thought it might be because of my SD card, but even when I remove it from my phone, the computer still won't even see my internal storage.
    I tried to see if i could simply move things from my computer to the empty phone folder, but it refuses to.

    I tried finding solutions, so here's what I tried, which failed obviously :

    - Changing my phone's USB settings to MTP, since that's the answer everyone always gives, but I already put it on MTP and it doesn't do anything. (Well, that's how my computer can find my phone, but not the storage)
    I also tried putting it on PTP or MIDI (Whatever that is) and other than changing my phone's appearance on my computer, it changes nothing.

    - Activating USB debugging from the developer options; it took me so much time finding the developer options only to find out this didn't change anything either.

    - Restarting my computer, restarting my phone, connecting my phone to another computer, these change nothing.

    - Checking for driver updates, my computer says it is up to date.

    - Uninstalling my phone on my computer, unplug it, then replug it so that it will reinstall it automatically. No change.

    - Some people said my computer could badly identify my phone as an unidentified device, but it sees it as a multimedia peripheral (dunno if that's how you call it in English) which is how it should, thus not the problem.

    I am completely lost on what could cause the problem, and whenever I search on the net, the question is for another problem or the answer they give is to change from charge only to MTP.
    I mostly find people who only find their SD card storage and not their internal storage, but me I can't see either of them.

    I even ended up giving up and chose to make a dropbox account and access my files from there on the dropbox app, but the app doesn't even work for me (it says "dropbox stopped working" each time I try to open it)
    Even my "I give up" options don't work T_T

    My phone is a Motorola Gen3 and my computer is on Windows 10, if that helps.
    02-20-2017 08:54 PM
  2. chanchan05's Avatar
    After plugging the phone into the computer, make sure it's not locked.
    B. Diddy likes this.
    02-20-2017 09:37 PM
  3. B. Diddy's Avatar
    Welcome to Android Central! Also, have you tried different USB cables? And are you using a native USB port on the computer, or a hub? Make sure it's a native port.
    02-20-2017 10:05 PM
  4. koakuma's Avatar
    After plugging the phone into the computer, make sure it's not locked.
    Oh, I forgot to mention this, I actually completely disabled my lock pattern due to how much I turn my phone on and off to try to find a solution, so right now it is never locked, so that's not the problem.
    (It is also not on the black screen either, I always try it when my phone's open)
    Also my previous problem deleted everything on my SD card, so I have nothing to protect anymore anyway (I did a backup on my computer (that I think could work maybe?) and that's actually what I try to re-install on my phone, but can't.)

    Welcome to Android Central! Also, have you tried different USB cables? And are you using a native USB port on the computer, or a hub? Make sure it's a native port.
    I only have one USB cable, (Well, maybe my brother or my mother have one, but I think they only have these phone-to-wallplug cables, not the phone-USB cables) but I don't understand why it could charge and see my phone, but not my internal storage if it was the cable's fault?
    Oh and I had to look-up what you meant by internal and hub port (English isn't my first language) and a hub is a sort of device that you plug in an USB port to give you numerous USB ports? a sort of portable USB port? to have more ports?
    If that is it, then I don't have one and I always connect my phone to my computer's internal USB ports.

    That made me think though, and I tried my other USB ports, because those at the front of my computer are blue and I though it might work better in a grey USB port in the back, so I tried to connect my phone there (which is annoying since I have a desktop computer so getting around it isn't that easy, looking at the port to see if it's grey or blue isn't easy either) and it made no difference.

    Thanks for trying to help me though, I thought replies would be much slower =)
    02-21-2017 02:48 AM
  5. chanchan05's Avatar
    The cable itself may be damaged to an extent that it lets charge through but the data is not accessible. Just try a different one. A blue USB port is a type 3 port, which is faster and gives more power than a black type 2 port.
    B. Diddy likes this.
    02-21-2017 04:31 AM
  6. B. Diddy's Avatar
    chanchan05 mentioned already what I was going to say about cables that are able to charge only. It's hard for us to comment further until you try a different cable. They're very inexpensive, and sold in lots of different stores.
    02-21-2017 09:13 PM
  7. koakuma's Avatar
    Took me so much time just to check again sorry ><
    I solved the problem, it was related to my other problem I mentioned before.

    My phone said my SD card was corrupted and I had no more access to the data on it.
    Then, when removing and reinserting that SD card, it didn't say it was corrupted anymore, but I lost all of my apps data (all my saved games).
    I tried getting it back, but sadly didn't find any solution, so I connected my phone to my computer to retrieve the data from my SD card and save it on my computer as back up (some of these files had an error message, so i think these corrupted files were my problem).
    This is why i didn't think my USB cable was the problem, since at that moment i WAS seeing my SD card's storage on the computer.

    After that, I formatted my SD card on my computer, (I put the micro SD card in an adaptor and inserted it directly in my computer) since it refused to add any data on it if it wasn't formatted (I later found out it wasn't asking to format it because of the corruption, but because my SD card was selected as internal storage for my phone, oops xD)
    So after formatting it, i saved my backup on it.
    Then, when I put my SD card back in my phone, it asked if i wanted to select it as internal storage and format it... again... (realized my mistake there xD)
    So my data was redeleted.

    At that moment i thought i'd just connect my phone with my USB cable and re-save my backup on it.
    And that's where my first message comes from, with me not seeing any storage from my phone on my computer.
    I didn't understand what could be the problem, since last time i connected it, I was able to see the SD card storage (I think i couldn't see the internal storage because i selected my SD card as internal storage)

    What seemed to be the problem and how I solved it :
    When I looked in my phone, in the storage options, it showed the internal storage, the SD card and a 2nd SD card.
    I have only ever installed 1 SD card in my phone, never 2 different ones.
    It seems that after formatting, my phone wouldn't see my same SD card as being, well, the exact same SD card and was instead seeing it as a new SD card.
    So it said it remembered my "old" SD card and asked for me to insert it back.
    So my phone was confused and seemed to think I had 2 SD cards as internal storage for my phone, creating the problem.
    So, today, I asked my phone to forget that "old" SD card so that only the current one would be seen as internal storage.
    And that fixed it, My computer now sees my SD card storage when i connect my phone with the USB cable.

    I doubt my problem is completely solved though, since i still need to check if my apps' saved games are retrievable or if they were ever on that back up to begin with, but the specific problem I asked about on this forum post is solved, so if i still have problems i might need to make a new post since the problem would be pretty different.

    But thanks for trying to help me, I appreciated it =)
    Really, trying to solve my problem, i seem to only create new ones, i don't understand phones well ¬¬
    02-28-2017 07:53 PM

Similar Threads

  1. Replies: 2
    Last Post: 02-21-2017, 01:59 PM
  2. When is nougat update coming to Verizon Samsung galaxy s7 phones?
    By AC Question in forum Samsung Galaxy S7
    Replies: 1
    Last Post: 02-20-2017, 10:34 PM
  3. samsung s5 can't turn call waiting on
    By AC Question in forum Samsung Galaxy S5
    Replies: 1
    Last Post: 02-20-2017, 09:46 PM
  4. Replies: 0
    Last Post: 02-20-2017, 08:43 PM
  5. how to answer another call when you're on phone
    By AC Question in forum Ask a Question
    Replies: 2
    Last Post: 02-20-2017, 06:12 PM
LINK TO POST COPIED TO CLIPBOARD