1. Android Central Question's Avatar
    Hi everyone,

    I've been dealing with this problem for months and Project Fi can't fix it.

    I have a Pixel 2 running the most recent OS. I am in New Zealand and on Project Fi for my service. I wife and mother-in-law have the exact same set up and are also in New Zealand. Both of their phones connect to LTE and my phone only gets "H". Over the past few months two or three times I've gone without any connectivity at all for days at a time. This same thing happened with my Pixel 1 back in December so I bought a new phone, thinking it was the phone. But the exact same problem has happened with the Pixel 2. Can't be the sim card as the new phone doesn't have one. Unlikely it's the phone as two phones have had the same problem. Unlikely it's the near by towers as my wife's phone works great. I have a chain of emails with Project Fi 75 emails long and they can't seem to figure it out. I've sent them countless bug reports and they don't have a clue.

    Please help! I'm leaving New Zealand soon and am concerned I'll never get LTE with this device but have no idea why.

    One additional note is that I've noticed my wife's phone has a bit of a different settings menu layout. I can't figure out why but that's the only difference between the two phones.

    Thanks everyone,

    Ross
    03-16-2018 02:57 AM

Similar Threads

  1. Replies: 2
    Last Post: 03-21-2018, 03:11 PM
  2. Why won't my Samsung keyboard ever come up?
    By Android Central Question in forum Ask a Question
    Replies: 2
    Last Post: 03-21-2018, 02:59 PM
  3. Why is my sim not working
    By Android Central Question in forum Ask a Question
    Replies: 3
    Last Post: 03-17-2018, 11:43 AM
  4. Can't convert .Avi to play on Moto e4
    By esjayy in forum Moto E4 & E4 Plus
    Replies: 1
    Last Post: 03-16-2018, 04:07 PM
  5. Why does my lightning charger work for my cell phone but not my tablet?
    By Android Central Question in forum Ask a Question
    Replies: 1
    Last Post: 03-15-2018, 04:47 PM
LINK TO POST COPIED TO CLIPBOARD