1. eaglesally's Avatar
    I can't believe that the wonderful Note 9 (running Android version 8.1.0) has made it so difficult to block spam callers.

    On my old Note 4, if I wanted to block a spam caller, all I had to do was to select the number from the calls list, go to the overflow menu and choose 'Add to Auto reject list'.

    Now, as far as I can see, I have to write down the number of the spammer, go to the blocked calls list and copy the number in. If I try to hold it to copy and paste, it merely opens a checked box for me to delete the number.

    Change for the sake of change = change for the worse. Or am I missing something?
    10-23-2018 07:02 AM
  2. hallux's Avatar
    Welcome!

    Maybe it's something with the Samsung dialer. On the Google dialer, if I tap on the incoming call in the recent calls list I get this expansion with options to tap on.

    10-23-2018 07:06 AM
  3. ManiacJoe's Avatar
    Definitely send an email to the owner of the dialer app.
    On my LG V30, "block number" is the first menu option from the 3-dot menu when viewing a call log entry.
    10-23-2018 08:16 PM

Similar Threads

  1. Question: Galaxy Watch and WhatsApp/Telegram Notifications
    By Android Central Question in forum Samsung Galaxy Watch
    Replies: 1
    Last Post: 10-26-2018, 07:57 AM
  2. Replies: 2
    Last Post: 10-23-2018, 07:58 AM
  3. WiFi calling issue after update
    By Danny Long2 in forum Samsung Galaxy Note 9
    Replies: 0
    Last Post: 10-23-2018, 06:51 AM
  4. Incoming outgoings call barred
    By Android Central Question in forum Ask a Question
    Replies: 1
    Last Post: 10-23-2018, 05:29 AM
  5. Question: Galaxy Watch and WhatsApp/Telegram Notifications
    By Android Central Question in forum Ask a Question
    Replies: 0
    Last Post: 10-23-2018, 03:29 AM
LINK TO POST COPIED TO CLIPBOARD