1. Android Central Question's Avatar
    I have tried a dozen, none of them work.
    Why is that?
    10-25-2018 08:31 AM
  2. ManiacJoe's Avatar
    Which phone?
    Which version of android?
    Which carrier?

    Which FTP client software are you running?
    Whose FTP server are you trying to contact?
    What is the exact wording of the error message?
    10-25-2018 05:29 PM
  3. Rukbat's Avatar
    Crickets, anyone?
    10-26-2018 12:20 PM
  4. LoisDroidX's Avatar
    I am having the same problem. My phone is LG V20, running Oreo. I have tried the following FTP servers:
    Remote File Transfer LIte
    FTP Server Ultimate
    SwiFTP
    Primitive Ftpd
    FTP Server
    ..and probably some others that I deleted after findint they didn't work.

    On a previous pone I used SwiFTP successfully, and on my tablet (currently running Nougat, but it wants to update to Oreo - haven't let it yet), another app called FTP Server work. On the LG V20, however, I set it up just as on my tablet & previous phone (but giving it the correct location for my sd card). I start the server on the phone & it gives me an IP address (sometimes more than one). I use my FTP client on my computer (FileZilla) and enter the login & password set on the phone's server. The client continuously fails to connect. The only error messages I get are from the client, which is just a failure-to-connect message.
    I'm guessing this is an Oreo thing since I didn't have trouble on other Android versions, and so I'd like to get it resolved before letting my tablet update itself. I have found that USB transfer is hit-or-miss, and FileZill works great on the tablet and previous phones.
    I've also tried to connect using my browser: ftp://[ipadress].[port], and that works fine on the tablet, fails to connect on the phone.
    12-16-2018 10:23 PM
  5. ManiacJoe's Avatar
    Trying to get the phone to be the FTP server, interesting....

    Any chance your phone has a firewall or other security software that is blocking the FTP ports (20 and 21)?

    Are you trying this over a wifi network or the cell data network?
    I would expect your carrier to be blocking the cell data system from working.
    12-17-2018 03:57 AM
  6. LoisDroidX's Avatar
    Thanks for the reply. I'm using it in WiFi. We actually figured it out. We have multiple wifi routers/bridges in our house, and it turned out that it worked on one and not on another until I set up port-forwarding on the one that wasn't working - so the issue was my home router settings, not the phone or Android version at all. It just happened that the device on which it was working typically connected to one access point, and the one that didn't connected to another one.
    12-18-2018 12:51 AM

Similar Threads

  1. Disable automatic assigning of contact picture for my google pixel 2XL
    By Android Central Question in forum Ask a Question
    Replies: 2
    Last Post: 10-27-2018, 05:46 AM
  2. why does my piece of crap phone keep turning of the wifi?
    By Android Central Question in forum Ask a Question
    Replies: 2
    Last Post: 10-25-2018, 08:52 AM
  3. My theme app doesn't work!
    By Android Central Question in forum Ask a Question
    Replies: 0
    Last Post: 10-25-2018, 08:03 AM
  4. Can I add a shortcut to the screen on a Moto Z3 for the mobile Hot Spot
    By Android Central Question in forum Ask a Question
    Replies: 1
    Last Post: 10-25-2018, 07:49 AM
  5. Replies: 0
    Last Post: 10-24-2018, 10:35 PM
LINK TO POST COPIED TO CLIPBOARD