1. Android Central Question's Avatar
    I have a Samsung Galaxy S9+ on T-Mobile. Downloaded the most recent security update last night, and now every time I open an existing conversation or start a new one, the stock SMS message app gives me a prompt to turn on Read confirmation. Every. Single. Time.

    In my chat settings, I have this turned off because sometimes I don't WANT people to know when I've read their messages, but my phone isn't taking the hint. I tried toggling it on and back off, but it still keeps prompting me to turn it on. I do a LOT of texting because of my job, so this is a persistent annoyance for me.
    W L and esmail like this.
    11-14-2018 11:12 AM
  2. rgalaxy4's Avatar
    Is there a way to stop the popup prompt to turn on Read confirmation?-20181115_134930.jpg

    I too seeing these annoying popups on very old message threads. Have never seen this before. Even in my settings its turned off.

    T-Mobile S9+ latest update.
    W L likes this.
    11-15-2018 03:57 PM
  3. 3x10_8's Avatar
    Same. It's super annoying.
    W L likes this.
    11-18-2018 02:16 PM
  4. Rukbat's Avatar
    It's up to the sender - if they ask for a confirmation, the app is supposed to ask you.
    11-18-2018 02:25 PM
  5. rgalaxy4's Avatar
    Do you mean that automated OTP websites also ask for confirmation like humans ?
    Bad reply !!!!! .... This has not happened before and its clearly a bug. It has nothing to do with sender or any other setting !!
    esmail likes this.
    11-19-2018 11:49 AM
  6. W L's Avatar
    It's up to the sender - if they ask for a confirmation, the app is supposed to ask you.


    No, it pops up immediately when starting a new blank text message (before choosing a recipient) as well.
    11-20-2018 11:59 AM
  7. ManiacJoe's Avatar
    There is another thread here suggesting that clearing the data cache of your messaging app should solve the problem.
    11-21-2018 01:47 AM
  8. rgalaxy4's Avatar
    There is another thread here suggesting that clearing the data cache of your messaging app should solve the problem.
    That solution is not for messages bug. It is for some brightness issue
    11-26-2018 12:01 PM
  9. proximitybifocal's Avatar
    Same thang, TMOBILE best realize they better fix this now. Ain't nobody wanna be axed this erry time. U crazy!
    Attached Thumbnails Is there a way to stop the popup prompt to turn on Read confirmation?-screenshot_20181128-080224_messages.jpg  
    esmail likes this.
    11-28-2018 10:12 AM
  10. ICS2's Avatar
    *FIXED*
    Galaxy s9 on T-Mobile
    So this worked for me after many attempts of restarting and digging in the settings menu to no avail....
    The simple fix is this....
    Open “messages” app
    Tap on the “new message” icon and pick any contact You don’t already have an existing conversation with. The prompt will then automatically pop up, click “turn on”
    Close the app.
    Open it again and repeat the first steps but this time there won’t be any prompt pop up since it’s been approved.
    Click on the top right menu (3dots) and at the bottom of the drop down window you’ll notice the option to turn off the “read message” that’s it! No more annoying prompt every time you open or start a new message.
    For some reason this option worked instead of turning it off directly from the messages settings.
    elisheva60 likes this.
    11-28-2018 05:17 PM
  11. Rick Nevarez's Avatar
    *FIXED*
    Galaxy s9 on T-Mobile
    So this worked for me after many attempts of restarting and digging in the settings menu to no avail....
    The simple fix is this....
    Open “messages” app
    Tap on the “new message” icon and pick any contact You don’t already have an existing conversation with. The prompt will then automatically pop up, click “turn on”
    Close the app.
    Open it again and repeat the first steps but this time there won’t be any prompt pop up since it’s been approved.
    Click on the top right menu (3dots) and at the bottom of the drop down window you’ll notice the option to turn off the “read message” that’s it! No more annoying prompt every time you open or start a new message.
    For some reason this option worked instead of turning it off directly from the messages settings.
    I tried it. Does not work!!
    01-28-2019 10:34 PM
  12. elisheva60's Avatar
    *FIXED*
    Galaxy s9 on T-Mobile
    So this worked for me after many attempts of restarting and digging in the settings menu to no avail....
    The simple fix is this....
    Open “messages” app
    Tap on the “new message” icon and pick any contact You don’t already have an existing conversation with. The prompt will then automatically pop up, click “turn on”
    Close the app.
    Open it again and repeat the first steps but this time there won’t be any prompt pop up since it’s been approved.
    Click on the top right menu (3dots) and at the bottom of the drop down window you’ll notice the option to turn off the “read message” that’s it! No more annoying prompt every time you open or start a new message.
    For some reason this option worked instead of turning it off directly from the messages settings.
    YAY!! It works! The details of the post were not exactly the same. But the bottom line is to go in and turn it on. Go out. Go back in and turn it off. And then it seems to eliminate the super annoying pop ups.
    04-06-2019 04:42 PM

Similar Threads

  1. Game play is terrible on the S9. Is there a fix?
    By Android Central Question in forum Samsung Galaxy S9 & S9+
    Replies: 23
    Last Post: 08-03-2019, 04:27 AM
  2. Replies: 8
    Last Post: 11-23-2018, 10:55 PM
  3. Samsung Galaxy s8 -random camera shutter sounds even when phone is not in use?
    By Android Central Question in forum Ask a Question
    Replies: 1
    Last Post: 11-15-2018, 07:49 AM
  4. Is there a voicemail enhancer app for Samsung notebook 8?
    By Android Central Question in forum Ask a Question
    Replies: 1
    Last Post: 11-14-2018, 12:29 PM
  5. Where do you find updates for Photo Editor on Galaxy S8
    By Android Central Question in forum Ask a Question
    Replies: 1
    Last Post: 11-14-2018, 11:49 AM
LINK TO POST COPIED TO CLIPBOARD