1. Android Central Question's Avatar
    I have two Samsung Tab Pros (SM-P900) which both began to exhibit the same errors.
    Sometimes they will appear to work fine for a period of time before resuming the same dysfunctional behavior.

    The screen will randomly flicker either once or multiple times in sequence. This seems to happen more when the tablet is forced to render a new screen such as when I slide side to side between desktops.

    This is the first symptom I noticed on one of my tablets, but after a few weeks of this it began to exhibit a second problem with loading images from an inserted SD card. I am not sure if this problem is directly related but I assume it must be because a second identical tablet I own just started exhibiting both problems at the same time.

    I use the tablets to show photos so I often load multiple albums of photos onto SD cards and insert them into the tablets using gallery to allow customers to browse them. Sometimes this still works fine, but then randomly it will start to have trouble loading the images from the SD which will be characterized in a variety of ways. Some of the image thumbnails will appear only a the first few top rows of pixels (perhaps 1/10 of the image) with all the rest a solid color, others will appear black with the broken file symbol in the middle and others will just remain grey and never load. Sometimes all thumbnails will just go grey... In parallel to this when I try to open the images many of them will not load only showing a spinning progress bar, while others will load with very low quality. Still others will load properly, (I assume these loaded into RAM before the error occurred).
    When this occurs the SD card seems to still be mounted, the file structure can be explored with the file browser or using other gallery apps, but nothing seems to be able to open them.

    I have tried to do a full factory reset of my device to no avail. I also tried to call samsung support and all they could do is tell me to send it in. The best lead I could find was that the screen flickering could be caused by a bad battery connection to the motherboard but I have not been able to find any info on the problem of the loading images from SD.

    Here is the possibly related forum post
    https://forums.androidcentral.com/samsung-galaxy-note-pro-12-2/588742-screen-flickering-power-problems-like-tab-12-2-a.html

    Thank you so
    12-14-2018 06:33 PM
  2. B. Diddy's Avatar
    Welcome to Android Central! Does this persist if you unmount the SD cards and remove them? Also, does it persist in Safe Mode? The steps for the Tab S should also work for the Tab Pro: https://support.t-mobile.com/docs/DOC-28736
    12-16-2018 07:43 PM

Similar Threads

  1. private mode issue on Samsung c5
    By Android Central Question in forum Ask a Question
    Replies: 1
    Last Post: 12-14-2018, 06:08 PM
  2. MetroPCS runs on T-Mobile's network and Sony Xperia XA2
    By Android Central Question in forum Ask a Question
    Replies: 0
    Last Post: 12-14-2018, 06:01 PM
  3. MetroPCS runs on T-Mobile's network and Sony Xperia XA2
    By Android Central Question in forum Sony Xperia XA2
    Replies: 0
    Last Post: 12-14-2018, 05:58 PM
  4. MetroPCS runs on T-Mobile's network and Sony Xperia XA2
    By Android Central Question in forum Ask a Question
    Replies: 0
    Last Post: 12-14-2018, 05:58 PM
LINK TO POST COPIED TO CLIPBOARD