1. Android Central Question's Avatar
    So I tried to format my phone by going to settings and factory reset. But it stayed in the startup motorola and droid loop, so I did the recovery mode factory reset by accessing the power + Volume down option. So everything was perfectly fine, The "android is starting , Optimizing app x of x" happened, it did it like 3 times, but then it said Finishing boot or something similar, the phone turned off and on again, but the loop was there again.

    I've noticed that between the loop, the screen turns black, and I am able to see the "Power off" the phone, I even pressed the power button and the down button, and it took a screen shot of a black screen. So i decided to turn it on into safe mode, but even the safe mode was black.

    Do you guys have any idea what can it be happening?
    07-13-2019 03:51 PM
  2. belodion's Avatar
    It could be a hardware or software problem so far as I can see. It may be worth reflashing the stock ROM, but before you do, why did you decide to factory reset in in the first place?
    07-13-2019 04:36 PM
  3. Israel Alonso's Avatar
    I was just going to give it to someone else.
    07-13-2019 04:41 PM
  4. B. Diddy's Avatar
    Welcome to Android Central! Which Moto phone is it? If it's pretty old, it's probably hardware failure.
    07-14-2019 02:17 AM
  5. Israel Alonso's Avatar
    It is a Motorola Droid powered by verizon, I believe is a xt1254 .
    08-07-2019 06:25 PM
  6. Rukbat's Avatar
    Evidently Android is corrupt. There are three "operating systems" on an Android phone:

    1. Bootloader

    2. Recovery

    3. Linux, on which Android runs. (Linux is called "the kernel" in cellphone parlance.)

    (It's like partitioning the hard drive on a PC, so you can run Windows or Linux, at your choice. Android storage is partitioned to next week and back.)

    So if Android has at least boot.img, it will boot. It won't go anywhere, but it will boot. If it has no, or a corrupted, boot.img, it will try to run recovery. If recovery can't boot, it runs the bootloader, which is always there. Your phone has, at least, boot.img, but it may take more than that to flash a ROM, you may actually have to get into Android to unlock the bootloader, which you can't do ... vicious circle time.

    There are services (you can find some on eBay) that can JTAG a phone - they replace the CPU (electronically, they don't remove it physically) and "feed" the phone the stock ROM. But it's a 2014 phone, it doesn't have anything on it that you want, and JTAGing it would cost more than replacing it, so put it on a shelf, take a picture of it, and consider it part of your history.
    08-07-2019 06:39 PM
  7. milleniumdroid's Avatar
    The problems @Rukbat is mentioning could also be caused by the internal flash memory having a "few" dead/dying memory cells. After many write/erase cycles (usually a few hundred thousand or higher, depending on the quality of the chip and what type of temperatures it was used in), the memory cells start losing their ability to hold an electron (which represents a binary 1) due to chemical wear and tear degradation of their silicon-based structure. You might not have been using those faulty cells before the factory reset (and the reset probably caused even MORE dead cells), but then Android probably tried to write 1s to those when doing the initial setup, causing bootloop-inducing data corruption. I'm totally not surprised if this happened especially smif you did lots of heavy work with large files on your device. I've had both an SD card and a desktop SSD start having read/write errors after 2 years of usage, but never with internal storage. You're probably out of luck unless you can find a good repair shop that can change the NAND flash chip in your phone or give you a whole new motherboard, but that is probably not worth it
    08-07-2019 06:51 PM

Similar Threads

  1. Trying to download the Weatherlink app on my LG E980 phone, I get an 945 error
    By Android Central Question in forum Ask a Question
    Replies: 4
    Last Post: 07-14-2019, 07:25 PM
  2. How do I get photo I loaded onto my android box onto a USB
    By Android Central Question in forum Android TV
    Replies: 3
    Last Post: 07-14-2019, 02:09 AM
  3. How can I rewrite my Tecno CA7 IMEI
    By Android Central Question in forum Ask a Question
    Replies: 4
    Last Post: 07-14-2019, 02:07 AM
  4. voicemail from calls not shown as received or missed
    By Android Central Question in forum Ask a Question
    Replies: 1
    Last Post: 07-13-2019, 06:09 PM
  5. Replies: 2
    Last Post: 07-13-2019, 12:13 PM
LINK TO POST COPIED TO CLIPBOARD