1. DearHorse085's Avatar
    Every time I try to recharge my phone via the charger it always shows a message saying that the battery is disconnected,I even tried to charge it up by the usb cable but it showed the same message again!What do I do?
    12-31-2014 09:00 AM
  2. Golfdriver97's Avatar
    Welcome to the forums. Have you tried other cables and wall plugs?
    12-31-2014 09:17 AM
  3. DearHorse085's Avatar
    I tried to charge it with the usb cable (usb debugging disabled) but nothing happens.
    12-31-2014 10:06 AM
  4. DearHorse085's Avatar
    Is there anything I can do?If so please post it here
    12-31-2014 12:10 PM
  5. Golfdriver97's Avatar
    Perhaps a new battery?

    From an AOSP M8
    12-31-2014 01:10 PM

Similar Threads

  1. Samsung S3 wont turn on/load past logo/welcome screen?
    By Issy Holmes in forum Samsung Galaxy S3
    Replies: 1
    Last Post: 01-01-2015, 02:35 AM
  2. Replies: 3
    Last Post: 12-31-2014, 11:53 AM
  3. Replies: 1
    Last Post: 12-31-2014, 09:21 AM
  4. Please help! Galaxy i9500
    By Daniel Shimon in forum Samsung Galaxy S4
    Replies: 0
    Last Post: 12-31-2014, 07:04 AM
LINK TO POST COPIED TO CLIPBOARD