1. Mr Davo's Avatar
    Hi Everyone,

    I am seeing an issue on my HTC Sensation when attempting to update Apps that I paid for in the Google Play Store. The exact message that I see when attempting to update these Apps is "Package File is Invalid".

    Here is a bit of background to this issue -

    1). My HTC Sensation has a custom ROM (Elegancia) installed, and I have now re-installed it (which is when these issues started).
    2). I can install a ROM and update Apps through the Play Store just fine at the start
    3). I install Titanium Backup and perform a restore (I have tried restoring only data & apps + data [starting from scratch and wiping the phone then installing the ROM again to test both scenarios])
    4). Apps return to the state that they were in before I flashed the new ROM

    *** However now whenever I attempt to update Apps I get the infamous "Package File Invalid" message ***

    I have noticed when opening Titanium Backup that it alerts me that the "Android ID" has changed, it also gives two options, 1). Leave the new ID, 2). Restore the old ID

    5). I tested the updating of Apps both whilst keeping the new "Android ID", and whilst restoring the old "Android ID", the ID (whilst I am sure is important) doesn't seem to affect whether or not Apps will update.

    This issue only appears to be affecting Apps that I have purchased, and the Play Store still recognizes that I have purchased the Apps.

    I believe that this issue is related to Titanium Backup. If anybody knows how to get around this it will be greatly appreciated. I have Googled the issue, and read up on it - none of the answers that I found worked, so I figured that another fresh ROM install should fix the problem, however it didn't!

    Any help will be greatly appreciated.

    Kind Regards,

    10-01-2012 02:27 AM
  2. Mr Davo's Avatar
    Hi Everyone,

    The plot thickens - I just logged into the Google Play Store and attempted to install a new App (through a Browser on my Desktop Computer). I was surprised to see the following screenshot:

    Package File is Invalid. Please help fix this issue!-cant-install-directly-google-play.jpg

    Notice that the SEND TO box has a greyed out entry - "Telstra HTC Sensation".

    I have an interesting predicament, even though I am a Vodafone (AU) customer, the reception at my residence is so poor that I keep an "emergency" Telstra (AU) SIM in case of the need to make an emergency call (I live in Suburbia so why I can't get reception through Vodafone will remain a mystery!).

    When I installed the Elegancia ROM I did so with the Vodafone SIM inserted. However when it came to downloading Apps I used the Vodafone SIM. I think that the Google Play Store is now in a "state of limbo" - as originally my phone had Vodafone HTC Sensation and now it has Telstra HTC Sensation.

    If I try to install an App onto my phone that has already been there before I see the following:

    Package File is Invalid. Please help fix this issue!-attempting-install-app-i-had-installed-previously.jpg

    I can click on Install but nothing downloads to my phone regardless of the SIM that I have inserted - I have tried both.

    I now feel like the Google Play Store & Titanium Backup are having a "game of tug of war", and my unfortunate phone is stuck in the middle!

    If anybody knows how to reset the "SEND TO" parameter in the Google Play Store please let me know.

    Kind Regards,

    Attached Thumbnails Package File is Invalid. Please help fix this issue!-cant-install-directly-google-play.jpg   Package File is Invalid. Please help fix this issue!-attempting-install-app-i-had-installed-previously.jpg  
    10-01-2012 03:22 AM
  3. Mr Davo's Avatar
    Hi Everyone,

    As attempts to fix this - using methods that I found elsewhere on the web - came to no avail...

    My fix -

    1). Formatted SD Card (after backing up data to PC)
    2). Installed newest firmware 3.33 RUU (PG58IMG.zip)
    3). Using 4EXT
    a). Formatted Partitions (except SD Card)
    b). Ran DragunKorr-WIPE-ALL.zip
    c). Wiped cache + dalvik
    d). Installed Elegancia ROM (Sense_4.V3.1.0.zip)
    4). Configured Apps manually

    *** DIDN'T use Titanium Backup ***

    I am no longer seeing the infamous "Package File Invalid" message, however the Google Play Store still isn't behaving correctly.

    When I log into the Play Store using a browser, and I attempt to install an App I am presented with the following:

    Package File is Invalid. Please help fix this issue!-you-havent-accessed.jpg

    Whilst the Play Store now recognizes that my carrier is Vodafone rather than Telstra I am not able to perform App installations from a browser. I have configured many Apps through my phone so the reasoning given by the Play Store (in the above screen capture) is not valid!

    Hopefully this information helps those people who are still stuck with the "Package File Invalid" error.

    Kind Regards,


    P.S.: I think that this error was originally caused by my flashing several different ROM versions, and restoring Apps / Data with Titanium Backup, over a short period. In my case I installed about 3 different ROMs in the course of one day.
    10-02-2012 09:01 PM
  4. Mr Davo's Avatar
    Hi Everyone,

    I have resolved the Google Play Issue -

    1). Log into Google Play Store (using a browser)
    2). Scroll to the bottom of the page & locate "My Orders & Settings"
    3). Click on the Settings Tab
    4). Assign a "Nickname" to your phone
    5). Check "Shown in Menus"
    6). Save settings
    7). Return to the Play Store and download Apps as normal!

    It seems that I have overcome all issues related to the "Package File Invalid" error message! Yippee for me!!!


    10-02-2012 11:44 PM
  5. 1Ando's Avatar
    Completing the action each time with the Browser - rather than the Play Store, eh?
    11-08-2012 03:21 PM
  6. THENICKRULZ's Avatar
    Doesnt Work. Any other ways other than having to re flash my ROM?
    11-12-2012 03:39 AM
  7. craigiobellio's Avatar
    Thanks that worked for me instantly!
    01-17-2013 05:06 PM
  8. Nick Marten's Avatar
    hi that does not work with my Orange San Deigo\!! want d/l bbc media player
    01-20-2013 12:19 PM
  9. xxmikerayxx's Avatar
    Uninstalling updates seemed to work to solve the "package file invalid" issue on my Galaxy note 10.1. But I tried the nickname thing and clearing cache and data before that. Just try application settings and Uninstall updates for Google play store. It oughtta work then.
    02-02-2013 02:28 PM
  10. April Holbrook's Avatar
    I've tried all this and still not working. How do I go ahead and update the Google play store back to how it was before I uninstalled updates? Thank you.
    06-11-2013 10:28 PM
  11. April Holbrook's Avatar
    nevermind. it automatically updated.
    06-11-2013 10:43 PM

Similar Threads

  1. [Solved] Error: Package file is invalid
    By wbsrlnyt in forum Virgin Mobile Optimus V
    Replies: 25
    Last Post: 08-17-2013, 05:52 PM
  2. Error: Package File Is Invalid
    By MrDynamo in forum Optimus V Rooting, ROMs, and Hacks
    Replies: 11
    Last Post: 10-11-2012, 06:19 AM
  3. Replies: 24
    Last Post: 08-26-2012, 12:56 AM
  4. Package File is invalid?
    By pwngmike in forum Virgin Mobile Optimus Slider
    Replies: 3
    Last Post: 07-22-2012, 01:31 PM
  5. Package file is invalid (Google Plus)
    By DazzaJay in forum Market Help
    Replies: 0
    Last Post: 06-30-2012, 09:06 AM