1. tarasmuz's Avatar
    Hi Internet,
    I was trying to flash Android M on my Nexus 9 (Wi-Fi only) today and ended up with errors such as: "system.ui has stopped working" or "android.process has stopped" because I wanted to see if I actually needed to do a factory reset for it to work properly (turns out I do). After that I've tried again and have run into some issues.
    Firstly, after that Android M wasn't flashing at all and I have decided to abandon the idea of M and just go back to Lollipop. Now, I am trying to flash 5.1.1 and I keep on getting FAILED (remote: data length is too large) error when flashing my system partition. I'm flashing everything separately because if I try to do it as one image because I keep getting error: update package missing system.img errors. I have no trouble with flashing my bootloader and other partitions(boot, cache, recovery, etc), but that system partition just won't flash! I've tried 5.0, 5.1, 5.1.1 and I keep on getting these errors.
    I have no idea what to do. Please help. I've spent the last 5 hours trying to figure it out and nothing has yet came up. I'm using a Mac, but I don't see how this might be causing an issue. If you have any valuable information - please help!
    I'm very comfortable with flashing and ROMs, in fact I've updated my N5 to M in 5 min, but I've never seen this error before and have no idea how to fix. All I found out is that, I think, it only happens on HTCs...
    06-14-2015 03:26 PM
  2. Brandon Hertel's Avatar
    I too would like an answer to this exact problem!
    09-22-2015 06:40 PM
  3. teknoloJ's Avatar
    First of all I can't take 100% credit for some of these steps. The linchpin was from a post by Keith I Myers on Google+ (plus.google.com/+KeithIMyers/posts/XuMNYBHEs76).

    Anyhow, I was actually trying to update my Nexus 9 to Android 6.0 (marshmallow) when I encountered the dreaded FAILED (remote: data length is too large) error. This fix should work for other versions of Android, but hey, why not just go right to the latest? So here's what I did to fix it. Note: For the record I was doing this on Linux, but the results should be similar on Windows.

    1) Extract the "volantis-mra58k-factory-cc430962.tgz" and navigate to the directory in a terminal/cmd prompt
    2) You should now see several files. For marshmallow the important file is “image-volantis-mra58k.zip”. Unzip this file to a separate location.
    3) Make sure your tablet is at the fastboot screen (with an unlocked boot loader) and connected via USB to your computer.
    4) Run "fastboot oem rebootRUU" Once successful, you will see a HTC logo on your Nexus 9 screen.
    5) Next comes the slightly tedious part; you'll need to flash each file within the “image-volantis-mra58k.zip” to your Nexus 9. Here's the commands:
    a) fastboot flash boot boot.img
    b) fastboot flash cache cache.img
    c) fastboot flash recovery recovery.img
    d) fastboot flash system system.img (Note: This image will flash in chunks of just under 500,000KB; you don't need to do anything but wait.)
    e) fastboot flash vendor vendor.img
    6) Following all the flashed images, it's probably a good idea to relock your boot loader with “fastboot oem lock”
    7) Once that's done the Nexus 9 should reboot, if it does not use “fastboot reboot"

    That's it, your Nexus 9 should reboot and will have the latest marshmallow.
    Significant props to Keith I Myers for the “fastboot oem rebootRUU” command which was key to getting this all to work.

    Hope this helps,

    tJ
    10-28-2015 11:15 PM
  4. celem's Avatar
    teknoloJ, Thank you for posting this! I had just about given up when I found your post. My Nexus 9 is alive again!! Thanks, Thanks, thanks!
    06-14-2016 11:30 AM
  5. primalrexgaming's Avatar
    oh THANK YOU!!!!!!! After all this time all i needed was to state where to flash it. EG: I put fastboot flash recovery system.img! when you actually have to put fastboot flash system system.img! OMG Thank You so much. The reason I am replying is because this worked and it was simple unlike flash tools! Also I have been looking for hours for a unbricking method as my Nexus5 was HARD BRICKED! OMG thnak you soooooo much!
    02-13-2017 03:02 AM

Similar Threads

  1. Why won't my data work on my lg g3
    By AC Question in forum Ask a Question
    Replies: 1
    Last Post: 06-15-2015, 06:20 PM
  2. Why won't my data work on my lg g3
    By AC Question in forum Ask a Question
    Replies: 1
    Last Post: 06-14-2015, 05:14 PM
  3. Why won't my data work on my lg g3
    By AC Question in forum Ask a Question
    Replies: 2
    Last Post: 06-14-2015, 04:25 PM
LINK TO POST COPIED TO CLIPBOARD