1. sonicmoon's Avatar
    I recently got the G1 and used my Gmail account online (via computer) to setup my contact list and then sync it to my G1. Now when I compose an SMS message, and begin typing the name of the person in my contact list, only some of the names that match will appear in the drop down auto-complete list.. but others that match don't show up at all. To compose SMS to them I have to use the Contacts>Scroll to contact>Select txt to mobile method.
    Any ideas why some of the contacts do not show up in the auto-complete list when composing an SMS and typing in a partial name in the To field?
    02-05-2010 05:16 AM
  2. sonicmoon's Avatar
    Yea, I figured this out about 20 minutes after I posted the Q. Numbers in contact list must be categorized as 'mobile' for them to show up when addressing an SMS message. Strange though, because some of the contacts I had listed with 'mobile' numbers yet when I logged into Gmail and checked the contacts there they were listed with 'home' numbers. I changed them to 'mobile' online, then resync'd via my G1. Tested SMS composing and all is good now.
    02-05-2010 04:50 PM
  3. prometheus's Avatar
    There is a setting in the messaging app to "show mobile only". If your contact info may be sloppy (from a google contact standpoint) and you have mobile numbers listed as work (which I do, 'cause they're mobile IS their work) then be sure to set this correctly.
    02-07-2010 01:24 PM
LINK TO POST COPIED TO CLIPBOARD