1. jtccjt's Avatar
    I'm having an issue with WhatsApp backing up to Google Drive on an Android device.

    It started when the phone was on a bad network with lots of dropped packets and interference. From there the backup stalled at 30%. I can't get it to continue, even on a solid network.

    I tried deleting the backup from Google Drive and starting it over in WhatsApp. WhatsApp thinks there is still a backup there. It shows the last successfully completed backup to be December 22nd, even though it doesn't exist in Google Drive anymore. Also, every time I try to start a backup, it jumps straight to 30% and never moves. I've also tried turning off the backup in Google Drive, which disables access to the needed service to do the backup, but it doesn't change anything.

    I've looked at the FAQ on the WhatsApp website and it doesn't have anything that helped.

    Is there a way to force WhatsApp to start a fresh backup?

    WhatsApp 2.17.427 running Android 7.0 on a Moto G 4 (4th gen)
    01-09-2018 01:03 PM
  2. Javier P's Avatar
    Welcome to the forums. I'd try this basic troubleshooting. Go to settings - apps - select WhatsApp - Force stop - storage - clear cache. Restart the phone and see if the problem persists.
    Mystyic likes this.
    01-09-2018 01:13 PM
  3. jtccjt's Avatar
    Thanks. I forgot to mention I tried that. I did it again just to see. It goes though and makes the local backup but when it starts to upload jumps straight to 30% and never moves. It shouldn't go to 30% since I've deleted the backup from Google Drive and tried to do a fresh one.
    01-09-2018 01:17 PM
  4. jtccjt's Avatar
    --Support Info--
    Debug info: +myphonenumber
    Description: 2.17.427
    Version: 2.17.427
    LC: US
    LG: en
    Context: settings/about
    Carrier: Claro
    Manufacturer: motorola
    Model: Moto G (4)
    OS: 7.0
    Socket Conn: UP
    Radio MCC-MNC: 740-01
    SIM MCC-MNC: 740-01
    Free Space Built-In: 2429849600 (2.26 GB)
    Free Space Removable: 2429849600 (2.26 GB)
    FAQ Results Returned: 10
    FAQ Results Read: 0
    Web session: token saved
    Smb count: 0
    Ent count: 0
    CCode: 593 989988219
    Target: release
    Distribution: play
    Product: athene_amz
    Device: athene
    Build: NPJ25.93-14.7
    Board: msm8952
    Kernel: 3.10.84-ge03508d-00031-g1c2d0e9 #1 SMP PREEMPT Wed Aug 30 11:59:19 CDT 2017
    Connection: W.I.F.I.
    Device ISO8601: 2018-01-08 11:34:08.088-0500
    Phone Type: G.S.M.
    Network Type: L.T.E.
    Missing Permissions: android.permission.INSTALL_SHORTCUT, android.permission.READ_PHONE_STATE, android.permission.WRITE_SETTINGS, com.sec.android.provider.badge.permission.READ, com.sec.android.provider.badge.permission.WRITE, com.htc.launcher.permission.READ_SETTINGS, com.htc.launcher.permission.UPDATE_SHORTCUT, com.sonyericsson.home.permission.BROADCAST_BADGE, com.sonymobile.home.permission.PROVIDER_INSERT_BADGE, com.huawei.android.launcher.permission.READ_SETTINGS, com.huawei.android.launcher.permission.WRITE_SETTINGS, com.huawei.android.launcher.permission.CHANGE_BADGE
    Architecture: armv7l
    Diagnostic Codes: TK-NS-1 FE-GDE FE-GDC FE-VIDC
    Network metered: 160:false
    Network restricted: 160:false
    Data roaming: false
    Tel roaming: false
    voip call side: 1
    voip call result: 2
    voip bind to any relay: Yes
    Video transcode: supported
    Payments: false
    01-09-2018 01:26 PM
  5. Javier P's Avatar
    Not sure what else to suggest. I imagine you already tried changing all the different options in the WhatsApp backup settings (never, when I tap, monthly ...).

    It seems something got stuck after that failed backup. If clearing cache didn't work the next step could be clearing data or uninstalling and installing back, and see if a fresh start solves that problem. A big price to pay, specially since you don't have a backup to restore your chats.

    Before that I'd try a workaround. If you don't have another Gmail account create one and change the backup settings in WhatsApp to use this new account. See if you can complete the backup this way. Not exactly a fix, but at least you could have a backup in case you need to start from scratch.
    01-09-2018 02:28 PM
  6. jtccjt's Avatar
    Thanks for the idea. I think it's fixed.

    I tried connecting another account and it started at 30%. Looking back, I didn't wait much time after I seen it went to 30% to see if it would continue. Strange that it started at that percentage though because it's impossible that it had anything loaded since there wasn't a backup there.

    After that, I restarted the phone and wiped the cache partition. i hadn't tried that yet.

    After restarting again, the backup went to 30% on the new account and started climbing. It finished.

    I then deleted the backup in my original account and started backing up. It started from 0% and seems to be uploading the entire backup.

    I think what I might do to assure myself it is a working backup is to look at the file system on android and save the local backup to my computer. Then uninstall the app, try to backup from what's in Google Drive. If the Google Drive backup doesn't work I'll try to restore the local backup.

    Here is some info on the local backup if someone in the future runs across this post.

    https://faq.whatsapp.com/en/android/20887921/

    I guess I could have just saved the local backup, uninstalled, and restored from the beginning but I didn't think about it until just now.


    Thanks for your help!
    Javier P likes this.
    01-10-2018 07:37 AM
  7. Javier P's Avatar
    Glad you managed to fix it and thanks for your detailed follow up! It'll be very helpful for other users with AC similar problem.
    01-10-2018 07:53 AM

Similar Threads

  1. Replies: 3
    Last Post: 01-10-2018, 04:25 PM
  2. Why won't my kingoroot finish?!?
    By vortex10 in forum Samsung Galaxy Note 3 Rooting, ROMs, & Hacks
    Replies: 1
    Last Post: 01-10-2018, 02:52 AM
  3. Replies: 2
    Last Post: 01-09-2018, 05:23 PM
  4. WhatsApp won't complete backup
    By Android Central Question in forum Ask a Question
    Replies: 2
    Last Post: 01-09-2018, 01:08 PM
  5. How to completely disable the vibration function on my pixel 2 phone
    By Mcaland in forum Google Pixel 2 & Pixel 2 XL
    Replies: 1
    Last Post: 01-09-2018, 05:51 AM
LINK TO POST COPIED TO CLIPBOARD