1. Himeko7's Avatar
    Windows 7 x64 Ent with latest updates, google USB Driver installed.
    My phone appears in device manager as an Android Device, but not under Portable Devices, and nothing in My Computer in windows explorer.



    I have tried in my laptop with the same windows etc, and it works fine there; in that case, the "Android Device" entry is missing, but the phone appears instead under Portable Devices and I can access it through windows explorer as if it was another drive.

    With the above said, I discard any issues with either the cable or the phone setup.

    Trying the following guide How to Use Android ADB Command Line Tool | All About Web & Mobile Application Development
    when i type "adb devices" it doesn't find the Nexus:



    Any ideas what could be going on? I've tried many things I found in these and other forums, enabling debug USB, switch MPT/PTP modes, using "Naked" drivers, to no avail.
    03-04-2013 12:50 AM
  2. Jaysus's Avatar
    You may have an issue with the device ID not registering through the USB driver, try to manually edit your winusb.inf" file to include your hardware ID.

    Try something like this: Fixing adb "Device not found" with Nexus 7/Android devices in Recovery Mode
    03-04-2013 07:45 AM
  3. Himeko7's Avatar
    The ID is there in the original Google USB driver:

    03-04-2013 07:56 AM
  4. greydarrah's Avatar
    Sounds like a driver conflict issue. Have you tried this:

    2. Drivers If you are on a Windows system (linux and mac need not bother with these): Universal Naked Driver 0.72.zip
    Warning: Uninstall any previous driver package's you may have installed and also manually remove drivers by attaching your phone and going to Windows device manager and right click the entry for your phone and select "Uninstall" on the next prompt make sure to select "Delete the driver software for this device" then hit OK and reboot before installing these drivers
    HUGE thanks to 1wayjonny at xda for these drivers and instructions!!

    It came from the unlock and root thread from here: http://forums.androidcentral.com/nex...lock-root.html
    swamiiyer likes this.
    03-04-2013 09:17 AM
  5. Aliandren's Avatar
    Are you using the nexus 4 cable that came with your phone, or some other micro-usb cable? On my N7 I have found that not all micro-usb to usb cables are created equally. All will charge, but not all will allow data view/transfer.

    Also, if you have device encryption on you will need to unlock your phone before you can connect.
    03-04-2013 10:22 AM
  6. Himeko7's Avatar
    Yup tried Naked drivers already as specified in the main post, same result.

    Using the original cable.

    I have encryption on, tried with the phone unlocked.
    03-04-2013 10:58 AM
  7. Himeko7's Avatar
    Fixed it! I'm not sure how though.. as I'm sure I tried the same before, and it would say the device cannot start..

    1. I uninstalled
    2. Reinstalled with Naked drivers
    3. Opened device properties, update driver
    4. Pointed to naked driver folder
    5. Picked "Let me pick from ..."
    6. Chose "MTP USB Device", from "Standard MTP Device" category



    I don't know why this worked now, I tried this before and it would take a while..20-30 seconds and then say the device could not start, but now it works somehow.

    03-04-2013 11:19 AM
  8. Melter Martin's Avatar
    I think we had the same problem..
    It is happen when I install my nexus 4 driver to my pc,
    turning off usb debugging mode should do the trick~
    06-12-2013 09:17 AM
  9. Jtmorris's Avatar
    I FOUND A FIX for the Nexus 4 not connecting to a PC via usp as MTP:

    My first Nexus 4 was not an issue at all - it just worked.
    I got a warranty replacement N4 and it would not connect as MTP.
    Support was idiotic and not helpful and sent me a different N4.
    Upon receiving that one, it also wouldn't connect.

    Here is what fixed it (on Windows 7 - it may work on Windows 8):

    1. Plug phone in and let it install drivers as usual
    2. If it hasn't worked, open device manager
    3. Find your Android device and right click on the ADB device and choose un-install
    4. The box that pops up, check the box to un-install drivers.
    5. Unplug the phone and plug it back in. It will reload drivers. (It will now show up in device manager under portable devices rather than Android)

    Now you should be able to access your phone through file manager!

    I really hope this helps many of you!
    08-30-2013 10:53 AM
  10. Jayadev Swain's Avatar
    I had a Nexus 4 with its cable. And then I tried to connect another Nexus 4 with the same cable but my PC wasn't able to recognize the new drivers. So, I tried it with the cable which came with the new Nexus 4 and it connected.

    No idea why this should happen but it worked!
    09-17-2013 06:22 AM
  11. andre21051990's Avatar
    cara obrigado pelo seu comentario que vc coloco . aparecia como o meu {Fixo} Nexus 4 no aparece no meu computador como dispositivo de armazenamento.. gradece

    dude thanks for your comment that u put. appeared as my Fixed {4} Nexus does not appear on my computer as a storage device ..
    10-08-2013 06:00 AM
  12. ronaldlantigua's Avatar
    This worked for me. Thanks
    10-28-2013 11:08 AM
  13. Jean-Patrick Leger's Avatar
    Hi there.

    So weird that i created an account just to reply about that thread :

    I use to devel with both Nexus 4 and 7, few weeks ago, my N7 started to not be detected as a MTP device anymore. I tried the driver update as mentioned above with no improvment. I tried with the Original N7 USB cable : WORKING AT FIRST ATTEMPT. So i got rid of the BBerry USB cable i was using since...

    thank you all for your help.

    JP.
    11-13-2013 05:15 AM
  14. brian johnston's Avatar
    This is what worked for me.
    1.Uninstall nexus device from device manager
    2.Unplug device and restart computer
    3.Download the Microsoft media feature pack for your version of windows (Microsoft media feature pack windows 8.1 as an example)
    4.Install the feature pack update
    5.Reconnect your device
    All done at lease it was for me.
    hope this helps others because i was two days looking for a fix.
    11-22-2013 06:24 PM
  15. dan1431's Avatar
    I used a program called USBDeview, removed all USB drivers listed as belonging to Google or LG.

    Restarted my CPU, plugged in my N4 and viola it recognized my N4 as an MTP device and I was able see it as a portable device.

    Dan
    11-23-2013 07:06 AM
  16. Mikey Young's Avatar
    Are you using the nexus 4 cable that came with your phone, or some other micro-usb cable? On my N7 I have found that not all micro-usb to usb cables are created equally. All will charge, but not all will allow data view/transfer.
    Oh dear I was desperately searching online... researching drivers, cursing windows 8 etc. It was the short spare cable I got with my Qi charger that I thought would be perfect for my laptop I was using. Swapped it out and problem solved thank you. Love a simple solution.
    11-26-2013 11:50 PM
  17. spaceodd's Avatar
    Yes this worked, thanks! (did have to check the delete files box)
    02-21-2014 11:43 AM
  18. Siddhantj's Avatar
    Hey Morris, Thanks a lot for your info. to connect my nexus 4 to my pc.. did the same and yes it was resolved, pretty simple.
    08-27-2014 02:25 AM
  19. Saptarshi Majumdar's Avatar
    its working after unistalling the ADB drivers...thanks a ton
    09-21-2014 07:12 AM
  20. Victoras Marcu's Avatar
    Dan, how exactly have you restarted your CPU?
    08-01-2015 10:44 AM
  21. diggifree's Avatar
    worked for me as well. Android 6.01 CyanogenMod DAragon Fruit (4)
    06-29-2016 06:44 AM

Similar Threads

  1. phone won't show up on My Computer when plugged in via USB
    By azgalorRC in forum Sprint Galaxy Nexus
    Replies: 82
    Last Post: 09-17-2017, 11:49 AM
  2. Nexus 4 not showing up in 'My Devices' List - How to Fix
    By leroy_sunset in forum Google Nexus 4
    Replies: 3
    Last Post: 04-13-2016, 02:05 PM
  3. Nexus 10 not showing up in Google Play store "Owned Devices" list
    By Vonbane in forum Google Nexus 10 Tablet
    Replies: 7
    Last Post: 01-24-2015, 02:15 PM
  4. Email account doesn't show up in "My Accounts"
    By Phaang in forum Android Apps
    Replies: 0
    Last Post: 08-20-2010, 02:19 PM
  5. WEIRD contact issue-- doesn't show up in messaging?
    By ali.fazal in forum Motorola Droid
    Replies: 4
    Last Post: 01-31-2010, 10:13 AM
LINK TO POST COPIED TO CLIPBOARD