10-05-2018 06:29 PM
43 12
tools
  1. Iceman0803's Avatar
    I'm using android 8.1 and for the life of me I can't get my phone to ring on incoming calls. I have a tone set and the volume is maxed but no ring tone plays when a call is received. When I look at the notification channels for incoming calls on the phone app the notification sound is set to "none" and the option is greyed out so it can't be changed. Has anyone seen this or know how to change it?
    Attached Thumbnails Can't get phone to ring on incoming calls-679.jpg  
    BBook1999 likes this.
    11-05-2017 01:31 AM
  2. N4Newbie's Avatar
    Please open the Phone app, tap the three-dot menu at top-right, then Settings, then Sounds and vibration.

    What is the phone ringtone set to?
    11-05-2017 06:05 AM
  3. N4Newbie's Avatar
    By the way, you say you are on Oreo 8.1 and a Pixel 2 phone (which one? XL?).

    I am looking at a Pixel 2 XL with 8.1 and I simply cannot find the exact screen you pictured above. How did you get to it?
    11-05-2017 06:11 AM
  4. BBook1999's Avatar
    I have the same issue on my Pixel 2 (smaller one) running 8.0. I can call my husband's Pixel 2 and his phone rings, but I cannot receive calls. My phone doesn't vibrate, there's no message until after the phone call has been aborted. Then I get a message about a missed call.
    11-05-2017 06:38 AM
  5. N4Newbie's Avatar
    I have the same issue on my Pixel 2 (smaller one) running 8.0. I can call my husband's Pixel 2 and his phone rings, but I cannot receive calls. My phone doesn't vibrate, there's no message until after the phone call has been aborted. Then I get a message about a missed call.
    Unlikely, probably, but open the Phone app, tap the three-dot menu at top right, tap Settings, tap Call blocking. Make certain that your husband's phone number isn't listed there.

    Another possibility - main Settings -> Apps & notifications -> Advanced -> Default apps -> Phone app. It should be set to "Phone (System)"
    11-05-2017 07:18 AM
  6. Iceman0803's Avatar
    Please open the Phone app, tap the three-dot menu at top-right, then Settings, then Sounds and vibration.

    What is the phone ringtone set to?
    It's actually set to a ringtone that I made.

    By the way, you say you are on Oreo 8.1 and a Pixel 2 phone (which one? XL?).

    I am looking at a Pixel 2 XL with 8.1 and I simply cannot find the exact screen you pictured above. How did you get to it?
    I'm on a Pixel 2 XL. To get to that screen you go to Settings > Apps & Notifications > Notifications > Phone > App notifications > Incoming calls

    I have the same issue on my Pixel 2 (smaller one) running 8.0. I can call my husband's Pixel 2 and his phone rings, but I cannot receive calls. My phone doesn't vibrate, there's no message until after the phone call has been aborted. Then I get a message about a missed call.
    That's the exact behavior I get. Rebooting the phone seems to have fixed it, at least for now...
    11-05-2017 07:20 AM
  7. N4Newbie's Avatar
    It's actually set to a ringtone that I made.



    I'm on a Pixel 2 XL. To get to that screen you go to Settings > Apps & Notifications > Notifications > Phone > App notifications > Incoming calls
    Okay; my screen for incoming call notifications looks exactly the same as yours (with the exception that I also have a toggle for "Blink light" - probably because I have that enabled elsewhere). And, yes, my phone does ring.

    Have you tested with one of the default ringtones?

    On your previous phone, did you ever install a third-party phone app? If so, some of your settings may have gotten screwed up when you set up your new Pixel by importing from your previous phone. Can you check the default phone app as I described in my previous post?
    11-05-2017 07:26 AM
  8. BBook1999's Avatar
    Thanks, N4Newbie. All of those were set like you suggested. After an hour of fiddling with any setting I could find, rebooting my phone, and my husband rebooting his, I can hear it ring when he calls. Oddly, the screenshot in the OP is still exactly what mine looks like. Weird. But as long as I'm getting phone calls I can hear, I am ok.
    11-05-2017 09:08 AM
  9. Ca_lvn's Avatar
    Regular pixel 2 My Phone app has been buggy once in awhile but never missed a call
    Seems to have improved lately
    11-05-2017 09:09 AM
  10. Iceman0803's Avatar
    Okay; my screen for incoming call notifications looks exactly the same as yours (with the exception that I also have a toggle for "Blink light" - probably because I have that enabled elsewhere). And, yes, my phone does ring.

    Have you tested with one of the default ringtones?

    On your previous phone, did you ever install a third-party phone app? If so, some of your settings may have gotten screwed up when you set up your new Pixel by importing from your previous phone. Can you check the default phone app as I described in my previous post?
    My previous device was the first gen Pixel XL. I never used any third party dialers or anything like that. I honestly never thought to test other ringtones however, rebooting the phone seems to have fixed the issue. But, I'm still at a loss as to why this happened in the first place as I never changed any settings to either cause or fix the issue. I'm hoping that this was just a fluke. Unfortunately I won't know for sure unless I miss another call.
    11-05-2017 05:48 PM
  11. anon(9681881)'s Avatar
    "It's actually set to a ringtone that I made. "

    My guess is that is your problem. It might be a ringtone that the phone won't recognize or play for some reason. Try setting it to a normal ring tone.
    11-05-2017 05:56 PM
  12. Timcredible's Avatar
    apparently, the non-bluetooth ringtone is tied together with bluetooth ringtone volume by default (if you have your phone on vibrate, you don't get a bluetooth ringtone). to change, menu->system->developer options->disable 'enable in-band ringing', reboot phone. if you don't have 'developer options', tap 'build number' 7 times
    Ca_lvn and GSDer like this.
    01-22-2018 08:02 AM
  13. Terrell Carey's Avatar
    apparently, the non-bluetooth ringtone is tied together with bluetooth ringtone volume by default (if you have your phone on vibrate, you don't get a bluetooth ringtone). to change, menu->system->developer options->disable 'enable in-band ringing', reboot phone. if you don't have 'developer options', tap 'build number' 7 times

    Trying this out now. Awesome if it works. I've had to reboot my phone multiple times over the last month or two. it has also been difficult to answer calls at times when connected to my cars Bluetooth since the last update so hopefully this will fix both issues.
    01-31-2018 08:44 AM
  14. RichAM's Avatar
    I'm using android 8.1 and for the life of me I can't get my phone to ring on incoming calls. I have a tone set and the volume is maxed but no ring tone plays when a call is received. When I look at the notification channels for incoming calls on the phone app the notification sound is set to "none" and the option is greyed out so it can't be changed. Has anyone seen this or know how to change it?
    Have this same issue on my phone and my wife's. Both are Pixel XL (originaly, not Pixel 2XL) running Android 8.1.

    After a restart, phone rings fine for a while. Then, after a while (half a day, a day..) it won't ring at all. Do Not Disturb is not enabled nor do any automatic DND settings exist. A custom ringtone is selected, and changing the ringtone won't fix it. Ring volume (and Media volume) is definitely at 100%.

    Only solution is to restart and then wait to restart again once it stops working again.

    Tried the Bluetooth In-Band Ringing fix via Developer Tools - didn't help.
    02-05-2018 10:57 AM
  15. DonnaJHart's Avatar
    Has anyone figured this out yet? I seem to be having the same issue. It seems like it happened after the last update. My phone will work like normal as far as the ringer is concerned for a few hours or up to half a day then all of a sudden everything seems like it is on silent. I have checked every setting, I have looked all over the Internet and tried every single suggestion that has been made. Nothing has fixed it, the only way to make it ring again is to restart it. And I'm getting tired of restarting my phone multiple times a day. It doesn't seem to be anything specific that triggers it, and my husband isn't having any of the issues I'm having. (We both have the pixel XL running Android 8.1)
    syvar likes this.
    02-05-2018 03:43 PM
  16. Thomas Tommy's Avatar
    I'm using android 8.1 and for the life of me I can't get my phone to ring on incoming calls. I have a tone set and the volume is maxed but no ring tone plays when a call is received. When I look at the notification channels for incoming calls on the phone app the notification sound is set to "none" and the option is greyed out so it can't be changed. Has anyone seen this or know how to change it?
    I have the same exact issue as the OP on my Pixel 2 XL with v8.1.0 for the last few weeks. I've tried rebooting multiple times. My Incoming Calls notification screen looks the same. The Sound says None and is grayed out.

    What the heck!? I'm missing many calls because the phone doesn't even vibrate until the caller hangs up. A pretty serious bug if you ask me.

    This is my first smart phone and wow what sour feeling to spend this much money on a phone that doesn't even make a noise when it rings.
    02-19-2018 11:39 AM
  17. TraderGary's Avatar
    Is there a possibility you might have accidentally turned on the "Do Not Disturb" icon?
    02-19-2018 01:06 PM
  18. LB LB's Avatar
    I've found this issue too, so I've written to Google about this:
    https://issuetracker.google.com/issues/73803081

    Sadly the issue occurs on my mom's phone, so I couldn't grab the bug report right after it has occurred.
    Please, if anyone here has the issue, report about it with a bug report file on this issue tracker website.
    Try to tell Google as much information as possible about the issue.
    02-23-2018 09:03 AM
  19. GSDer's Avatar
    Has anyone figured this out yet?
    I have the same exact issue as the OP
    Could you try rebooting into Safe mode and see if the problem still occurs?
    02-23-2018 09:42 AM
  20. DMMarlowe's Avatar
    I'm having the same issue on my pixel using Oreo. Sometimes a call will ring through and sometimes it goes straight to voicemail. This is a relatively new problem. Up until recently all calls rang through. I did notice the under set ringtone it said unroute to voicemail on one that did not ring through. I switched it to route to voicemail and it worked the next time so we'll see if that was the trick.
    03-03-2018 11:26 PM
  21. Knightmayre90's Avatar
    I may be way off but hit the volume up and check the bell icon shows at the end of the volume slider graphic and not the vibrate icon. it could be a simple as that for some. if it is, hit the icon to toggle to sound.
    03-04-2018 08:43 AM
  22. daweasels's Avatar
    I have some additional information on this issue. I just got a new Pixel 2 XL. IT DOES NOT RING! Does not matter whether I use stock or custom ringtone BUT if I go to contacts and assign a custom ringtone to a user...it rings perfectly. I'm going to check out if the Samsung S8 XL has a ring problem and if not, I am returning my phone to the vendor as there is obviously no desire to address the issue by Google. No word. No comment. No update on an issue that was posted in NOVEMBER. Better to deal with the bloat than a phone that won't ring. Google..this is kinda a MAJOR issue to ignore.
    03-11-2018 01:25 PM
  23. anon(5506951)'s Avatar
    I've had the same issue on my 6P with 8.1. The phone wouldn't ring, nor would I hear notification sounds. I did a hard reset through Recovery and it's working again.
    03-11-2018 09:58 PM
  24. Raeanne Steele's Avatar
    There is a "Do Not Disturb" function on the Pixel two that turns off the sound of incoming calls. I think I accidentally turned mine on with the Active Edge squeeze function. Here are the directions for getting your sound back:
    https://support.google.com/pixelphon.../6111295?hl=en

    Good luck!
    03-12-2018 01:03 PM
  25. GSDer's Avatar
    I think I accidentally turned mine on with the Active Edge squeeze function.
    I knew that you could silence an incoming call using the squeeze feature (I use that frequently) but I didn't think you could turn on DND by simply squeezing.
    03-12-2018 05:03 PM
43 12

Similar Threads

  1. phone calls only work with headphones
    By Android Central Question in forum Ask a Question
    Replies: 1
    Last Post: 11-05-2017, 01:51 AM
  2. SIM applications cannot be reached on Samsung S8+
    By Android Central Question in forum Ask a Question
    Replies: 2
    Last Post: 11-05-2017, 01:51 AM
  3. Lg3 fades in and out, jumps to other pages
    By Android Central Question in forum Ask a Question
    Replies: 1
    Last Post: 11-05-2017, 12:38 AM
  4. My phone turned off and now almost everything is gone?
    By Android Central Question in forum Ask a Question
    Replies: 1
    Last Post: 11-05-2017, 12:35 AM
  5. Replies: 1
    Last Post: 11-05-2017, 12:02 AM
LINK TO POST COPIED TO CLIPBOARD