1. bgpmpn191's Avatar
    This is random as I just started to encounter this problem.

    At first when I would add a new contact it would save to my contacts list & being that I have my google account connected it would save it there as well.

    Now for some odd reason every time I try to add a new contact to my contacts list it doesn't save it, but it does save to my google account (after it does its sync process)

    Why is that? How do I fix this problem?

    I really don't want to do a factory reset because of this issue.

    I would appreciate any help.

    Thanks in advance!
    09-25-2013 04:14 AM
  2. Gator352's Avatar
    I know you have Google synced, but maybe check to see if you actually changed it to save to your sim or another account as well?
    09-25-2013 05:16 AM
  3. bgpmpn191's Avatar
    Update:

    For anyone else who experiences this problem...

    1. I went ahead & deleted my google account & all my contacts list
    2. I added my google account again
    3. I synced my google account (like you would do when you first setup your phone)

    & voil, problem solved! When entering a new contact it would save in my contacts list!

    Btw, I'm still curious as to what the problem was. Why did it do that? How come it wouldn't save in my contacts list when it said saved, but show up in my google account? Also, I can't recall, but if I were to send a text it would pull the persons name up even though they didn't show in my contacts list.

    Glad I didn't have to reset my phone as I was getting really frustrated!!
    09-25-2013 02:58 PM
  4. Owenz Arido's Avatar
    Your contacts were being saved to your google account instead of your phone. The reason you could't find them was because you had your "Save new contact" option to "Phone", and you didn't have "Google" ticked on the drop-down Phonebook source menu on the top left of the People app (Two swipes right from Dial screen). All you had to do was tick the little box next to "Google" (It should have your email address below it), and you would have been fine. Too bad you had to delete everything
    07-19-2014 01:49 PM
  5. Anwar Alayash's Avatar
    thank you very much , my problem solved because of you
    08-03-2014 04:14 AM
  6. afreedman's Avatar
    New contacts saved but do not remain in contact list
    07-29-2016 11:11 AM
  7. anon(632115)'s Avatar
    New contacts saved but do not remain in contact list
    Please READ the thread, the answer is there.
    07-29-2016 11:18 AM
  8. katemn99's Avatar
    I have a Samsung S7. I read:
    Your contacts were being saved to your google account instead of your phone. The reason you could't find them was because you had your "Save new contact" option to "Phone", and you didn't have "Google" ticked on the drop-down Phonebook source menu on the top left of the People app (Two swipes right from Dial screen). All you had to do was tick the little box next to "Google" (It should have your email address below it), and you would have been fine. Too bad you had to delete everything

    BUT I don't think this applies to the S7. After saving the new contact .. it does not show up in "Contact". But if I search for contact .. it will show up! It says"Connected via Google" .. Group: "My Contacts" when I "view" it.

    Please help me .. a "non techie" grandmother of 10! Thanking you in advance!
    08-06-2016 06:04 PM
  9. Gemini_Enigma's Avatar
    I'm having the same problem with my LG V10. I set the contacts to save to my google account but it still doesn't save to the contact list. The number may be in my phone under the text message threads but still not in the contacts. I have synced my phone several times since I've saved the last contact I inputted but again, not found in the the contact list. Now I'm having bootloop issues with the phone and I cant find all my contacts via gmail and that is SUPER wack especially since I have over 400 contacts and have no idea which ones are missing until I look for one that's not there anymore.
    10-27-2016 08:56 AM
  10. Marty Hultgren's Avatar
    I've read every thing above and nothing works. I've got an S6 and nothing I do saves to the phone. Any other ideas are most welcome.
    11-24-2016 03:02 PM
  11. prismaustin's Avatar
    I've read every thing above and nothing works. I've got an S6 and nothing I do saves to the phone. Any other ideas are most welcome.
    This contact that you saved - is there a phone number attached to it? If not, then your settings on your phone might only be set to show contacts with phone numbers. To fix this:

    1) Open Contacts
    2) Click "More"
    3) Click "Settings"
    4) Under Phone Settings, there should be an option to turn on/off "Contacts with numbers". Switch it to off, so that you show contacts with AND without phone numbers.
    5) Press the back button and search for the contact you were missing again. Is it there?

    Hope this helps
    luvfamilylife likes this.
    03-30-2017 10:14 AM
  12. Hotshot123's Avatar
    Contact added to phone isn't updating my PC google contacts list.

    Galaxy S6 with recent Nougat upgrade. Going to contact settings you show above, ther is no choice "Phone Settings", there should be an option to turn on/off "Contacts with numbers"
    06-14-2017 10:06 AM
  13. djdannyby50's Avatar
    Had this same issue on S7, the option to turn on/off "Contacts with numbers" was the solution! When entering a contact i'd typed the number into the next available field after name, not realising that it was an ADDRESS field, so the contact effectively had no number, just a strange numeric address! Toggling this setting worked and contact was corrected.
    10-10-2018 06:46 AM
  14. Monivee618's Avatar
    Thank you! This just fixed my S7. I didn't realize the line after name was address. I was putting the phone number in the address bar. I unchecked "show only contacts with numbers" and they appeared. Then I put the numbers in the correct place. Pretty silly of them to do it that way and pretty silly of me not to notice. =)
    02-03-2019 05:46 PM

Similar Threads

  1. Replies: 7
    Last Post: 09-27-2013, 10:39 AM
  2. Replies: 2
    Last Post: 09-25-2013, 09:58 PM
  3. Talking Clock Pro - new advanced scheduler
    By abuko in forum Android Apps
    Replies: 0
    Last Post: 09-25-2013, 02:31 AM
  4. No longer applicable
    By knnbccbtan in forum Software Development and Hacking
    Replies: 0
    Last Post: 09-25-2013, 12:47 AM
LINK TO POST COPIED TO CLIPBOARD