1. devriesj's Avatar
    Hi,

    I have a hydro vibe by kyocera. Android 4.3. The phone will not format my 64gb card but can read my 32gb card with out formatting. I can format the card to fat32 on the pc and have 59.9gb free. but phone says "sd card is blank or has unsupported filesystem" even with fat32. I know its not the card as card has worked in 3 other android's and pc. 64gb card as worked on 2.2, 4.0, 4.2. Also this is the first time I have used android 4.3. Could this be an error with 4.3?

    Don't want to return this phone. Got it for its water resistant's.

    Virgin Mobile if it helps. Could this be fixed with root?

    Thanks for the help. May just get an LG Optimus F3 again.
    09-11-2014 10:52 PM
  2. B. Diddy's Avatar
    The specs suggest that it only supports cards up to 32 GB (SDHC). Kyocera Hydro VIBE specs

    http://www.kyoceramobile.com/hydro-v..._Mobile_en.pdf
    09-11-2014 11:02 PM
  3. devriesj's Avatar
    Hydro Vibe (4.3)
    Ok so no "workaround" like other phones. I now know why, I never herd for this brand before. OK thanks. Back to the store with this phone.

    Optimus v (2.2stock, custom rom 4.2) that I had for the past 3 years, worked just fine with the 64gb card. All all though it wasn't "supposed". I would put the card in and pass format and be done. Now when I put the card in the Hydro and pass format, It's like its try's to format, but the "blank sd card" error comes right back.

    I lost the Optimus v, so I get the Optimus F3 (4.1). So 64gb "not supposed", but the card just need to be formatted then it just worked right away.

    Installed a custom recovery, then try system update. the optimus f3 would not boot. Was able to return the phone. Then I see the hydro vibe and say, why not try it, for its water resistance. This ones going back to the store to if there no "workaround"!

    Every android I use give me the same "blank sd card" error. All I have to do is pass the error and than pass format, but the Hydro(4.3) this shows the "blank sd card" after trying to format.
    Also the 64gb cards worked in my dads Tab 4 (4.2) after the format (same "blank sd card" error, as with all androids)

    I think its an 4.3 error. I have not seen an android that "officially supports" the 64gb cards.
    09-12-2014 06:08 AM

Similar Threads

  1. WTS: OnePlus One 64GB Sandstone
    By rob damiani in forum Marketplace Archive
    Replies: 5
    Last Post: 09-14-2014, 10:21 PM
  2. My Galaxy S5 is rooted - should I accept an OTA?
    By gabrielxavila in forum Samsung Galaxy S5
    Replies: 6
    Last Post: 09-13-2014, 04:22 PM
  3. Sd card items not showing up
    By Mark Pacana in forum Samsung Galaxy S5
    Replies: 7
    Last Post: 09-13-2014, 11:34 AM
  4. My galaxy S3 won't turn on?
    By BigDaddyStaCcs12 in forum Ask a Question
    Replies: 3
    Last Post: 09-13-2014, 03:32 AM
  5. Android Central Android App
    By peteramollica in forum Ask a Question
    Replies: 5
    Last Post: 09-12-2014, 10:22 AM
LINK TO POST COPIED TO CLIPBOARD