1. Cattich's Avatar
    I bought an unlocked t mobile samsung s3 4g lte and it was working... then a few months later it says no mobile network available. I reboot my device and nothing. I checked solutions online and tried the *#06# and my IMEI is null/null. I went to mobile networks and it says to insert USIM card to access networks when there is already a sim card there... I tried the holding the power & home button thing and still nothing.... HELP ME!!!!
    09-19-2015 10:23 AM
  2. Almeuit's Avatar
    Did you buy it used? It sounds like the IMEI was reported / blacklisted.
    09-21-2015 02:51 PM

Similar Threads

  1. Chrome and Data Saver
    By KPMcClave in forum LG G4
    Replies: 9
    Last Post: 09-21-2015, 09:19 PM
  2. how to run google play app on my one plus 1 mobile phone
    By winnie marshellyn in forum Ask a Question
    Replies: 1
    Last Post: 09-19-2015, 10:51 AM
  3. Replies: 0
    Last Post: 09-19-2015, 10:22 AM
  4. Rare problem with my G S5 and Lollipop
    By snappyapple632 in forum Legacy Android & Other OS's
    Replies: 0
    Last Post: 09-19-2015, 09:58 AM
  5. [Free][Game] Rage Quit Racer single and multiplayer
    By pocketreers in forum Android Games
    Replies: 0
    Last Post: 09-19-2015, 09:10 AM
LINK TO POST COPIED TO CLIPBOARD