1. Soy Anonimo's Avatar
    My call log is empty and I run out of ideas as to why or what to do about it.

    I even did a factory reset.

    My phone is a Blu Studio One, Android 5.1. I'm using the stock Phone app. Other log apps don't see a log either (i.e. "Call Log Monitor").

    03-29-2017 11:59 AM
  2. ManiacJoe's Avatar
    I would expect the factory reset to empty the call log and any other database files you have.

    How many incoming and outgoing calls are you expecting to see?

    Does your call log app have options to "purge older entries" or the like?
    03-29-2017 03:22 PM
  3. Soy Anonimo's Avatar
    I expected to see at least a few. I tried calling my own number from a different phone. The phone rings, I get a lost call notification, but the call doesn't show up in the call log.

    Fairly recently, I got and OTA firmware update. I don't remember if I ever checked the log after the update. I wonder if maybe there's something wrong with that firmware. I haven't found anything about it anywhere on the internet (BLU_S0110UU_V11_GENERIC 16-01-2017 01:01).
    03-29-2017 04:46 PM
  4. Soy Anonimo's Avatar
    I'm sorry ManiacJoe, I didn't answer your second question. I can't find any "purge older entries", I assumed the option would appear only if there actually were older entries.
    03-29-2017 04:56 PM
  5. Soy Anonimo's Avatar
    OK. Googling around I found that the table "calls" in the "contacts2.db" database at "/data/data/com.android.providers.contacts/databases/" should contain the call log. It's empty, not a single row...
    03-29-2017 06:12 PM
  6. ManiacJoe's Avatar
    That you can get to and see that database suggests that your phone is rooted.

    Given that the DB is empty, it means that the call logs are getting displayed correctly, but the actual writing to the db is not working correctly.
    I have no idea how to fix that.
    Soy Anonimo likes this.
    03-29-2017 09:32 PM
  7. Soy Anonimo's Avatar
    Yes, I rooted it just to see that database. I came to the same conclusion, that the db is not been written correctly. I'll see if I can roll back the update, I think the problem is with the new firmware. Thanks, ManiacJoe.
    03-30-2017 08:23 AM
  8. Soy Anonimo's Avatar
    Well, I found an older firmware and figured how to install it. Everything works fine again. So, don't update your Blu Studio One to V11! :-)
    03-30-2017 01:06 PM
  9. ManiacJoe's Avatar
    Thanks for the follow up!

    It might be good to forward your findings to Google and your carrier and your phone's maker to see if someone can fix the bug.
    03-30-2017 07:09 PM

Similar Threads

  1. What do you think of Samsung Dex?
    By EMGSM in forum Samsung DeX
    Replies: 21
    Last Post: 03-18-2020, 02:49 PM
  2. No Samsung Logo on the front - No Verizon Logo on the back?
    By felloffthetruck in forum Samsung Galaxy S8 & S8+
    Replies: 23
    Last Post: 03-30-2017, 10:48 PM
  3. Replies: 1
    Last Post: 03-29-2017, 06:06 PM
  4. where can i find go on android apps
    By AC Question in forum Ask a Question
    Replies: 1
    Last Post: 03-29-2017, 03:55 PM
  5. What is tergiversation?
    By AC Question in forum Ask a Question
    Replies: 1
    Last Post: 03-29-2017, 12:12 PM